Ubuntu 7.04 freezes on splash screen after install to new hard drive-HELP!!!

Asked by n3m3sis on 2007-09-02

I have tried now for over a week to get a fresh install of ubuntu 7.04 to boot on my hard drive. I initially used a 10.1 IBM hdd which was my old windows xp system drive. I completely raw partitioned it and installed feisty from the live cd and the installation went without a hitch, until the reboot!. the pc gets to the splash screen and then just freeezes. I get the same with recovery boot.... no error message it just stops. I have tried installing server, text mode, and command line and all of them just freeze shortly after saying its loading.
In desperation I went out and bought a new 160gb maxtor drive and installed feisty to that but with the same result, it just hangs at the splash screen never to move again. The thing is, everythig works great from the cd version(and the dvd version, but it just wont work when installed to the hard drive. I am at my wits end as I have already removed windows xp from my pc and dont want to go back to it. Please can someone help me to get 7.04 running on my hard drive as I have invested both time and money in this and I really want it to work, but from my hard drive,not the cd. I tried debug mode but it still just hangs, either at the splash screen or in recovery mode, both without an error message. the thing is, it installs to the drive great, with no errors, it just wont start up properly on the hdd. Help! Please!

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-11-06
Last reply:
2007-11-21

This question was reopened

tiger69 (andrei-lupu) said : #1

check out the Bios
the boot sequence should include, after the cd/dvd, the hard disk
after rebooting, the system is supposed to load from hard disk,but
if the hard disk is not in the boot sequence in BIOS ,it will fail

n3m3sis (nem2killu2) said : #2

Thanks for the reply tiger69, however that is not the problem.
Update: I have managed to now get some blue text below the ubuntu splash screen after editing the main kernel startup up line (removed ro, quiet) and also added irqpoll pci=noacpi nolapic acpi=off to the same line.
removed quiet also from the line below the initrd /boot/initrd.img 2.6.20-15-generic
I now get the splash screen with a little bit more of the orange progress bar showing and as I said some blue text. It says that it has loaded drivers etc, but it then hangs after it says mounting root filesystem.....?
Any ideas?

Francisco Athens (freelikegnu) said : #3

it may be checking the filesystems of other partitions and disks. Remove "splash" from the kernel startup line to get more detailed output.

n3m3sis (nem2killu2) said : #4

Eureka! I have solved the problem ubuntu is no installed on my new hard drive.
I think the developers need to look at this problem though as it was only after trying to
use a PC Linux live cd that I got a proper pointer to the problem.
Unlike the Ubuntu 7.04 Live Cd which loads and runs flawlessly on my pc, the PC Linux one would not load up in any mode... it just crashed after picking any loadup option.
When I used the v switch I say a line that said "nforce2 not in 100% native mode" and this was the clue I needed to try adn solve the install and bootup problem.
My problem with the Ubuntu install stemmed from the fact that I wasnt getting an undestandable error message from Ubuntu when it kept on locking up on boot. When the splash and quiet was removed from the kernel boot line (or recovery mode was used) the only message I got was "hpt37xxx has no clock data saved from bios", which told me nothing and besides it then went on for about five lines after that, all about PIO modes for various hard drives. PC Linux's "nforce2 not in 100% native mode" was more informative to me as it told me that perhaps it was something not native to the NForce2 that was the problem and so it proved. I took both sata drives and plugged them into the motherboard, and the one remaining sata drive plugged into my HighPoint 1540 4port Sata interface card, I removed (I didnt remove the card although that would have been the next step.) The PC Linux live cd booted up fine after that with no errors so, I reinstalled Ubuntu with the drive not connected to the Sata interface card, and yes you guessed it, when I booted up from the hard drive it worked first time and pretty soon the login screen was there!!! :)
So my options now are to see if there is a fix for the incompatability with the HighPoint 1540 4 port Sata interface card and apply it, if not then it will have to be a new motherboard with more "native" sata ports as I need the use of that drive and ubuntu will not recognize it even if I hot plug it in after boot-up.

Many thanks to all who tried to solve my problem and especially to Mike Ocran. If he didnt give me the PC Linux live cd to try I dont know when if ever, I would have got Ubuntu to run from my hard drive. Future Ubuntu releases could learn from this.... the PC Linux Live CD wouldnt run with the problem it saw with the interface card (kudos to Ubuntu for being able to bypas that problem and load normally), however its reporting of a problem was clear enough to indicate where the problem might lie, unlike Ubuntu's "hpt37xxx has no clock data saved from bios" which told me nothing. Perhaps if the Ubuntu Live CD had not loaded up on my pc but had given me the message the PC Linux one did, I would have got the solution much sooner.

n3m3sis (nem2killu2) said : #5

By the way does anyone know of a fix for the Highpoint add-on 1540 Rocket 4 port Sata card?

n3m3sis (nem2killu2) said : #6

Does anyone know of a fix for the Highpoint add-on 1540 Rocket 4 port Sata card?
I have still not received a reply to the above question and although I have now upgraded to the beta Gutsy, the problem
still remains, ie I cannot access the drive connected to the above interface card. I had hoped that this issue would be
fixed in gutsy but so far it has not been. If someone has a fix for this please let me know as it will mean me having to buy a new motherboard otherwise. I have tried dmraid but it reports no raid sets which is true, as I only have one 200Gb drive attached to the card.
Please can someone help with this

Tia

n3m3sis (nem2killu2) said : #7

I would like to link this bug to this one...... https://bugs.launchpad.net/ubuntu/+source/hal/+bug/159397
as frankly they are both related. I still cannot boot up my system with any drive connected to ports 1 or 2 of my Highpoint 1540 rocket raid sata interface card. Its really getting me down as I have a lot of stuff I want to access on the 200gb drive that is normally attached to that interface card.
My only way to access it at present is to boot up the livecd where it works perfectly well. There must be some reason for this and I think, in the bug report that I have posted above there might be an answer.

Please help someone.........

n3m3sis (nem2killu2) said : #8

Alan Pope, I met you at the Gutsy launch party and explained the problem to you. Do you have any further thoughts, given the info I have put in the bug report (link above) 159397.

n3m3sis (nem2killu2) said : #9

Ok, some additional information. It seems that I got it wrong in the previous post. The feisty live(DvD) does indeed have two entries for the HPT374 module, one of which is linked to the HPT366 driver. What is curious (not to mention damn infuriating as well), is that I can see the drive connected when I boot up from the Feisty Live(DvD) and I can access all the content. However, today I booted up from a Gutsy Live (CD) and although I can still see the drive, it would not mount. It gave me some error about improper shutdown or it still being in use. Also something about ntfs and a very concise option on how to force mount it (at my own risk) if I so wished.
So, in conclusion for this post.....
1.) The drive mounts and is able to be accessed normally from a Feisty Live (DvD).
2.)The drive is visible but is not mounted, neither can it be accessed on the Gutsy Live (Cd) without forcing (something I am not prepared to do at this juncture as the data held on it is to important to me to risk corruption). 3.)The drive causes a virgin Feisty installation to a IDE hard drive to freeze at the Ubuntu splash window, if it is connected to the Highpoint RocketRaid 1540 interface card at boot up (* please note that it will only cause a boot freeze if connected to ports 1 or 2 on the interface card - If connected to ports 3 or 4 it will boot normally, however the drive is not visible inside either ubuntu Feisty or Gutsy if the the OS is installed on a hard drive).

Has anyone got any idea why I can see and use the drive connected to port 1 or 2 on the Highpoint Rocket Raid 1540 SATA , when using the Feisty Live (DvD) but it will not work on either the Gutsy Live (Cd) or either Feisty or Gutsy installed on an IDE hard drive?

Please help me someone as this is causing me sleepless nights and I dont know enough about linux or Ubuntu yet to try compiling the source HPT374 driver from Highpoint, yet.

Nuff respect to all the good work all of you do both here and elsewhere, in promoting this wonderful (if sometimes frustrating) OS.

Launchpad Janitor (janitor) said : #10

This question was expired because it remained in the 'Open' state without activity for the last 15 days.