Can't eject removable hard drive

Asked by Rooster Cogburn on 2007-08-29

I am running Feisty.
I can't get my removable hard drive to eject. When I try it gives ".......Please do not remove the media or disconnect the drive."
when I do sudo fdisk -l
Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 14240 114382768+ 83 Linux
/dev/sda2 14241 14593 2835472+ 5 Extended
/dev/sda5 14241 14593 2835441 82 Linux swap / Solaris

$ sudo umount /dev/sda
umount: /dev/sda: not mounted
$ sudo eject /dev/sda
umount: /: device is busy
umount: /: device is busy
eject: unmount of `/' failed

I also can't mount it by manual or sudo
$ sudo mount /dev/sda
mount: can't find /dev/sda in /etc/fstab or /etc/mtab

What I want is to just safely eject this hd.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
wjr74
Solved:
2007-08-29
Last query:
2007-08-29
Last reply:
2007-08-29
Rooster Cogburn (ilikeegg) said : #1

Sorry, nevermind about those commands. I realize I was in the wrong location.
How do I figure out the location?

It also won't mount as well as eject. I was able to safely remove this before when it was mounted and it was in the media folder.

Best wjr74 (wjr74) said : #2

If you are using Gnome try installing Gnome-mount, Gnome-Volume Manager, and Pmount through Synaptic Package Manager

Rooster Cogburn (ilikeegg) said : #3

Thanks wjr74, that solved my question.

wjr74 (wjr74) said : #4

You're welcome