can't login as root

Asked by n@ning on 2006-07-19

can't mount windows data vfat format n can't login as root ("authenticaiton failure")
can't modify (insert or append) /etc/fstab for mounting windows data (vfat) automaticaly

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2006-07-19
Last reply:
2011-01-06
Benjamin Hodgetts (enverex) said : #1

Do "sudo passwd" and when it prompts, enter your current password and then when it asks for the new password type what you'd like to use for root, you can then use "su" in the terminal to switch to root.

To edit fstab or any other root files you need to either run your GUI editor from a su'd terminal or run a terminal editor with sudo, i.e. "sudo nano -w /etc/fstab" as regular users don't have write access to these files for obvious reasons.

Onkar Shinde (onkarshinde) said : #2

Root account is disabled by default in Ubuntu.

Please use 'sudo vi /etc/fstab' or 'gksudo gedit /etc/fstab'

Bhavani Shankar (bhavi) said : #3

yes root access is disabled by default in ubuntu... (Root is also called as the superuser)...
to get a root terminal with superuser privileges do:

$ su
$ password: rootpassword

if you don't have a root password first need to do:

$sudo passwd root
$New Password: typeyourpassword
$Retype password: Again

and if you are unable to mount windows partitions:
Execute 'gksudo gedit /etc/fstab' in a terminal and paste its output..

Cheers,
Bhavani Shankar.

Alan (alan-karna) said : #4

Just want to say thanks. This solved my problem as well.

Bhavani Shankar (bhavi) said : #5

Please tag this question as solved...........

Marc Knight (marcjknight) said : #6

I would like to replace the desktop-login.ogg file to one of my own. How do I do this? Is it possible. I guess I need to login as root, but what then? Thanks for any help.

Can you help with this problem?

Provide an answer of your own, or ask n@ning for more information if necessary.

To post a message you must log in.