Synaptic error

Asked by gaddo

Can anyone help with this error
tried to open synaptic package manager and get the following error

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

tried to run above and was told you need to be a superuser not sure what that is.
Any ideas thanks

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Cesare Tirabassi
Last query:
Last reply:
Revision history for this message
Best Cesare Tirabassi (norsetto) said :

Open again the terminal, and give this command:

sudo dpkg --configure -a

Give your password and you should be done.

Revision history for this message
gaddo (gaddofly-googlemail) said :

Thanks Cesare Tirabassi, that solved my question.

Revision history for this message
ankit1200 (ankit1200) said :

hi i am having the same problem but when i type the code into the terminal it still does not work.
so can some one help me out please?

Revision history for this message
puputboy (puput-budiadtya) said :

I can install or removal program from my synaptic like this: please help me....

puputadit@puputadit-boy:~$ su
root@puputadit-boy:/home/puputadit# sudo dpkg --configure -a
Sedang menyetel sun-java6-doc (6-13-1) ...
This package is an installer package, it does not actually contain the
JDK documentation. You will need to go download one of the

(choose the non-update version if this is the first installation).
Please visit

now and download. The file should be owned by root.root and be copied
to /tmp.

[Press RETURN to try again, 'no' + RETURN to abort]

Revision history for this message
Steve (stupendoussteve-deactivatedaccount) said :

It is Answers etiquette that a person should open a new question when they have a new question.

To puputboy, the instructions are in the message:

You need to manually download Java SE 6 Documentation at

Copy the file to /tmp (this can be done in the GUI)

Open a command line and run "sudo chown root:root /tmp/"

Then rerun the command.

Revision history for this message
mwb53tx (wayne-wayneboyd) said :

No no no.... You CAN NOT manually download either or at

The reason you can't is because when you go to that URL there is no place to download those specific files, which must be obtained in order to solve the problem.

Does anyone have a WORKING url to download either of these files?