Always need CD to boot Ubuntu

Asked by yangj on 2007-08-25

I just installed Ubuntu and always have to use the CD to boot, after I unplug the computer. It is fine if the computer stays plugged in. All the network settings seem to be the same even after a Live CD reboot. Everything works great, which I shouldn't be complaining. But it is kind of annoying.

I did an automatic install so i think all the mounts should be proper. Maybe something in the BIOS is not set right??

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Georges Dubus
Solved:
2007-08-26
Last query:
2007-08-26
Last reply:
2007-08-26
Georges Dubus (madjar) said : #1

Grub, the bootloader, should enable you to select Ubuntu on boot. What really append when you start your computer without the CD ? Do you see anything about grub ?

If not, can you check whether the package 'grub' is installed (it should be), show us the content of your file '/boot/grub/menu.lst', and explain how you hard drives are parted ?

I think there may be a problem with your grub install (maybe your reinstaller windows after), and it need to be reinstalled, so just tell me how your system is parted, and I'll give you the exact command. If you want to do it yourself, execute 'grub-install /dev/hda', changing /dev/hda if needed.

I hope that will help you

Georges Dubus (madjar) said : #2

Just another idea : maybe your system boot on a drive on which grub is not installed.
You should tell us how are your hard drives.

I don't think I understood that properly. Let me check. You say that you
1) have installed Ubuntu to disk.
2) are able to boot into Ubuntu without the cd-rom in the cd-rom drive, as long as you don't unplug your computer?
3) are using live cd persistence? Or did I misunderstand that point?

Which version is this?

yangj (yangj-84) said : #4

Thanks for the quick responses guys. Well I tried to pull up more info by using /boot/grub/menu.lst, but no luck. So I decided to install gparted. This is what I have:

/dev/hdb1 File system: ext3 mountpoint: /, /dev/.static/dev size: 38.8 GiB used: 2.83 unused: 34.06 GiB boot

/dev/hdb2 Extended --------------------------------------------- 1.39 GiB ------------ -----------------------------

/dev/hdb5 Linux-Swap ------------------------------------- -----------------------------------------------------------------

As for when the computer starts, I see things loading like Natilius, etc.. but no Grub

jyang@jyang-desktop:~$ grub-install /dev/hda
/dev/hda: Not found or not a block device.
jyang@jyang-desktop:~$

Also, i now need to use the CD to boot the system every time..

Best Georges Dubus (madjar) said : #5

I seem you don't have any hda, probably because of a problem of hdd jumpers.

I think that a little 'sudo grub-install /dev/hdb' should solve your problem.

Explaination : The installer probably tried to install grub on hda, but you don't have it. Instead, you only have hdb. So let's install grub on it !

yangj (yangj-84) said : #6

Thanks Georges Dubus, that solved my question.

yangj (yangj-84) said : #7

Now it looks like I have to reformat my hard-drive and reinstall because it looks like i have 2 operating systems on my drive when I tried to reinstall the first time.

Well, gotta get to it. Much appreciated!!