password error logging on

Asked by Cushie on 2007-08-24

I am very concerned about having to enter my password twice on login. The first time returns 'error' and the box is cleared, the second time is ok and I use the same password each time. I have tried changing the password, and even setting up another user with the same result. Can you suggest any options for me? AMD XP3200, Feisty Fawn.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-08-31
Last reply:
2007-09-05
Mauro Vale (maurovale) said : #1

Where in the hell that happens ? it is in GDM it is in a terminal ?? is in GRUB

B rabbit (justin--prince) said : #2

i hate to say this but have you tried rebooting(restart) your box and login again.....if yes then have a look at system >adminstration > login window to see if there is any faults. :)

Cushie (redhotwal) said : #3

1. It is the login screen just before going into Gnome (or other option) I have no password in Grub but the terminal sudo login seems ok.

2. I looked the 'Login Window' over and tried some simplification, all seems ok, but still a double login!

Your help appreciated.

Cushie (redhotwal) said : #4

This is the lower pert of the/etc/passwd (unprotected) file;-

gdm:x:109:118:Gnome Display Manager:/var/lib/gdm:/bin/false
walter:x:1000:1000:Walter,,,:/home/walter:/bin/bash
beagleindex:x:110:65534::/var/cache/beagle:/bin/false
tom:x:1001:1001:tom,,,,:/home/tom:/bin/bash

I note the figure after the login name appears twice, is that normal?

Hello Cushie,

Do you run Beagle, by any chance, or just have Desktop Effects turned on? What does happen if you turn them off?

Cushie (redhotwal) said : #6

No I have not run Beagle or desktop effects for some 4 weeks or more. I did get some peculiar mouse key responses from desktop effects (not always the ones expected). The effects are turned off, but how would I disable Beagle?

Justin M. Wray (wray-justin) said : #7

Cushie:

     Has this always been the case on this system, or did it just start happening out of the blue?

Thanks,
Justin M. Wray

Cushie (redhotwal) said : #8

I've had this system running for since 7.04 came out, I have only noticed this double login the last perhaps three weeks.

I have had no change in hardware except I ran an ethernet router for about 3 weeks from the 23 July, and then changed back to my wifi router, accessed thro' an USB adapter, this last two weeks . That did cause a problem with the network/interfaces file which I edited and is running as before. However that caused me to get entangled with a 'keyring' scenario requesting more passwords, which I could not understand at the time. I did eventually get rid of it via the Terminal, following some online instructions. But that 'keyring' event could be a clue to this issue.

Justin M. Wray (wray-justin) said : #9

Cushie:

     Okay, I'll ignore the keyring comment for a moment. In the past three weeks (or more importantly about three weeks ago) did you install any new software? Or have you installed any updates?

     As far as the "keyring" issue, can you provide more detail? What happened? What errors/issues arose? What documentation did you follow to correct the issue? Etc...

Thanks,
Justin M. Wray

Cushie (redhotwal) said : #10

Thank you Justin, yes, the regular Ubuntu 7.04 updates were installed about once per week. I don't think I installed anything new. The main problem I sought help on was the Network not automatically logging in on bootup. I hope the following helps. I did download some .iso files particularly 'Pendrivelinux, Puppylinux and Linuxsystemrestore and I dare some wallpaper pictures from somewhere like 'gnome-art.'

This was my post on 11 Aug 2007 to alt.os.linux.ubuntu

>>This last week a window keeps popping up asking me for a 'Keyring' password. I only use one password on my Ubuntu (Feisty) system and it does not like this. To my knowledge I don't have a 'Keyring' (if I knew what one was I might want one!) and have not installed any, nor even the so called 'Network Manager Applet 0.6.4' which annoyingly pops up and demands a password. The network icon says I am logged onto my network (1 computer + 1 wifi router at present) and the settings listed are correct (WEP etc) but will not let me access the network, router or Internet. I just wondered if something this has infiltrated or bugged my system? How can I get around this or clean things up and get back into my system. I tried rebooting the router, no better. I have tried DHCP, fixed address and even roaming to kick start the network (which has sometimes worked but not tonight) The previous 8 months my network logged itself in automatically once I got all the settings into /etc/network/ file but these settings seem to have been taken over.
<<
I followed the following from posts on
alt.os.linux.ubuntu
http://ubuntuforums.org/showpost.php?p=2545332&postcount=71
http://ubuntuforums.org/showthread.php?t=514360
libpam-keyring and pam_key were installed

Justin M. Wray (wray-justin) said : #11

Cushie:

     As a side note, the keyring is on the system by default and it hold the network key. At login the password should be your account password, which gives the Network Applet (also a default) the ability to read the network key from the keyring.

     This does seem to be where the issue arose, as you made changes to your authentication (pam) etc. Reversing these changes may correct the problem. More importantly note, you made changes to GDM, where the problem exists.

     Just to make sure we are on the right page, try the following and let me know the results:
          1) Hit CTRL+ALT+F1
          2) Enter your username
          3) Enter password
     Let me know if you are prompted for two passwords (aside from a typo during your password entry).

Thanks,
Justin M. Wray

Bhavani Shankar (bhavi) said : #12

yes What justin told was right... Did you accidentally change your authentication like pam, for password aging (i.e remove an old password after some specified days) or a One time use password (i.e change the password every single time you use it)........? more importantly probleem exists as you made changes to GDM... Try out what justin has said and keep us informed...
BR,
Bhavani Shankar.

Cushie (redhotwal) said : #13

Thank you again. it seems as though we are getting somewhere.
Ctrl ALT F1 or F2 or F3 do nothing (Gnome Ubuntu 7.04)
If I enter 'App/System tools/Terminal' and 'sudo' I only enter the password once to gain root.
(How should I enable the Cntl +F keys?)

Justin M. Wray (wray-justin) said : #14

Cushie:

     You should be able to access the TTYs by using CTRL+ALT+Fx. But that is another issue. Do you have SSH running on your system?

Thanks,
Justin M. Wray

Cushie (redhotwal) said : #15

Well I am not consciously using it or have set it up, but I have used samba file sharing 'windows network' recently. I hope that helps.

Ashton (cogneato) said : #16

I have the same issue here. I have to enter my password twice at login. I ALSO messed with the settings recently in an attempt to get the keyring manager to stop asking for its password. I would ask my own separate question but this seems so similar to your issue Cushie that I thought my info might help someone help you! (erm, and me)

I installed libpam-keyring and have both login and keyring passwords set as the same. This is my /etc/pam.d/gdm :

#%PAM-1.0
auth optional pam_keyring.so try_first_pass
session optional pam_keyring.so
auth requisite pam_nologin.so
auth required pam_env.so
@include common-auth
@include common-account
session required pam_limits.so
@include common-session
@include common-password

Is there anything here that's obvious to someone? :) I know the "@include common-password" is something I added, but I'm not sure what else may be wrong. If I remove libpam-keyring altogether will that solve the prob?

Can you help with this problem?

Provide an answer of your own, or ask Cushie for more information if necessary.

To post a message you must log in.