Ubuntu on Virtual PC 2007 does not allow me to log in!

Asked by Bahram Saghari on 2010-08-09

Hello,
I installed Ubuntu 10.04 LTS twice on a Virtual PC - in both cases it took for ever but it successfully installed.
In the process, it asked to add a user, which I did "bahram", and completed.
At the end of the installation, again, in both cases, it asked if I wanted to continue testing!, or to restart and use the system.
I restarted but now I cannot login!

It gives me the login screen, I enter my login name, bahram, and the password and it does not let me in with "Authentication Failure"!

What am I doing wrong ...?!
I installed SuSe and it runs just fine - I installed a bunch of other Windows variations, and they all work.
This thing completed the installation and I can see the pinkish reddish purplish background, but cannot login :(
p.s. It never asked me for a root password - in both cases, it asked me to add a new user, during the installation, and that was it. Help!

Cheers,
Bahram

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2010-08-09
Last query:
2010-08-09
Last reply:
2010-08-09
Jim Bauwens (jimbauwens) said : #1

Try this:
Startup in recovery mode (select it in grub)
When you get to a menu, select something like "go to shell" or "go to terminal"
In the shell type:

passwd bahram

and press enter.
It will ask you for a new password.
Note that you will not be able to see you type the password.
When you are done press ctrl-d and select resume.

Hope this helps
Jim

Jim - thanks.
You are not going to believe, the most basic, the most obvious that just happened!
Following your advice, I rebooted the system for the second time to find out what you meant by "GRUB" , watching every step. it did its basic boot up stuff, and voila, asked if I wanted to login as Bahram or ...
In other words, I am now logged in successfully - One question remains that I never entered a root password, and how do I become root?!

1. In the old days, we did SU to be root, and we had a password. This system seems to understand SU but I never gave it a root password. Is the notion of the ROOT still alive ...?!

2. it offered sudo, and asked for my password, and I am now, root! Is this how it is these days?
(I promise not to ask any more questions from this forum ... only password and login !)

Cheers,
Bahram

Please mark as solved if it is so, otherwise please detail the situation and we can advise further.

Thanks.

The reboot did solve the problem. Done. Thanks.