install over old ubuntu without formatting

Asked by jwizardc on 2010-08-06

I had a power failure during an in-place upgrade to 10.4 Now it boots to several choices of kernel and troubleshooting options.
I ran fsck and it found errors, but it still won't boot.

When I boot from a live cd and check with the file browser, my entire file structure is present.

Of course my backups are current...not.

What I would like to do is repair the installation, but the only options I seem to find all involve wiping the disk.

I apologize for my ignorance. I'm sure this question has been answered many times. I did search the forums and this site.

I am not a total idiot. I have 10.4 installed in a VBox virtual under Win VII. I use it as a server while developing web pages. Doing it that way saves me all the hassle of FTPing to the target.

btw - did you know that IIS supports PHP? Well, sorta. It wraps it up in a cgi-bin shell. Just what I need; another layer of something to configure.

Thanks!

-Jim
<email address hidden>

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Andrea Corbellini (andrea.corbellini) said :
#1

Hello,

Sorry, but I don't undestand exactly what you mean when you say "Now it boots to several choices of kernel and troubleshooting options". Do you mean that you see a list of kernels, some with the "(recovery mode)" label? If so, what happens if you try one of them (both normal and recovery)?

Also, how did you run fsck? Did it just find the errors, or did it try to fix them too?

Thanks,
Andrea

Revision history for this message
delance (olivier-delance) said :
#2

VBox allow you to make snapshots, which is an easy way of doing backup, and restoring previous state, specially before a critical action.
Think about it next time!
About repairing a system broken during installation, I'm pessimistic.
Did you went from 9.10 to 10.04 ? In this case, I'm afraid best is a fresh install of 10.04, after backup of "/home".

Revision history for this message
Andrea Colangelo (warp10) said :
#3

@delance: QA Team members (and Ubuntu Developers in general) are always *so* happy when someone discourages dist-upgrading after 6 months of hard efforts to Make Everything Just Work (cit.). :)

@jwizardc: have you tried to boot your machine disabling "quiet" and "splash" options at boot to make it more verbose? This way you can understand where exactely the boot process stops, and maybe we can find a hack to at least reach a terminal and safely complete the upgrade.

Revision history for this message
delance (olivier-delance) said :
#4

@Andrea: If installation stopped during update, I presume the state of computer is inconsistent and except if you have a magic solution, it will be faster to do a fresh install of 10.4. Repairing things can be a highly time consuming job, and dangerous when you try to many tricks.
@jwizard:
First make a snapshot of current state of disk, because by trying to repair, you can make things worst. If you can't snapshot, use VBox utility to clone disk or make a copy of VDI file.
There are many solutions.
One of them could be:
   - make a second hard drive
   - copy first disk into this second one (including /home)
   - make a fresh install of 10.04
   - restore "/home" directory
   - reinstall needed software

But before doing anything, do a BACKUP of current VDI file!

Revision history for this message
jwizardc (jwizardc) said :
#5

Okay, I see that I confused everyone.

The information about running vbox has nothing at all to do with the question at hand. Not enough slepppp causes strrrrrange things to come out of one's keyobard. I guess that by attempting to deny being an idiot I proved myself to be one.

This problem is with my physical server box. It is just for my family; I am using it to keep my networking skills reasonably fresh.

Yes, Andrea; it comes up and gives me the recovery options. I got one to run and give me a cli. That is where I ran the fsck and It did find and fix several errors.

I have a copy of /home. I just hate having to redo my Apache2 and Samba settings.

"I've wrestled with reality for years and I'm proud to say I've finally won out over it." -Elwood P. Dowd

Revision history for this message
Andrea Corbellini (andrea.corbellini) said :
#6

Hi and thanks for the information. I'd like to know, how did you do the upgrade? Which tool did you use?

(I'm asking this because sometimes people do upgrades using directly apt-get or aptitude, which results in strange behaviors)

Revision history for this message
jwizardc (jwizardc) said :
#7

I downloaded the ISO directly from Ubuntu.

"I'm thinking of the immortal words of Socrates when he said 'I drank what' " - Chris Knight (Real Genius)

Revision history for this message
jwizardc (jwizardc) said :
#8

Thank you for helping with this!

 The FNG

________________________________
From: Andrea Corbellini <email address hidden>
To: <email address hidden>
Sent: Sat, August 7, 2010 9:14:08 AM
Subject: Re: [Question #120230]: install over old ubuntu without formatting

Your question #120230 on Ubuntu changed:
https://answers.edge.launchpad.net/ubuntu/+question/120230

    Status: Open => Needs information

Andrea Corbellini requested for more information:
Hi and thanks for the information. I'd like to know, how did you do the
upgrade? Which tool did you use?

(I'm asking this because sometimes people do upgrades using directly
apt-get or aptitude, which results in strange behaviors)

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.edge.launchpad.net/ubuntu/+question/120230

You received this question notification because you are a direct
subscriber of the question.

Revision history for this message
jwizardc (jwizardc) said :
#9

Sorry, I don't remember the exact sequence [note to self - stop doing these things when sleep deprived. {ps - get some sleep}]

I am presently running from a live boot. All seems well - it sees all; or at least what I have looked at.

Now that I have a moment of (hopefully) lucidity...

I have managed to use recovery mode to get myself logged in as root.

I have a bootstrap.log in /var/log. I could probably email it to you if you want. It's about 40K.

"It is illegal, immoral, and stupid to yell 'fire' in a crowded theater.
Is it ok to yell 'snow' in a crowded school room?" - me

Revision history for this message
jwizardc (jwizardc) said :
#10

PS - I am logged in as root on the actual machine, not the live cd.

Revision history for this message
delance (olivier-delance) said :
#11

What's the status ?

Revision history for this message
jwizardc (jwizardc) said :
#12

Still open, no change.
Fortunately this box isn't critical at the moment.

"We are the dreamers of the dreams" - Willy Wonka

Revision history for this message
delance (olivier-delance) said :
#13

In a terminal (Applications->Accessories->Terminal), type the following commands and paste results:
    sudo parted -l
where "-l" is lowercase "L". This will display list of partition.
     grub-install -v
which will display version (0.97 = Legacy, 1.97 & 1.98 = Grub 2)
And if you have Grub 2
     sudo update-grub
which will search again Windows OS and will build grub menu from default file

Can you detailed all the problems you have currently ?

Revision history for this message
jwizardc (jwizardc) said :
#14

parted returns 2.5 partitions:
1 is from 32.3kb to 120gb, primary, ext4, boot
2 is from 120gb to 123gb extended
3 is from 120gb to 123gb logical, linux-swap(v1)

grub says1.97~beta4

if I boot without any intervention, I get a message: mount: mounting none on /dev failed: no such device

After about 5 seconds, it goes on to try to boot with several messages. It gets as far as 'checking battery state [ok]' and stops.
It is not a laptop and it does not have a battery backup.

I have a boot.log file. It has the following messages:
fsck from util-linux-ng 2.17.2
udevd[2823]: SYSFS() will be removed from future versions...

udev[2823]: specified user 'usbmux' unknown

{deleted to prevent death by boredom}

start: Unknown job: S49console-setup

Again, the problem I am attempting to solve is to install Ubuntu over an upgrade that failed. When I attempt to install from the cd, it wants to either install side-by-side {extreme waste of space} or format the disk and install afresh.

A repair install would be my favorite option.

Revision history for this message
delance (olivier-delance) said :
#15

"'checking battery state [ok]' and stops." => it's a graphic card problem (graphic is activated just after battery" This means also reinstalling Grub2 will change nothing.
What's your graphic card (name and processor name: Nvidia, ATI, Intel) ?

Revision history for this message
jwizardc (jwizardc) said :
#16

I am using the built-in K8M800M video on a MS-6741 ver 1 mb.

Revision history for this message
delance (olivier-delance) said :
#17

Graphics Controller VIA UniChrome Pro K8M800
I never heard of this motherboard graphic chipset. I'm afraid it will be hard to get some help. This chipset is supported by Linux.
I told you problem lies in graphic card. I improved my Linux knowledge since then, and it's not sure at 100%, but simply highly probable. In your error message, Plymouth talk about usbmux, which could be the right problem.
"start: Unknown job: S49console-setup": your "upstart" process is broken.
I "googled", but have lot of difficulties to find useful data.
I have perhaps an idea: in one forum, the guy also use Virtual Box.

Could you uninstall VirtualBox (without removing data in Synoptic's option) to check if problem is linked to USB management of VBox ?

Revision history for this message
jwizardc (jwizardc) said :
#18

Thank you for your research. I really do appreciate it.

This answer does not seem to address the actual issue I am trying to resolve. I want to learn how to install Ubuntu over an existing (broken) install.

It seem to me that this is a problem that must have happened to someone else sometime before. Am I the first person in the history of Linux to have this problem?

It seems to me that Ubuntu must have some facility to do a 'repair' install: Reinstall the OS without formatting. Keep the existing configuration files if possible.

There gots to be a way.

Revision history for this message
Launchpad Janitor (janitor) said :
#19

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
jwizardc (jwizardc) said :
#20

I must admit that I'm rather disappointed. I shall send this to whomever handles suggestions for new features.

-ww\oz

Revision history for this message
delance (olivier-delance) said :
#21

"It seems to me that Ubuntu must have some facility to do a 'repair' install: Reinstall the OS without formatting. Keep the existing configuration files if possible.": for this, you need to make a dedicated "/home" partition, and a general "/" partition of 10-20GBytes.

Can you help with this problem?

Provide an answer of your own, or ask jwizardc for more information if necessary.

To post a message you must log in.