Desktop does not load after login.

Asked by Abid Iqbal on 2010-08-03

After I removed evolution and installed new evolution 2.30, rebooted my system, the desktop does not load and log in screen loops back.
I removed evolution, compiz and reinstalled evolution but issue is there.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Abid Iqbal
Solved:
2010-08-04
Last query:
2010-08-04
Last reply:
2010-08-03
delance (olivier-delance) said : #1

Do you open automatically evolution at startup of session ?

Abid Iqbal (abid-itd) said : #2

No, I removed all the evolution package.

inashdeen (inashdeen) said : #3

you might had remove the packages for gnome as well, causing your system not to open gnome
a simple solution is to install other desktop environment and reconfigure from there
but it is not simple when u dont have other desktop environment
there might be a way to do it
but as i had did before
a reformat and reinstall might be easier

Abid Iqbal (abid-itd) said : #4

I will loss lots of stuff and it is starting from zero.

Philip Muškovac (yofel) said : #5

Did you try to install the 'ubuntu-desktop' package? That should pull in everything that's needed for the default desktop

Philip Muškovac (yofel) said : #6

as you can't login by gui, to install the package press 'ctrl+alt+f1' at the login screen, login on the terminal and run 'sudo apt-get install ubuntu-desktop' - a wired network connection would be good as wireless is a bit hard to set up there. If that doesn't to anything maybe remove the package with 'apt-get remove' first and then install it again.

Abid Iqbal (abid-itd) said : #7

I started system in recovery mode and run the apt-get install ubuntu-desktop.
This solved my problem. Thanks Philip and all others for help.