How do I run a program that doesn't have an Applications menu item?

Asked by Esther Strom on 2010-08-02

I'm trying to run a number of programs that the Software Center says are installed, but they do not have entries in any of the applications menus. I've searched my lib folder and found files that indicate they are executable, but they do not open when I double-click them. Any ideas?

An example: in the Software Center, there's a program listed as Archive Manager. When I click on the More Info button, it indicates it's actually called file-roller. So I go to usr/lib/file-roller, and there's another file-roller directory, which contains two files - a shell script, and an executable called rpm2cpio, which says it's executable. But when I double-click on it, nothing happens.

So how can I run this program, and how can I get an entry for it in my application menu?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Philip Muškovac
Solved:
2010-08-03
Last query:
2010-08-03
Last reply:
2010-08-02
Best Philip Muškovac (yofel) said : #1

Hi, executable applications are usually in the /bin, /usr/bin and /usr/local/bin folders (and /sbin /usr/sbin /usr/local/sbin for administrative programs) If they are gui applications, you can run them either by pressing alt+f2 and entering 'file-roller' or you can open a Terminal (Applications->Accessories->Terminal) and run the app from there, if it's only a terminal application you'll have to run it from a terminal.

As to why file-roller isn't in the menu, since it's the default archive manager (and called archive manager in the menu) and supposed to open once you try to open an archive, it's menu entry is disabled by default. You can enable it by opening the menu editor 'alacarte' by right clicking on the menu I think. It should be under Applications->Other->Archive Manger

Another reason (not in this case) for an application to not have a menu entry is because it doesn't supply a .desktop file in the package which has the menu entry definition.

Thanks Philip Muškovac, that solved my question.

Thanks so much! I found the actual executable and was able to add it to the menu. As to file-roller being the default and opening automatically when you try to open an archive - I need to create archives, not open them, so I need to be able to open the program directly.