no install. cant test cause drive in use

Asked by doccpu

been trying to instal 10.04 for 48 hours. A brand new 3 day old drive. It wont do an install from cd. Says r/w problem of cd or drive. Why wont it tell which? cant do a sector check of the drive from live install. it says drive mounted or in use. mount says not, lsof says not others say /dev/sda in not in use but badblocks and others say it is. so how the hell am i to find bad sectors (if any) on the %$^%^& drive? <email address hidden>
windows sucks but linux has been a real pain for years.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Sam_ (and-sam) said :
#1

Is CD from official source, did you make integrity check of CD?
https://help.ubuntu.com/community/Installation

Revision history for this message
doccpu (dhorner) said :
#2

it checked the cd which i got from ubuntu sites download. cd tests good. so it must be a bad sector on the drive. how do i check the drive within a live cd? it keeps saying drive in use but not how.

Revision history for this message
Sam_ (and-sam) said :
#3

Bad sector on a new drive doesn't sound good.
Try this one, incl. lots of diagnose tools.
http://www.ultimatebootcd.com/

Revision history for this message
doccpu (dhorner) said :
#4

tried on an old ide ata. seems to be ok. the sata drive is under test right now. so far no errors. Is there a problem with 10.04 and sata drives? 9.10 didnt like displays as they changed where and how it tested display capabilities so you couldnt change gui res after the fact. What did they break now?

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#5

Download the ultimate boot cd and test the drive using manufacturers tools (ultimate boot cd has most of the main drive manufacturers tools on)

You can always return the drive under warranty, it may be DOA

Revision history for this message
doccpu (dhorner) said :
#6

ran the seagate sea tools. no probs found after 2 extensive tests. The install done on the ide drive is doa. never even tries to boot. i have had terrible results on ubuntu installing on every machine i have ever bought built or borrowed in 3 years. All seem to not run after a base install. only wubi's seem to work but i want a stand alone. red hats, debians, slackwares, etc etc install and run but i've had nothing but grief from ubuntu.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#7

Ubuntu isn't always the answer

Revision history for this message
doccpu (dhorner) said :
#8

ok forget it i give up. ubuntu sucks. I have NEVER been able to install it on any of the machines i have ever tried. A full new install failed on both sata and ide. . tried to do it from the live it dropped to after a failure. it failed. it says the drive is busy wether mounted or not. Ubuntu totally refuses to let me use anything cause i am not root. Well i own the machine, i installed the machine i run the machine i should be given root priviledges. 8 lost its wifi, 9 lots its video res capabilities. 10 wont install at all. ubuntu is doomed to fail.

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#9

doccpu very strange you have so many fails might be you are doing some wrong...
You said "Says r/w problem of cd or drive" please be sure to have a valid install cd... made from a velid downloaded iso (md5sum verified).

May be your Ubuntu live install cd is not perfect or it can't be read from your cdrom drive please verify it...

Here some general note and howto:

The main ubuntu site is this: www.ubuntu.com and the download location is this
http://www.ubuntu.com/desktop/get-ubuntu/download

Prerequisites: https://help.ubuntu.com/community/Installation/SystemRequirements
Please also be sure to read the release notes: https://wiki.ubuntu.com/LucidLynx/ReleaseNotes

1) please download the 700 mb file http://www.ubuntu.com/desktop/get-ubuntu/download simply press on download button
To avoid download errors please prefer to download the desired ubuntu iso install cd image using the torrent protocol.
2) check the md5sum of downloaded file to be sure it have no error https://help.ubuntu.com/community/HowToMD5SUM

Only if the md5sum number match with this: http://releases.ubuntu.com/10.04/MD5SUMS go to the next steps otherwise
install a torrent client i suggest you http://deluge-torrent.org/ if you are using Windows and download the iso using a .torrent link from here:
http://releases.ubuntu.com/10.04/ubuntu-10.04-desktop-i386.iso.torrent

3) burn the iso image onto a cd, to do it install and use http://infrarecorder.org/?page_id=5
4) insert the self made install cd into your pc cdrom drive and reboot your pc. You must not see Windows starting and you can try Ubuntu from cdrom and then install it

If you have trouble with installation (the system freeze or you can't complete it) be sure to read the above suggestions, then:

1.a ) Please boot entirely (you must not see windows starting) from Ubuntu live install cd and when the system start to boot from cd you will see two bottom screen icons (keyboard and man inside circle ) please press space (choose your desired language) then a screen textual center menu will appear to you with this items in it:

Try Ubuntu without installing
Install Ubuntu
Check disc for defects
Test memory
Boot from first hard disk

Please select "Check disc for defects" and press enter to test if your cd-driver can read in a good way the live install cd... or if the install cd have some defective file in it.
Then please also perform a Test memory to be sure your pc RAM memory have not any issue

http://www.ubuntugeek.com/how-to-fix-ubuntu-10-04-lts-lucid-blank-screen-at-startup.html

---- Trouble with intel8xxx graphic cards:

please try this: https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes

Revision history for this message
doccpu (dhorner) said :
#10

verified cd. ran seatools on hd. system is a zotac mb with amd 215 dual core. less than 1 yr old. Is new install on system. just wont write to hd and thinks its always busy in live edition. on another system the 10.04 wont even boot into gui at all (amd athlon 800mhz 512 ram) i have never been able to get ubuntu cleanly to install on any machine ive tried new or old.

Revision history for this message
Sam_ (and-sam) said :
#11

>A full new install failed on both sata and ide. . tried to do it from the live it dropped to after a failure. it failed. it >says the drive is busy wether mounted or not.

Ok, if nothing helps usually AlternateCD is the better choice.
It doesn't have the unmounting_issue of LiveCD.

https://wiki.ubuntu.com/LucidLynx/ReleaseNotes
https://help.ubuntu.com/10.04/installation-guide/index.html
https://help.ubuntu.com/community/Grub2
https://wiki.ubuntu.com/X/KernelModeSetting

In case some boot options.
https://help.ubuntu.com/community/BootOptions

> refuses to let me use anything cause i am not root
It simply isn't necessary to be root on Ubuntu, it uses 'sudo'.
https://help.ubuntu.com/community/RootSudo

Verify that BIOS recognizes primary master correctly.
e.g.
http://www.bcot1.com/bios03.jpg

In order to make Ubuntu better please consider to report a bug against 'ubiquity'.
e.g.
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/601723
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/598743
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/583790

Revision history for this message
doccpu (dhorner) said :
#12

finally gave up and put debian 5 on it. It worked. still couldnt get zone minder to work no matter what and x had a prob but thru persistence got x to see screen and correct res's ( nvidia is a mess)
motion and xawtv work good but zone minder is a mess. too complicated and just wont run as they say.
i verified the cd again and tried to load it on another machine that has been running video surveillance for 5 years +. put in a 10gb drive and it just hangs on cd boot . i guess i will use ubuntu 8.04 on serious installations cause later versions are grief.

Revision history for this message
inashdeen (inashdeen) said :
#13

i am not sure whether this really helps, but from my experience, some hard disk, when you try to install a stuff, over and over again, it got like a " memory stuck". it will tell you that this cannot be done, that cannot be done. whatever. tell you what, close your pc, let it cool for few hours, days is better. them you use gparted, http://sourceforge.net/projects/gparted/files/gparted-live-stable/0.5.2-9/

from here and clean your whole system. try to put ubuntui again, and see whether it works or not

please, ubuntu might be a bit pain, but it is an adventure. at least you learn lot from it. windows is good, i respect that, but i just cant stand the viruses. unless you want to be a steve jobs devotees, then staty away from mac. apple sucks!

Can you help with this problem?

Provide an answer of your own, or ask doccpu for more information if necessary.

To post a message you must log in.