Intel IPW2200 not working

Asked by duvidel on 2007-08-17

I have a Dell Inspiron 600M with Intel IPW2200 card. I also have a Linksys WRT54G v6 router, which seems to have no problem in the past. I would prefer not to mess with usb wireless devices, just use what I have got. After disabling the automatic start of the network manager as one article said, I tried with WEP and WPA, neither helped, nor did roaming mode. It seems to temporarily knock the wired connection offline whenever I restart the wireless. When I change anything manually, it only mentions WEP, but when the network manager started automatically, it offered WPA too.

I had moved from CentOS 5.0 with flukey wireless, to Ubuntu 7.04 because my friends said it was more friendly to wireless. This is most frustrating. I had a configuration file that I could edit and ensure the WEP code was in there, as well as copy and paste the lib/ firmware files to their rightful destination.

Is there a command to ensure that I can add, remove, modify files like within the lib folder? I am the only user on the system, so I should be root. Perhaps if I could rip and reinstall the firmware it would help?

This is what IFCONFIG shows:
david@duvidel:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:11:43:4D:EA:B7
          inet addr:192.168.1.54 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::211:43ff:fe4d:eab7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:4759 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3888 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4838213 (4.6 MiB) TX bytes:835287 (815.7 KiB)
          Interrupt:11

eth1 Link encap:Ethernet HWaddr 00:16:6F:95:2F:5E
          inet6 addr: fe80::216:6fff:fe95:2f5e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:27973 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6445 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
          Interrupt:7 Base address:0x4000 Memory:faffd000-faffdfff

eth1:avah Link encap:Ethernet HWaddr 00:16:6F:95:2F:5E
          inet addr:169.254.5.70 Bcast:169.254.255.255 Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          Interrupt:7 Base address:0x4000 Memory:faffd000-faffdfff

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:30 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2719 (2.6 KiB) TX bytes:2719 (2.6 KiB)

vmnet1 Link encap:Ethernet HWaddr 00:50:56:C0:00:01
          inet addr:192.168.124.1 Bcast:192.168.124.255 Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

vmnet8 Link encap:Ethernet HWaddr 00:50:56:C0:00:08
          inet addr:192.168.18.1 Bcast:192.168.18.255 Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Notice below that I edited the ESSID. Also, I found within the ETC/ Network/ folder an interface file, which mentioned different interfaces and I wonder if I should somehow rename eth1 to wlan0, as I once did in CentOS. Again, I can't edit the permissions to do so.

david@duvidel:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 unassociated ESSID:"d--------"
          Mode:Managed Channel=0 Access Point: Not-Associated
          Bit Rate:0 kb/s Tx-Power=20 dBm Sensitivity=8/0
          Retry limit:7 RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

vmnet8 no wireless extensions.

vmnet1 no wireless extensions.

Any help will be appreciated or I will be forced to go back to the unreliable CentOS, probably within 10 days because this is costing far too much time and worry.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Alan Pope 🍺🐧🐱 πŸ¦„
Solved:
2007-08-19
Last query:
2007-08-19
Last reply:
2007-08-18
duvidel (david-dschwartz) said : #1

I got the new firmware downloaded for the card, but I don't know how to copy the files or build the driver, after reading their documents.

If you're using network manager you shouldn't touch the files in /etc/network/interfaces other than to comment out the settings in it for all interfaces other than lo.

You shouldn't need the new firmware, it should be included in the distro (possibly in the linux-restricted-modules package for your kernel release, e.g. linux-restricted-modules-2.6.22-9-generic). It will end up in /lib/firmware/<kernel version> but you can backup the file in question and replace with a new one if you want to test that.

Ubuntu doesn't use root, but uses sudo to gain root-like authorisation. See this page for details:-

http://wiki.ubuntu.com/RootSudo

duvidel (david-dschwartz) said : #3

We shall see what happens at next boot, but there's always ubuntu as a vm and running centos again.

duvidel (david-dschwartz) said : #4

i will close this off for now and let it rest for the time being.

potestas (cambra-rob) said : #5

I have a Dell Latitude D410 with the same card. Ubuntu 7.04 out of the box install and using KNetworkManager. I see all the wireless networks around me but can't successfully connect to any (secured or not). I was wondering if you ever solved your problem. If so I could use some pointers. Thanks - RC.

duvidel (david-dschwartz) said : #6

Unfortunately, I did not solve my problem. As equally frustrating, my CentOS 5 install still has iffy recognition of the card. I had to find the latest firmware, and stick it in /lib/firmware, and edit the modprobe.conf file, as well as build an eth1 file with the mac and wep codes in it. It gets better. I discount most of what people say until I actually found a knowledgeable person in BestBuy. Yes, that is scary. He told me that he doesn't use Intel boards especially with Celeron chips, but prefers AMD. He found that the cards on the Intel boards, especially the one we've got don't work so well with Linux. He's never had a problem with AMD. Go ahead and say: "So what?" However, I asked at work. My posse was none too surprised. It may be isolated on this type of card or the 2915, but I doubt it. That means to me, like it or lump it.

I may have to go with the next to last release of the firmware ware at ipw2200.sf.net. Even so, how much do I really want to put into this command or that for wireless, unless I can somehow back up and replicate what I did? I found trying to find and install firmware in Ubuntu a bear. Fortunately in the case of CentOS, my cousin is a Redhat administrator who helped me build the files. In Ubuntu, and even Suse 9.0, the internal support just wasn't there on forums, and worse, not enough built in hardware support. Sure, I may not be a true geek cause I don't like compiling or modifying, and I expect it to work. That's too bad Both computer manufacturers and Linxu developers really need to get together and come up with some rock solid drivers and firmware, then test and re-test. I am shocked that Dell offers Linux distributions, because if they have Celeron processors and these Intel chips, they ought to change the Dell logo to a big question mark. Seriously, the lack of consistency and plug and pray make me shy away from a Dell again, and if I can't get better wireless performance in Linux, I may have to use the dreaded Microsoft Virtual PC 2004 to run Linux in there!!! It's half-tempting to say the least. For all it's promise, Linux has probably caused me more problems than its worth. You can say that's sour grapes on my part. True. But even my cousin the Red Hat administrator agrees, IT'S SUPPOSED TO WORK!!! Friends, please forgive my rant, but I hope that someone out there with any influence is listening!

Potestas, I wish you the best. I may post back here if I find a usable PCMCIA card. I will tell you that Linksys seems to have taken down their GPL code center and upon close search in Google, any USB/Ethernet driver seemed too convoluted to use from some other site. Again, if it doesn't work, screw it. I have heard DLink PCMCIA cards work, mine was dead in the water, or in my case, the slot. Never mind the WPA supplicant. If it doesn't even pick up a signal without encryption, what good is WPA? Wep was iffy at best in CentOS and worked maybe 1 night in Ubuntu for 10 minutes, but knocked off the wired connection. If I saw the little cycling icon in Ubuntu 1 more time for 10 minutes, I was ready to scream.

Overall, I will milk my machine for what it is worth, and in a few years, I will do heavy research on processors and motherboards. I may switch to AMD. At this point, I am ready to use CentOS or Ubuntu only wired, if at all.

duvidel (david-dschwartz) said : #7

I forgot to add that I don't want to use any NDIS wrapper. If a card is going to be recognized and usable, fine. But there are limits to my patience.

potestas (cambra-rob) said : #8

duvidel - I'm with you man! I'm a Microsoft-based IT guy and have built a career around it but love to play with Linux. Unfortunately Linux is just for play now and not ready for the mainstream. I have a wait and see strategy with Linux professionally. Most likely I'll put Ubuntu or some other distro on a desktop and travel the evil empire OS.... for now. It's a shame really.

duvidel (david-dschwartz) said : #9

So much promise, so little gain. I went through CentOS and noticed with firmware that I went around in a circle to get the same packages. Worse, ther e was no clear cut path how to build drivers. I am not a dumb guy. But come on people! Throw me a bone. If I use a Windows .exe file, it will do something. If you want drivers put in a certain place, put them in a .tar or .rpm that is designed to go to the right file! I will stick with CentOS on its previous IPW2200 firmware. I will also try VMware Server (allegedly free as opposed to the VM ESX Server) in Windows to put Linux in there. If there is not a big lag on the operating systems, I may enlarge the Windows and obliterate the Linux. So much for 2 years of practice, and admittedly some pride in learning new tricks.

Again, I find it sad because I was ready to get a Linux+ certification. I was telling friends how proud I was to learn this or that, but with sporadic hardware support, why bother? Even more galling, the Linksys wireless print server worked in Linux, no longer in Windows XP or Vista! I hope somewhere, somehow that hardware manufacturers and Linux driver compilers will really get it together, especially on Wireless N internal cards!

Good luck to you all. I may check back once in awhile, but I am pretty much done here.

duvidel (david-dschwartz) said : #10

Update about the hardware: I did a complete BIOS reset to factory defaults and put in the older wireless chip that came with the pc. The manufacturing date was 07/05 as opposed to the slightly newer 05/06. In my case, I even tried Vista, and the newer chip didn't get recognized, only the older. Some of you folks may want to try the BIOS reset. However, in CentOS, I used the firmware 3.0 - nothing recognized, the firmware labeled ipw2200_1.2.2.tgz (or something to that effect, the 1.2.4, and I will try the 1.20 package that's out there. I hope the 1.2.0 may do the trick because the others still don't get the card recognized. I may go back to Ubuntu 7.0.4 and see if original stock wireless card gets picked up. Right now, I am sadly thinking about Vmware or Virtual PC for Windows and dropping the Linux installs in there because it's no use having useless network connections on a laptop. I need to move on, but hopefully my experience may help another person.