Help to get skype 1.4 to work with pulseaudio?

Asked by Bogdan Butnaru on 2007-08-13

Hello!

I'm having trouble getting Skype 1.4 beta to work. Maybe someone with some experience with Pulseaudio can help me find the problem.

I installed Skype without a problem from the .deb on their site. When I start it there's a slight delay when the window isn't updated, five to ten seconds. Then the window appears, and it looks and works correctly as far as I can tell (menus work, etc), but with no sound whatsoever. I can't start a call, but I don't get any error messages either.

The only thing I found were some weird messages in /var/log/user.log: "Aug 13 20:44:11 cimer pulseaudio[8718]: protocol-esound.c: kicked client with invalid authorization key." As far as I know, I don't use any authorization key.

I can run everything else with sound (Amarok, mplayer, Totem, VLC) without problems. Any ideas where to look next?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Mariano Mara
Solved:
2007-08-17
Last query:
2007-08-17
Last reply:
2007-08-16
Mariano Mara (marplatense) said : #1

Please see this document: http://developer.novell.com/wiki/index.php/Feisty/HOWTO:_PulseAudio
There's a section called "Running Skype" in that document that I suggest trying first.

My other suggestion would be that you try to find some help here: http://forum.skype.com/index.php?s=&showforum=18

Good luck.

Bogdan Butnaru (bogdanb) said : #2

Unfortunately your first link only discusses Skype 1.3, which worked, sort-of, on my computer. Now I can't even downgrade to it (actually, I don't know how), as apt-get insists on installing 1.4 (which it can't find unless I give it the file). Help on that would be welcome, too.

I scoured the forum for help earlier. Apparently it just works with Pulseaudio for most people---which rather annoys me, together with the fact that Skype simply doesn't give me _any_ info on what's wrong besides "problem with audio device"... and I can't find any settings file for it, anything. Grrr...

Mariano Mara (marplatense) said : #3

Hi Bogdan, I saw it's about 1.3 but maybe you can try starting Skype with the option
padsp skype
just to see if it uses Pulse Audio.

The thing is that Skype really spends a lot of time adding code so no one besides them can debug the app. I think you won't get any useful information by your own means.
If the option mentioned up supra does not work, my suggestion is to create an account in the Skype forum and ask the question over there. Maybe somebody -I think Skype's devs log in from time to time- can help you out.

If you want to go back to 1.3 I would say to use Synaptic to fully uninstall your current version, get the 1.3 .deb and install it directly from Nautilus, without using Synaptic.

Good luck

Bogdan Butnaru (bogdanb) said : #4

I'm probably just dense, but I can't for the life of me find the 1.3 deb anywhere on the net. Every link points to the Skype home page which insists on sending me the 1.4 version. Any idea how to get the old package?

(BTW, I did try using padsp, but the 1.4 doesn't support OSS at all, so it doesn't make a difference.)

Best Mariano Mara (marplatense) said : #5

Ok, after searching a bit I found it (I think this version would do the trick): http://www.getautomatix.com/apt/dists/edgy/main/binary-i386/
My advice would be not to download and install Automatix: just download skype_1.3.0.53-1medibuntu1+b1_i386.deb and install it.

Bogdan Butnaru (bogdanb) said : #6

Thanks Mariano Mara, that solved my question.