IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default' --> aptitude package manager is unable to upgrade rhythmbox application

Asked by Sbn on 2010-06-11

Hi! When I try to use synaptic I get this message:

" The package system is broken
Check if you are using third party repositories. If so disable them, since they are a common source of problems. Furthermore run the following command in a Terminal: apt-get install -f "

-and then below under "Details":

" rhythmbox-plugins rhythmbox-plugin-cdrecorder "rhythmbox-plugins rhythmbox-plugin-cdrecorder

This happens no matter if I try to install or remove something. I unchecked all the third party sources and ran sudo apt-get install f which returned this message:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package f

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Sbn
Solved:
2010-06-13
Last query:
2010-06-13
Last reply:
2010-06-11
Sbn (esbenvinsnes) said : #1

I also get this message when trying to fix broken packages in synaptic:

E: /var/cache/apt/archives/rhythmbox_0.12.8-0ubuntu6_i386.deb: subprocess new post-removal script returned error exit status 1

Sbn (esbenvinsnes) said : #2

more info: I tried this command:

sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libxine1-x vcdimager libxine1-misc-plugins libxcb-xv0 libxine1-bin dvdauthor libxine1-ffmpeg libvpx0 libxcb-shape0
  linux-backports-modules-2.6.31-21-generic linux-backports-modules-alsa-2.6.31-21-generic libxcb-shm0 libreadline5
  libxine1-console libxine1
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  rhythmbox
The following packages will be upgraded:
  rhythmbox
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
6 not fully installed or removed.
E: Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the download directory
esben@esben-laptop:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libxine1-x vcdimager libxine1-misc-plugins libxcb-xv0 libxine1-bin dvdauthor libxine1-ffmpeg libvpx0 libxcb-shape0
  linux-backports-modules-2.6.31-21-generic linux-backports-modules-alsa-2.6.31-21-generic libxcb-shm0 libreadline5
  libxine1-console libxine1
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  rhythmbox
The following packages will be upgraded:
  rhythmbox
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
6 not fully installed or removed.
Need to get 0B/1,226kB of archives.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 148659 files and directories currently installed.)
Preparing to replace rhythmbox 0.12.8-0ubuntu5 (using .../rhythmbox_0.12.8-0ubuntu6_i386.deb) ...
Unpacking replacement rhythmbox ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: warning: old post-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing /var/cache/apt/archives/rhythmbox_0.12.8-0ubuntu6_i386.deb (--unpack):
 subprocess new post-removal script returned error exit status 1
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Processing triggers for hicolor-icon-theme ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for desktop-file-utils ...
Processing triggers for man-db ...
Processing triggers for python-support ...
Errors were encountered while processing:
 /var/cache/apt/archives/rhythmbox_0.12.8-0ubuntu6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hi,

First please make sure to close all open programs, including all package managers like Synaptic, Add/remove programs, etc ...

Then please try this procedure:

Step 1: Open Terminal from "Applications->Accessories->
Terminal"

Step 2: Please COPY-PASTE each line below into the Terminal then hit <enter> after each line)

Tip: If you have a wheel mouse or 3 button mouse, you do not need to type commands into the Terminal. Highlight the command written on the webpage. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

cat /etc/lsb-release
uname -a
sudo rm /var/lib/apt/lists/lock
sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
sudo rm -rf /var/lib/dpkg/updates/*
sudo rm -rf /var/lib/apt/lists
sudo mkdir /var/lib/apt/lists
sudo mkdir /var/lib/apt/lists/partial
LANG=C;sudo aptitude clean
LANG=C;sudo aptitude autoclean
LANG=C;sudo apt-get update
sudo dpkg --clear-avail
sudo dpkg --configure -a
LANG=C;sudo aptitude install -f
LANG=C;sudo aptitude update
LANG=C;sudo aptitude dist-upgrade

Step 3: Please post results (copy/paste terminal output from each command) on this thread

Hope it helps,

Regards,

Mark

Sbn (esbenvinsnes) said : #4

Ok, here it is:

esben@esben-laptop:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04 LTS"
esben@esben-laptop:~$ uname -a
Linux esben-laptop 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 22:02:19 UTC 2010 i686 GNU/Linux
esben@esben-laptop:~$ sudo rm /var/lib/apt/lists/lock
rm: cannot remove `/var/lib/apt/lists/lock': No such file or directory
esben@esben-laptop:~$ sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
esben@esben-laptop:~$ sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
esben@esben-laptop:~$ sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
esben@esben-laptop:~$ sudo rm -rf /var/lib/dpkg/updates/*
esben@esben-laptop:~$ sudo rm -rf /var/lib/apt/lists
esben@esben-laptop:~$ sudo mkdir /var/lib/apt/lists
esben@esben-laptop:~$ sudo mkdir /var/lib/apt/lists/partial
esben@esben-laptop:~$ LANG=C;sudo aptitude clean
Reading package lists... Done
Building dependency tree
Reading state information... Done
Initializing package states... Done
Writing extended state information... Done
esben@esben-laptop:~$ LANG=C;sudo aptitude autoclean
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Freed 0B of disk space
esben@esben-laptop:~$ LANG=C;sudo apt-get update
Get:1 http://no.archive.ubuntu.com lucid Release.gpg [189B]
Get:2 http://no.archive.ubuntu.com lucid-updates Release.gpg [189B]
Get:3 http://archive.canonical.com lucid Release.gpg [189B]
Get:4 http://no.archive.ubuntu.com lucid Release [57.2kB]
Get:5 http://security.ubuntu.com lucid-security Release.gpg [189B]
Get:6 http://archive.canonical.com lucid Release [8203B]
Get:7 http://no.archive.ubuntu.com lucid-updates Release [38.5kB]
Get:8 http://archive.canonical.com lucid/partner Packages [10.2kB]
Get:9 http://no.archive.ubuntu.com lucid/main Packages [1386kB]
Get:10 http://archive.canonical.com lucid/partner Sources [2824B]
Get:11 http://security.ubuntu.com lucid-security Release [38.5kB]
Get:12 http://security.ubuntu.com lucid-security/main Packages [34.6kB]
Get:13 http://security.ubuntu.com lucid-security/restricted Packages [14B]
Get:14 http://security.ubuntu.com lucid-security/main Sources [11.2kB]
Get:15 http://security.ubuntu.com lucid-security/restricted Sources [14B]
Get:16 http://security.ubuntu.com lucid-security/universe Packages [13.2kB]
Get:17 http://security.ubuntu.com lucid-security/universe Sources [2013B]
Get:18 http://security.ubuntu.com lucid-security/multiverse Packages [14B]
Get:19 http://security.ubuntu.com lucid-security/multiverse Sources [14B]
Get:20 http://no.archive.ubuntu.com lucid/restricted Packages [6208B]
Get:21 http://no.archive.ubuntu.com lucid/main Sources [659kB]
Get:22 http://no.archive.ubuntu.com lucid/restricted Sources [3775B]
Get:23 http://no.archive.ubuntu.com lucid/universe Packages [5448kB]
Get:24 http://no.archive.ubuntu.com lucid/universe Sources [3165kB]
Get:25 http://no.archive.ubuntu.com lucid/multiverse Packages [180kB]
Get:26 http://no.archive.ubuntu.com lucid/multiverse Sources [119kB]
Get:27 http://no.archive.ubuntu.com lucid-updates/main Packages [193kB]
Get:28 http://no.archive.ubuntu.com lucid-updates/restricted Packages [2102B]
Get:29 http://no.archive.ubuntu.com lucid-updates/main Sources [75.3kB]
Get:30 http://no.archive.ubuntu.com lucid-updates/restricted Sources [737B]
Get:31 http://no.archive.ubuntu.com lucid-updates/universe Packages [46.5kB]
Get:32 http://no.archive.ubuntu.com lucid-updates/universe Sources [12.8kB]
Get:33 http://no.archive.ubuntu.com lucid-updates/multiverse Packages [632B]
Get:34 http://no.archive.ubuntu.com lucid-updates/multiverse Sources [14B]
Fetched 11.5MB in 31s (365kB/s)
Reading package lists... Done
esben@esben-laptop:~$ sudo dpkg --clear-avail
esben@esben-laptop:~$ sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of rhythmbox-plugins:
 rhythmbox-plugins depends on rhythmbox (= 0.12.8-0ubuntu6); however:
  Package rhythmbox is not installed.
dpkg: error processing rhythmbox-plugins (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of rhythmbox-plugin-coherence:
 rhythmbox-plugin-coherence depends on rhythmbox (>= 0.12); however:
  Package rhythmbox is not installed.
 rhythmbox-plugin-coherence depends on rhythmbox (<< 0.13); however:
  Package rhythmbox is not installed.
dpkg: error processing rhythmbox-plugin-coherence (--configure):
 dependency problems - leaving unconfigured
Setting up gnome-panel-data (1:2.30.0-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing gnome-panel-data (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of rhythmbox-plugin-cdrecorder:
 rhythmbox-plugin-cdrecorder depends on rhythmbox (= 0.12.8-0ubuntu6); however:
  Package rhythmbox is not installed.
dpkg: error processing rhythmbox-plugin-cdrecorder (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-panel-data (>= 1:2.30); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 1:2.31); however:
  Package gnome-panel-data is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 rhythmbox-plugins
 rhythmbox-plugin-coherence
 gnome-panel-data
 rhythmbox-plugin-cdrecorder
 gnome-panel
esben@esben-laptop:~$ LANG=C;sudo aptitude install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  rhythmbox-plugin-cdrecorder rhythmbox-plugins
The following packages will be REMOVED:
  dvdauthor{u} libreadline5{u} libvpx0{u} libxcb-shape0{u}
  libxcb-shm0{u} libxcb-xv0{u} libxine1{u} libxine1-bin{u}
  libxine1-console{u} libxine1-ffmpeg{u}
  libxine1-misc-plugins{u} libxine1-x{u}
  linux-backports-modules-2.6.31-21-generic{u}
  linux-backports-modules-alsa-2.6.31-21-generic{u}
  vcdimager{u}
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data rhythmbox-plugin-coherence
0 packages upgraded, 0 newly installed, 15 to remove and 1 not upgraded.
Need to get 0B of archives. After unpacking 21.4MB will be freed.
The following packages have unmet dependencies:
  rhythmbox-plugin-cdrecorder: Depends: rhythmbox (= 0.12.8-0ubuntu6) but 0.12.8-0ubuntu5 is installed and it is kept back.
  rhythmbox-plugins: Depends: rhythmbox (= 0.12.8-0ubuntu6) but 0.12.8-0ubuntu5 is installed and it is kept back.
E: I wasn't able to locate file for the rhythmbox package. This might mean you need to manually fix this package.
The following actions will resolve these dependencies:

Upgrade the following packages:
rhythmbox [0.12.8-0ubuntu5 (now) -> 0.12.8-0ubuntu6 (lucid-updates)]

Score is 120

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  dvdauthor{u} libreadline5{u} libvpx0{u} libxcb-shape0{u}
  libxcb-shm0{u} libxcb-xv0{u} libxine1{u} libxine1-bin{u}
  libxine1-console{u} libxine1-ffmpeg{u}
  libxine1-misc-plugins{u} libxine1-x{u}
  linux-backports-modules-2.6.31-21-generic{u}
  linux-backports-modules-alsa-2.6.31-21-generic{u}
  vcdimager{u}
The following packages will be upgraded:
  rhythmbox
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data rhythmbox-plugin-cdrecorder
  rhythmbox-plugin-coherence rhythmbox-plugins
1 packages upgraded, 0 newly installed, 15 to remove and 0 not upgraded.
Need to get 1226kB of archives. After unpacking 21.4MB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
Get:1 http://no.archive.ubuntu.com/ubuntu/ lucid-updates/main rhythmbox 0.12.8-0ubuntu6 [1226kB]
Fetched 1226kB in 3s (379kB/s)
(Reading database ... 148659 files and directories currently installed.)
Preparing to replace rhythmbox 0.12.8-0ubuntu5 (using .../rhythmbox_0.12.8-0ubuntu6_i386.deb) ...
Unpacking replacement rhythmbox ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: warning: old post-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing /var/cache/apt/archives/rhythmbox_0.12.8-0ubuntu6_i386.deb (--unpack):
 subprocess new post-removal script returned error exit status 1
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Processing triggers for hicolor-icon-theme ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.C.cache...
Processing triggers for desktop-file-utils ...
Processing triggers for man-db ...
Processing triggers for python-support ...
Errors were encountered while processing:
 /var/cache/apt/archives/rhythmbox_0.12.8-0ubuntu6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
dpkg: dependency problems prevent configuration of rhythmbox-plugins:
 rhythmbox-plugins depends on rhythmbox (= 0.12.8-0ubuntu6); however:
  Package rhythmbox is not installed.
dpkg: error processing rhythmbox-plugins (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of rhythmbox-plugin-coherence:
 rhythmbox-plugin-coherence depends on rhythmbox (>= 0.12); however:
  Package rhythmbox is not installed.
 rhythmbox-plugin-coherence depends on rhythmbox (<< 0.13); however:
  Package rhythmbox is not installed.
dpkg: error processing rhythmbox-plugin-coherence (--configure):
 dependency problems - leaving unconfigured
Setting up gnome-panel-data (1:2.30.0-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing gnome-panel-data (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of rhythmbox-plugin-cdrecorder:
 rhythmbox-plugin-cdrecorder depends on rhythmbox (= 0.12.8-0ubuntu6); however:
  Package rhythmbox is not installed.
dpkg: error processing rhythmbox-plugin-cdrecorder (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-panel-data (>= 1:2.30); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 1:2.31); however:
  Package gnome-panel-data is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 rhythmbox-plugins
 rhythmbox-plugin-coherence
 gnome-panel-data
 rhythmbox-plugin-cdrecorder
 gnome-panel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

esben@esben-laptop:~$ LANG=C;sudo aptitude update
Hit http://no.archive.ubuntu.com lucid Release.gpg
Hit http://no.archive.ubuntu.com lucid-updates Release.gpg
Hit http://archive.canonical.com lucid Release.gpg
Hit http://no.archive.ubuntu.com lucid Release
Hit http://archive.canonical.com lucid Release
Hit http://security.ubuntu.com lucid-security Release.gpg
Hit http://no.archive.ubuntu.com lucid-updates Release
Hit http://security.ubuntu.com lucid-security Release
Hit http://no.archive.ubuntu.com lucid/main Packages
Hit http://no.archive.ubuntu.com lucid/restricted Packages
Hit http://no.archive.ubuntu.com lucid/main Sources
Hit http://no.archive.ubuntu.com lucid/restricted Sources
Hit http://no.archive.ubuntu.com lucid/universe Packages
Hit http://no.archive.ubuntu.com lucid/universe Sources
Hit http://no.archive.ubuntu.com lucid/multiverse Packages
Hit http://no.archive.ubuntu.com lucid/multiverse Sources
Hit http://archive.canonical.com lucid/partner Packages
Hit http://no.archive.ubuntu.com lucid-updates/main Packages
Hit http://no.archive.ubuntu.com lucid-updates/restricted Packages
Hit http://no.archive.ubuntu.com lucid-updates/main Sources
Hit http://no.archive.ubuntu.com lucid-updates/restricted Sources
Hit http://no.archive.ubuntu.com lucid-updates/universe Packages
Hit http://no.archive.ubuntu.com lucid-updates/universe Sources
Hit http://no.archive.ubuntu.com lucid-updates/multiverse Packages
Hit http://security.ubuntu.com lucid-security/main Packages
Hit http://no.archive.ubuntu.com lucid-updates/multiverse Sources
Hit http://archive.canonical.com lucid/partner Sources
Hit http://security.ubuntu.com lucid-security/restricted Packages
Hit http://security.ubuntu.com lucid-security/main Sources
Hit http://security.ubuntu.com lucid-security/restricted Sources
Hit http://security.ubuntu.com lucid-security/universe Packages
Hit http://security.ubuntu.com lucid-security/universe Sources
Hit http://security.ubuntu.com lucid-security/multiverse Packages
Hit http://security.ubuntu.com lucid-security/multiverse Sources
Reading package lists... Done

esben@esben-laptop:~$ LANG=C;sudo aptitude dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages will be REMOVED:
  dvdauthor{u} libreadline5{u} libvpx0{u} libxcb-shape0{u}
  libxcb-shm0{u} libxcb-xv0{u} libxine1{u} libxine1-bin{u}
  libxine1-console{u} libxine1-ffmpeg{u}
  libxine1-misc-plugins{u} libxine1-x{u}
  linux-backports-modules-2.6.31-21-generic{u}
  linux-backports-modules-alsa-2.6.31-21-generic{u}
  vcdimager{u}
The following packages will be upgraded:
  rhythmbox
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data rhythmbox-plugin-cdrecorder
  rhythmbox-plugin-coherence rhythmbox-plugins
1 packages upgraded, 0 newly installed, 15 to remove and 0 not upgraded.
Need to get 0B/1226kB of archives. After unpacking 21.4MB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
(Reading database ... 148659 files and directories currently installed.)
Preparing to replace rhythmbox 0.12.8-0ubuntu5 (using .../rhythmbox_0.12.8-0ubuntu6_i386.deb) ...
Unpacking replacement rhythmbox ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: warning: old post-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing /var/cache/apt/archives/rhythmbox_0.12.8-0ubuntu6_i386.deb (--unpack):
 subprocess new post-removal script returned error exit status 1
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Processing triggers for hicolor-icon-theme ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.C.cache...
Processing triggers for desktop-file-utils ...
Processing triggers for man-db ...
Processing triggers for python-support ...
Errors were encountered while processing:
 /var/cache/apt/archives/rhythmbox_0.12.8-0ubuntu6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
dpkg: dependency problems prevent configuration of rhythmbox-plugins:
 rhythmbox-plugins depends on rhythmbox (= 0.12.8-0ubuntu6); however:
  Package rhythmbox is not installed.
dpkg: error processing rhythmbox-plugins (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of rhythmbox-plugin-coherence:
 rhythmbox-plugin-coherence depends on rhythmbox (>= 0.12); however:
  Package rhythmbox is not installed.
 rhythmbox-plugin-coherence depends on rhythmbox (<< 0.13); however:
  Package rhythmbox is not installed.
dpkg: error processing rhythmbox-plugin-coherence (--configure):
 dependency problems - leaving unconfigured
Setting up gnome-panel-data (1:2.30.0-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing gnome-panel-data (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of rhythmbox-plugin-cdrecorder:
 rhythmbox-plugin-cdrecorder depends on rhythmbox (= 0.12.8-0ubuntu6); however:
  Package rhythmbox is not installed.
dpkg: error processing rhythmbox-plugin-cdrecorder (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-panel-data (>= 1:2.30); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 1:2.31); however:
  Package gnome-panel-data is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 rhythmbox-plugins
 rhythmbox-plugin-coherence
 gnome-panel-data
 rhythmbox-plugin-cdrecorder
 gnome-panel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

Please send us the output of the following command as well:

 sudo aptitude purge rhythmbox rhythmbox-plugin-cdrecorder rhythmbox-plugin-coherence rhythmbox-plugins

Then rerun the following commands:

LANG=C;sudo aptitude install -f
LANG=C;sudo aptitude update
LANG=C;sudo aptitude dist-upgrade

Make sure to run the following command before running the aptitude purge command:

sudo touch /usr/share/gconf/defaults/20_une-gconf-default

Sbn (esbenvinsnes) said : #7

well, I didn't see the last message before it was too late so here is the output:

esben@esben-laptop:~$ sudo aptitude purge rhythmbox rhythmbox-plugin-cdrecorder rhythmbox-
[sudo] password for esben:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  rhythmbox-plugin-coherence rhythmbox-plugins
  rhythmbox-radio-browser
The following packages will be REMOVED:
  dvdauthor{u} libreadline5{u} libvpx0{u} libxcb-shape0{u}
  libxcb-shm0{u} libxcb-xv0{u} libxine1{u} libxine1-bin{u}
  libxine1-console{u} libxine1-ffmpeg{u}
  libxine1-misc-plugins{u} libxine1-x{u}
  linux-backports-modules-2.6.31-21-generic{u}
  linux-backports-modules-alsa-2.6.31-21-generic{u}
  rhythmbox rhythmbox-plugin-cdrecorder{p} vcdimager{u}
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
0 packages upgraded, 0 newly installed, 17 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 36.8MB will be freed.
The following packages have unmet dependencies:
  rhythmbox-radio-browser: Depends: rhythmbox but it is not installable
  rhythmbox-plugin-coherence: Depends: rhythmbox (>= 0.12) but it is not installable
                              Depends: rhythmbox (< 0.13) but it is not installable
  rhythmbox-plugins: Depends: rhythmbox (= 0.12.8-0ubuntu6) but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
rhythmbox-plugin-coherence
rhythmbox-plugins
rhythmbox-radio-browser
rhythmbox-ubuntuone-music-store

Score is -32

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  dvdauthor{u} libboost-python1.40.0{u} libreadline5{u}
  libubuntuone-1.0-1{u} libvpx0{u} libxcb-shape0{u}
  libxcb-shm0{u} libxcb-xv0{u} libxine1{u} libxine1-bin{u}
  libxine1-console{u} libxine1-ffmpeg{u}
  libxine1-misc-plugins{u} libxine1-x{u}
  linux-backports-modules-2.6.31-21-generic{u}
  linux-backports-modules-alsa-2.6.31-21-generic{u}
  python-axiom{u} python-clientform{u} python-coherence{u}
  python-configobj{u} python-epsilon{u} python-louie{u}
  python-mechanize{u} python-nevow{u} python-pyasn1{u}
  python-pysqlite2{u} python-tagpy{u}
  python-twisted-conch{u} python-ubuntuone{u} rhythmbox
  rhythmbox-plugin-cdrecorder{p}
  rhythmbox-plugin-coherence{a} rhythmbox-plugins{a}
  rhythmbox-radio-browser{a}
  rhythmbox-ubuntuone-music-store{a} streamripper{u}
  vcdimager{u}
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
0 packages upgraded, 0 newly installed, 37 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 54.4MB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
(Reading database ... 148658 files and directories currently installed.)
Removing rhythmbox-plugin-coherence ...
Removing rhythmbox-ubuntuone-music-store ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing rhythmbox-ubuntuone-music-store (--remove):
 subprocess installed post-removal script returned error exit status 1
Removing rhythmbox-plugins ...
Errors were encountered while processing:
 rhythmbox-ubuntuone-music-store
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up gnome-panel-data (1:2.30.0-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing gnome-panel-data (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of rhythmbox-plugin-cdrecorder:
 rhythmbox-plugin-cdrecorder depends on rhythmbox (= 0.12.8-0ubuntu6); however:
  Package rhythmbox is not installed.
dpkg: error processing rhythmbox-plugin-cdrecorder (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-panel-data (>= 1:2.30); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 1:2.31); however:
  Package gnome-panel-data is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gnome-panel-data
 rhythmbox-plugin-cdrecorder
 gnome-panel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

esben@esben-laptop:~$ LANG=C;sudo aptitude install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages will be REMOVED:
  dvdauthor{u} libboost-python1.40.0{u} libreadline5{u}
  libubuntuone-1.0-1{u} libvpx0{u} libxcb-shape0{u}
  libxcb-shm0{u} libxcb-xv0{u} libxine1{u} libxine1-bin{u}
  libxine1-console{u} libxine1-ffmpeg{u}
  libxine1-misc-plugins{u} libxine1-x{u}
  linux-backports-modules-2.6.31-21-generic{u}
  linux-backports-modules-alsa-2.6.31-21-generic{u}
  python-axiom{u} python-clientform{u} python-coherence{u}
  python-configobj{u} python-epsilon{u} python-louie{u}
  python-mechanize{u} python-nevow{u} python-pyasn1{u}
  python-pysqlite2{u} python-tagpy{u}
  python-twisted-conch{u} python-ubuntuone{u} rhythmbox
  rhythmbox-plugin-cdrecorder{p}
  rhythmbox-radio-browser{a}
  rhythmbox-ubuntuone-music-store{a} streamripper{u}
  vcdimager{u}
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
0 packages upgraded, 0 newly installed, 35 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 52.3MB will be freed.
Do you want to continue? [Y/n/?] y
(Reading database ... 148475 files and directories currently installed.)
Removing rhythmbox-plugin-cdrecorder ...
(Reading database ... 148464 files and directories currently installed.)
Removing rhythmbox-radio-browser ...
dpkg: error processing rhythmbox (--remove):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Removing rhythmbox-ubuntuone-music-store ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing rhythmbox-ubuntuone-music-store (--remove):
 subprocess installed post-removal script returned error exit status 1
Removing dvdauthor ...
Removing python-coherence ...
Removing python-tagpy ...
Removing libboost-python1.40.0 ...
Removing libreadline5 ...
Removing python-ubuntuone ...
Removing libubuntuone-1.0-1 ...
Removing libvpx0 ...
Removing libxine1 ...
Removing libxine1-x ...
Removing libxcb-shape0 ...
Removing libxcb-shm0 ...
Removing libxcb-xv0 ...
Removing libxine1-misc-plugins ...
Removing libxine1-ffmpeg ...
Removing libxine1-console ...
Removing libxine1-bin ...
Removing linux-backports-modules-2.6.31-21-generic ...
update-initramfs: Generating /boot/initrd.img-2.6.31-21-generic
Removing linux-backports-modules-alsa-2.6.31-21-generic ...
update-initramfs: Generating /boot/initrd.img-2.6.31-21-generic
Removing python-axiom ...
Removing python-mechanize ...
Removing python-clientform ...
Removing python-configobj ...
Removing python-epsilon ...
Removing python-louie ...
Removing python-nevow ...
Removing python-twisted-conch ...
Removing python-pyasn1 ...
Removing python-pysqlite2 ...
Removing streamripper ...
Removing vcdimager ...
Processing triggers for man-db ...
Processing triggers for python-support ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for doc-base ...
Processing 2 removed doc-base file(s)...
Registering documents with scrollkeeper...
Processing triggers for python-twisted-core ...
Processing triggers for install-info ...
Processing triggers for python-central ...
Errors were encountered while processing:
 rhythmbox
 rhythmbox-ubuntuone-music-store
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up gnome-panel-data (1:2.30.0-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing gnome-panel-data (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-panel-data (>= 1:2.30); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 1:2.31); however:
  Package gnome-panel-data is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gnome-panel-data
 gnome-panel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

Current status: 1 broken [-1].
esben@esben-laptop:~$ LANG=C;sudo aptitude update
Hit http://no.archive.ubuntu.com lucid Release.gpg
Get:1 http://no.archive.ubuntu.com lucid-updates Release.gpg [189B]
Hit http://no.archive.ubuntu.com lucid Release
Hit http://archive.canonical.com lucid Release.gpg
Get:2 http://security.ubuntu.com lucid-security Release.gpg [189B]
Get:3 http://no.archive.ubuntu.com lucid-updates Release [38.5kB]
Hit http://archive.canonical.com lucid Release
Get:4 http://security.ubuntu.com lucid-security Release [38.5kB]
Hit http://no.archive.ubuntu.com lucid/main Packages
Hit http://no.archive.ubuntu.com lucid/restricted Packages
Hit http://no.archive.ubuntu.com lucid/main Sources
Hit http://archive.canonical.com lucid/partner Packages
Hit http://no.archive.ubuntu.com lucid/restricted Sources
Hit http://no.archive.ubuntu.com lucid/universe Packages
Hit http://no.archive.ubuntu.com lucid/universe Sources
Hit http://no.archive.ubuntu.com lucid/multiverse Packages
Hit http://no.archive.ubuntu.com lucid/multiverse Sources
Get:5 http://no.archive.ubuntu.com lucid-updates/main Packages [196kB]
Hit http://archive.canonical.com lucid/partner Sources
Get:6 http://security.ubuntu.com lucid-security/main Packages [34.6kB]
Get:7 http://no.archive.ubuntu.com lucid-updates/restricted Packages [2102B]
Get:8 http://no.archive.ubuntu.com lucid-updates/main Sources [76.0kB]
Get:9 http://no.archive.ubuntu.com lucid-updates/restricted Sources [737B]
Get:10 http://no.archive.ubuntu.com lucid-updates/universe Packages [47.2kB]
Get:11 http://no.archive.ubuntu.com lucid-updates/universe Sources [13.1kB]
Get:12 http://no.archive.ubuntu.com lucid-updates/multiverse Packages [632B]
Get:13 http://no.archive.ubuntu.com lucid-updates/multiverse Sources [14B]
Get:14 http://security.ubuntu.com lucid-security/restricted Packages [14B]
Get:15 http://security.ubuntu.com lucid-security/main Sources [11.2kB]
Get:16 http://security.ubuntu.com lucid-security/restricted Sources [14B]
Get:17 http://security.ubuntu.com lucid-security/universe Packages [13.2kB]
Get:18 http://security.ubuntu.com lucid-security/universe Sources [2013B]
Get:19 http://security.ubuntu.com lucid-security/multiverse Packages [1668B]
Get:20 http://security.ubuntu.com lucid-security/multiverse Sources [580B]
Fetched 477kB in 1s (265kB/s)
Reading package lists... Done

Current status: 9 updates [+8], 28494 new [+1].
esben@esben-laptop:~$ LANG=C;sudo aptitude dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  rhythmbox-ubuntuone-music-store
The following packages will be upgraded:
  openssh-client pm-utils-powersave-policy
  python-ubuntuone-client rhythmbox ssh-askpass-gnome
  ubuntuone-client ubuntuone-client-gnome update-manager
  update-manager-core
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
The following packages are RECOMMENDED but will NOT be installed:
  rhythmbox-plugin-cdrecorder rhythmbox-plugins
9 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 2124kB/3350kB of archives. After unpacking 12.3kB will be used.
The following packages have unmet dependencies:
  rhythmbox-ubuntuone-music-store: Depends: libubuntuone-1.0-1 (>= 0.2.100) but it is not installable
                                   Depends: python-ubuntuone (>= 0.2.100) but it is not installable
                                   Depends: rhythmbox-plugins but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
rhythmbox-ubuntuone-music-store

Score is 121

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  rhythmbox-ubuntuone-music-store{a}
The following packages will be upgraded:
  openssh-client pm-utils-powersave-policy
  python-ubuntuone-client rhythmbox ssh-askpass-gnome
  ubuntuone-client ubuntuone-client-gnome update-manager
  update-manager-core
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
The following packages are RECOMMENDED but will NOT be installed:
  rhythmbox-plugin-cdrecorder rhythmbox-plugins
9 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 2112kB/3338kB of archives. After unpacking 311kB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
Get:1 http://no.archive.ubuntu.com/ubuntu/ lucid-updates/main openssh-client 1:5.3p1-3ubuntu4 [761kB]
Get:2 http://no.archive.ubuntu.com/ubuntu/ lucid-updates/main update-manager 1:0.134.9 [802kB]
Get:3 http://no.archive.ubuntu.com/ubuntu/ lucid-updates/main update-manager-core 1:0.134.9 [196kB]
Get:4 http://no.archive.ubuntu.com/ubuntu/ lucid-updates/main pm-utils-powersave-policy 0.3.1 [2788B]
Get:5 http://no.archive.ubuntu.com/ubuntu/ lucid-updates/main ubuntuone-client-gnome 1.2.1-0ubuntu3 [88.9kB]
Get:6 http://no.archive.ubuntu.com/ubuntu/ lucid-updates/main ubuntuone-client 1.2.1-0ubuntu3 [23.6kB]
Get:7 http://no.archive.ubuntu.com/ubuntu/ lucid-updates/main python-ubuntuone-client 1.2.1-0ubuntu3 [151kB]
Get:8 http://no.archive.ubuntu.com/ubuntu/ lucid-updates/main ssh-askpass-gnome 1:5.3p1-3ubuntu4 [86.7kB]
Fetched 2112kB in 6s (305kB/s)
(Reading database ... 146593 files and directories currently installed.)
Removing rhythmbox-ubuntuone-music-store ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing rhythmbox-ubuntuone-music-store (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 rhythmbox-ubuntuone-music-store
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up gnome-panel-data (1:2.30.0-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing gnome-panel-data (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-panel-data (>= 1:2.30); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 1:2.31); however:
  Package gnome-panel-data is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gnome-panel-data
 gnome-panel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

esben@esben-laptop:~$

As I wrote before, run this sequence:

sudo touch /usr/share/gconf/defaults/20_une-gconf-default

sudo aptitude purge rhythmbox rhythmbox-plugin-cdrecorder rhythmbox-plugin-coherence rhythmbox-plugins

Then rerun the following commands:

LANG=C;sudo aptitude install -f
LANG=C;sudo aptitude update
LANG=C;sudo aptitude dist-upgrade

Sbn (esbenvinsnes) said : #9

Ok, thanks Mark, here it is:

esben@esben-laptop:~$ sudo touch /usr/share/gconf/defaults/20_une-gconf-default
[sudo] password for esben:
touch: cannot touch `/usr/share/gconf/defaults/20_une-gconf-default': No such file or directory
esben@esben-laptop:~$ sudo aptitude purge rhythmbox rhythmbox-plugin-cdrecorder rhythmbox-plugin-coherence rhythmbox-plugins
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  rhythmbox-ubuntuone-music-store
The following packages will be REMOVED:
  rhythmbox{p}
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
0 packages upgraded, 0 newly installed, 1 to remove and 8 not upgraded.
Need to get 12.3kB of archives. After unpacking 15.3MB will be freed.
The following packages have unmet dependencies:
  rhythmbox-ubuntuone-music-store: Depends: libubuntuone-1.0-1 (>= 0.2.100) but it is not installable
                                   Depends: python-ubuntuone (>= 0.2.100) but it is not installable
                                   Depends: rhythmbox-plugins but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
rhythmbox-ubuntuone-music-store

Score is 121

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  rhythmbox{p} rhythmbox-ubuntuone-music-store{a}
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
0 packages upgraded, 0 newly installed, 2 to remove and 8 not upgraded.
Need to get 0B of archives. After unpacking 15.6MB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
dpkg: error processing rhythmbox (--purge):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
 rhythmbox
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up gnome-panel-data (1:2.30.0-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing gnome-panel-data (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-panel-data (>= 1:2.30); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 1:2.31); however:
  Package gnome-panel-data is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gnome-panel-data
 gnome-panel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

esben@esben-laptop:~$ LANG=C;sudo aptitude install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages will be REMOVED:
  rhythmbox{p} rhythmbox-ubuntuone-music-store{a}
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
0 packages upgraded, 0 newly installed, 2 to remove and 8 not upgraded.
Need to get 0B of archives. After unpacking 15.6MB will be freed.
Do you want to continue? [Y/n/?] y
dpkg: error processing rhythmbox (--purge):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
 rhythmbox
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up gnome-panel-data (1:2.30.0-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing gnome-panel-data (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-panel-data (>= 1:2.30); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 1:2.31); however:
  Package gnome-panel-data is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gnome-panel-data
 gnome-panel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

esben@esben-laptop:~$ LANG=C;sudo aptitude update
Hit http://archive.canonical.com lucid Release.gpg
Hit http://no.archive.ubuntu.com lucid Release.gpg
Hit http://no.archive.ubuntu.com lucid-updates Release.gpg
Hit http://archive.canonical.com lucid Release
Hit http://no.archive.ubuntu.com lucid Release
Hit http://security.ubuntu.com lucid-security Release.gpg
Hit http://no.archive.ubuntu.com lucid-updates Release
Hit http://archive.canonical.com lucid/partner Packages
Hit http://no.archive.ubuntu.com lucid/main Packages
Hit http://security.ubuntu.com lucid-security Release
Hit http://no.archive.ubuntu.com lucid/restricted Packages
Hit http://no.archive.ubuntu.com lucid/main Sources
Hit http://no.archive.ubuntu.com lucid/restricted Sources
Hit http://no.archive.ubuntu.com lucid/universe Packages
Hit http://no.archive.ubuntu.com lucid/universe Sources
Hit http://archive.canonical.com lucid/partner Sources
Hit http://no.archive.ubuntu.com lucid/multiverse Packages
Hit http://no.archive.ubuntu.com lucid/multiverse Sources
Hit http://no.archive.ubuntu.com lucid-updates/main Packages
Hit http://no.archive.ubuntu.com lucid-updates/restricted Packages
Hit http://no.archive.ubuntu.com lucid-updates/main Sources
Hit http://security.ubuntu.com lucid-security/main Packages
Hit http://no.archive.ubuntu.com lucid-updates/restricted Sources
Hit http://no.archive.ubuntu.com lucid-updates/universe Packages
Hit http://no.archive.ubuntu.com lucid-updates/universe Sources
Hit http://no.archive.ubuntu.com lucid-updates/multiverse Packages
Hit http://no.archive.ubuntu.com lucid-updates/multiverse Sources
Hit http://security.ubuntu.com lucid-security/restricted Packages
Hit http://security.ubuntu.com lucid-security/main Sources
Hit http://security.ubuntu.com lucid-security/restricted Sources
Hit http://security.ubuntu.com lucid-security/universe Packages
Hit http://security.ubuntu.com lucid-security/universe Sources
Hit http://security.ubuntu.com lucid-security/multiverse Packages
Hit http://security.ubuntu.com lucid-security/multiverse Sources
Reading package lists... Done

esben@esben-laptop:~$ LANG=C;sudo aptitude dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  rhythmbox-ubuntuone-music-store
The following packages will be upgraded:
  openssh-client pm-utils-powersave-policy
  python-ubuntuone-client rhythmbox ssh-askpass-gnome
  ubuntuone-client ubuntuone-client-gnome
  update-manager update-manager-core
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
The following packages are RECOMMENDED but will NOT be installed:
  rhythmbox-plugin-cdrecorder rhythmbox-plugins
9 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 12.3kB/3350kB of archives. After unpacking 12.3kB will be used.
The following packages have unmet dependencies:
  rhythmbox-ubuntuone-music-store: Depends: libubuntuone-1.0-1 (>= 0.2.100) but it is not installable
                                   Depends: python-ubuntuone (>= 0.2.100) but it is not installable
                                   Depends: rhythmbox-plugins but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
rhythmbox-ubuntuone-music-store

Score is 121

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  rhythmbox-ubuntuone-music-store{a}
The following packages will be upgraded:
  openssh-client pm-utils-powersave-policy
  python-ubuntuone-client rhythmbox ssh-askpass-gnome
  ubuntuone-client ubuntuone-client-gnome
  update-manager update-manager-core
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
The following packages are RECOMMENDED but will NOT be installed:
  rhythmbox-plugin-cdrecorder rhythmbox-plugins
9 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0B/3338kB of archives. After unpacking 311kB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
(Reading database ... 146593 files and directories currently installed.)
Removing rhythmbox-ubuntuone-music-store ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing rhythmbox-ubuntuone-music-store (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 rhythmbox-ubuntuone-music-store
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up gnome-panel-data (1:2.30.0-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing gnome-panel-data (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-panel-data (>= 1:2.30); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 1:2.31); however:
  Package gnome-panel-data is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gnome-panel-data
 gnome-panel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

esben@esben-laptop:~$

Hmmm I guess we need a little more patience and an even longer procedure ;-)

Try this command:

sudo mkdir /usr; sudo mkdir /usr/share; sudo mkdir /usr/share/gconf; sudo mkdir /usr/share/gconf/defaults; sudo touch /usr/share/gconf/defaults/20_une-gconf-default

Then rerun this command:

sudo aptitude purge rhythmbox rhythmbox-plugin-cdrecorder rhythmbox-plugin-coherence rhythmbox-plugins

Then rerun the following commands:

LANG=C;sudo aptitude install -f
LANG=C;sudo aptitude update
LANG=C;sudo aptitude dist-upgrade

I have a feeling this may solve the package manager issue for good. If not, then I am out of idea's.....

Sbn (esbenvinsnes) said : #11

esben@esben-laptop:~$ sudo mkdir /usr; sudo mkdir /usr/share; sudo mkdir /usr/share/gconf; sudo mkdir /usr/share/gconf/defaults; sudo touch /usr/share/gconf/defaults/20_une-gconf-default
[sudo] password for esben:
mkdir: cannot create directory `/usr': File exists
mkdir: cannot create directory `/usr/share': File exists
mkdir: cannot create directory `/usr/share/gconf': File exists
mkdir: cannot create directory `/usr/share/gconf/defaults': File exists
touch: cannot touch `/usr/share/gconf/defaults/20_une-gconf-default': No such file or directory
esben@esben-laptop:~$ sudo aptitude purge rhythmbox rhythmbox-plugin-cdrecorder rhythmbox-plugin-coherence rhythmbox-plugins
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  rhythmbox-ubuntuone-music-store
The following packages will be REMOVED:
  rhythmbox{p}
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
0 packages upgraded, 0 newly installed, 1 to remove and 8 not upgraded.
Need to get 12.3kB of archives. After unpacking 15.3MB will be freed.
The following packages have unmet dependencies:
  rhythmbox-ubuntuone-music-store: Depends: libubuntuone-1.0-1 (>= 0.2.100) but it is not installable
                                   Depends: python-ubuntuone (>= 0.2.100) but it is not installable
                                   Depends: rhythmbox-plugins but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
rhythmbox-ubuntuone-music-store

Score is 121

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  rhythmbox{p} rhythmbox-ubuntuone-music-store{a}
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
0 packages upgraded, 0 newly installed, 2 to remove and 8 not upgraded.
Need to get 0B of archives. After unpacking 15.6MB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
dpkg: error processing rhythmbox (--purge):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
 rhythmbox
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up gnome-panel-data (1:2.30.0-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing gnome-panel-data (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-panel-data (>= 1:2.30); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 1:2.31); however:
  Package gnome-panel-data is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gnome-panel-data
 gnome-panel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

esben@esben-laptop:~$ LANG=C;sudo aptitude install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages will be REMOVED:
  rhythmbox{p} rhythmbox-ubuntuone-music-store{a}
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
0 packages upgraded, 0 newly installed, 2 to remove and 8 not upgraded.
Need to get 0B of archives. After unpacking 15.6MB will be freed.
Do you want to continue? [Y/n/?] y
dpkg: error processing rhythmbox (--purge):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
 rhythmbox
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up gnome-panel-data (1:2.30.0-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing gnome-panel-data (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-panel-data (>= 1:2.30); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 1:2.31); however:
  Package gnome-panel-data is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gnome-panel-data
 gnome-panel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

esben@esben-laptop:~$ LANG=C;sudo aptitude update
Hit http://security.ubuntu.com lucid-security Release.gpg
Hit http://no.archive.ubuntu.com lucid Release.gpg
Hit http://no.archive.ubuntu.com lucid-updates Release.gpg
Hit http://no.archive.ubuntu.com lucid Release
Hit http://archive.canonical.com lucid Release.gpg
Hit http://security.ubuntu.com lucid-security Release
Hit http://no.archive.ubuntu.com lucid-updates Release
Hit http://archive.canonical.com lucid Release
Hit http://no.archive.ubuntu.com lucid/main Packages
Hit http://no.archive.ubuntu.com lucid/restricted Packages
Hit http://no.archive.ubuntu.com lucid/main Sources
Hit http://no.archive.ubuntu.com lucid/restricted Sources
Hit http://no.archive.ubuntu.com lucid/universe Packages
Hit http://no.archive.ubuntu.com lucid/universe Sources
Hit http://no.archive.ubuntu.com lucid/multiverse Packages
Hit http://no.archive.ubuntu.com lucid/multiverse Sources
Hit http://security.ubuntu.com lucid-security/main Packages
Hit http://archive.canonical.com lucid/partner Packages
Hit http://no.archive.ubuntu.com lucid-updates/main Packages
Hit http://no.archive.ubuntu.com lucid-updates/restricted Packages
Hit http://no.archive.ubuntu.com lucid-updates/main Sources
Hit http://no.archive.ubuntu.com lucid-updates/restricted Sources
Hit http://no.archive.ubuntu.com lucid-updates/universe Packages
Hit http://no.archive.ubuntu.com lucid-updates/universe Sources
Hit http://no.archive.ubuntu.com lucid-updates/multiverse Packages
Hit http://no.archive.ubuntu.com lucid-updates/multiverse Sources
Hit http://security.ubuntu.com lucid-security/restricted Packages
Hit http://security.ubuntu.com lucid-security/main Sources
Hit http://archive.canonical.com lucid/partner Sources
Hit http://security.ubuntu.com lucid-security/restricted Sources
Hit http://security.ubuntu.com lucid-security/universe Packages
Hit http://security.ubuntu.com lucid-security/universe Sources
Hit http://security.ubuntu.com lucid-security/multiverse Packages
Hit http://security.ubuntu.com lucid-security/multiverse Sources
Reading package lists... Done

esben@esben-laptop:~$ LANG=C;sudo aptitude dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  rhythmbox-ubuntuone-music-store
The following packages will be upgraded:
  openssh-client pm-utils-powersave-policy
  python-ubuntuone-client rhythmbox ssh-askpass-gnome
  ubuntuone-client ubuntuone-client-gnome update-manager
  update-manager-core
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
The following packages are RECOMMENDED but will NOT be installed:
  rhythmbox-plugin-cdrecorder rhythmbox-plugins
9 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 12.3kB/3350kB of archives. After unpacking 12.3kB will be used.
The following packages have unmet dependencies:
  rhythmbox-ubuntuone-music-store: Depends: libubuntuone-1.0-1 (>= 0.2.100) but it is not installable
                                   Depends: python-ubuntuone (>= 0.2.100) but it is not installable
                                   Depends: rhythmbox-plugins but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
rhythmbox-ubuntuone-music-store

Score is 121

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  rhythmbox-ubuntuone-music-store{a}
The following packages will be upgraded:
  openssh-client pm-utils-powersave-policy
  python-ubuntuone-client rhythmbox ssh-askpass-gnome
  ubuntuone-client ubuntuone-client-gnome update-manager
  update-manager-core
The following partially installed packages will be configured:
  gnome-panel gnome-panel-data
The following packages are RECOMMENDED but will NOT be installed:
  rhythmbox-plugin-cdrecorder rhythmbox-plugins
9 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0B/3338kB of archives. After unpacking 311kB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
(Reading database ... 146593 files and directories currently installed.)
Removing rhythmbox-ubuntuone-music-store ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing rhythmbox-ubuntuone-music-store (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 rhythmbox-ubuntuone-music-store
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up gnome-panel-data (1:2.30.0-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 156, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 116, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20_une-gconf-default'
dpkg: error processing gnome-panel-data (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-panel-data (>= 1:2.30); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 1:2.31); however:
  Package gnome-panel-data is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gnome-panel-data
 gnome-panel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

esben@esben-laptop:~$

Sbn (esbenvinsnes) said : #12

Thanks for the effort, but I have decided to install Lucid fresh without the remix.