IOGear KVM switch unusable after upgrade to 6.10

Asked by Steve Sakoman on 2007-08-13

For the past year I've been using an IOGear 4 port DVI/USB KVM to share my display/kb/mouse between an Ubuntu 6.06LTS machine, a couple of Macs, and a Windows machine. I've had no problems with this setup.

Today I upgraded to Ubuntu 6.10 and the KVM is now essentially unusable. The symptoms:

   - during and after boot I get the following repeated error: usb 1-2.1: failed to restore interface 0 altsetting 0 (error = -62)
   - the mouse operation is extremely jerky
   - keyboard input is flakey -- typed characters are either missed, slow to appear on the screen, or appear multiple times
   - keyboard and mouse operations on the other 3 machines are affected in a similar manner (perhaps repeated usb resets on the Ubuntu side are confusing the kvm)
   - the problems disappear if I remove the kvm and connect the kb/mouse directly to the Ubuntu machine

Any ideas on how to work around this issue?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Dmitry Mityugov
Solved:
2007-08-13
Last query:
2007-08-13
Last reply:
2007-08-13

This thread describes several possible workarounds: http://forums.nvidia.com/lofiversion/index.php?t9269.html

And yes, buying a cheap USB hub and attaching it between the machine and the KVM fixed it to me

Steve Sakoman (steve-sakoman) said : #2

I put an IOGear USB hub between the kvm and the computer and the problem has gone away.

Thanks!