esound not installed in tribe 4

Asked by Juan Pablo Salazar Bertín

In a fresh gutsy tribe 4 install, esound package is not installed, but when gedit shows a tooltip it tries to call /usr/bin/esd, like this:

snifer@snifer-laptop:~$ gedit
/bin/sh: /usr/bin/esd: not found

Is esound going to be dropped or replaced by something else? Should I file a bug about esound not being installed or gedit or tooltips?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Juan Pablo Salazar Bertín
Last query:
Last reply:
Revision history for this message
Matteo Settenvini (tchernobog) said :

Probably the best course of action is to phase out esound in favor of pulseaudio.
Try to install the following packages via Synaptic:
 * libao-pulse
 * libgstreamer-plugins-pulse0.10-0
 * pulseaudio
 * pulseaudio-esound-compat
 * pulseaudio-module-gconf
 * pulseaudio-module-hal
 * pulseaudio-module-x11
 * pulseaudio-utils

Ah, by the way, Fedora is going the same way with its version 8, so I expect this is the Right Thing (tm).

Revision history for this message
Juan Pablo Salazar Bertín (snifer) said :

I think I've also read somewhere else that esound is going to be replaced with pulseaudio. Thanks for your answer. Problem solved.