Upgrade from Ubuntu 8.04 to 10.04 LTS aborted

Asked by Randy Schilling

I tried to upgrade from ubuntu 8.04 to 10.04. The process terminated with the following message: "The upgrade is now
aborted. Your system could be in an unstable state. A recovery will run now (dpkg --configure -a)". I tried to boot
to my ubuntu disk. The grub boot loader showed several options, several version 10.04 kernels (no 8.04 kernels)
and corresponding recovery options. I tried a normal boot and it locked up in the first screen following the boot loader. I did not try a recovery option. Instead, I selected the Windows option from the grub menu; this so I could could get this message off ASAP.

I am in dire need of help. I am a linux novice but I was doing very well learning about ubuntu and linux from the book by Kier Thomas. I worked through almost all 700 or so pages and now I wish I had never tried this upgrade.

I run a pentium D cpu at 3ghz and 5gb ram. It has two 150gb hard disks, one I call my ubuntu side, the other my
windows side. I decided to learn linux at my son's behest. After a virus infection and costly recovery, my windows
side has not been the same. It is disgustingly slow and it continues to slow down.
All I did was click on a picture of Rihanna and kaboom, infected!

Back to the upgrade.
The upgrade was interrupted by the following messages: "Sorry, the packgage "x" failed to install or upgrade" where
x=gwibber2.30.0.1-0ubuntu1, libimobiledevice00.9.7-1ubuntu1, evolution-couchdb0.4.5-0ubuntu1, rtkit,
libgpod40.7.93-0ubuntu1, python-desktopcouch-records0.6.4-0ubuntu3, libgpod-common0.7.93-0ubuntu1,
rhythmbox-plugins0.12.8-0ubuntu4, couchdb-bin, python-speechd0.6.8~unofficial~N2-0ubuntu3, nVidia-gix-new,
python-desktopcouch0.6.4-ubuntu3, gvfs-backends1.6.0+git20100414-0ubuntu1, gwibber-service2.30.0.1-0ubuntu1,
rhythymbox-ubuntuone-music-store0.0.9-0ubuntu1, gnome-orca-2.30.0ubuntu3, desktopcouch0.6.4-0ubuntu3,

What do I do from here? Install 8.04 or 9.04 or 10.04 from scratch?
How do I get back up and running with ubuntu without loosing the important documents on my ubuntu side?

Please, please, somebody help me get through this ghastly problem. Your help will be most graciously appreciated.

Regards - Randy (<email address hidden>)

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Vu Do Quynh
Last query:
Last reply:
Revision history for this message
Mario Tomljenović (tomljenovicmario) said :

Have you got all updates applied to your current 8.04 version of Ubuntu before you tried to upgrade?

Revision history for this message
Best Vu Do Quynh (vu-do-quynh) said :


You could try to boot and select in the grub menu the second line which should indicate at its end (recovery).

You'll be dropped to a console where you could issue the command that was indicated : "sudo dpkg --reconfigure -a" and wait it to complete (might take some time).

If this doesn't improve the situation, I would suggest a fresh install of 10.04. (I suppose you did check with a live CD that 10.04 was running without problems on your hardware. If not, then check this prior to install 10.04 with a live CD).

For your personal data (under /home), if you have put your /home in a separate partition from the root system /, then you're safe with your data on doins a new installation (just do not check the format option for the partition that support /home). In this case, to restore all the users that are under your /home, you'll need to backup the 3 following files : /etc/passwd, /etc/group and /etc/shadow. It would be better that you use the same username for installation (i.e. the one with id number of 1000 - you can check the id number of any user with the command "id username").

If you do not have /home on a separate partition, I heard that you could do a fresh install without losing data in /home as long as you do not format the / partition (I never verified that but I think it makes some sense).

In any case, it is imperative to backup your essential data by using a live CD, mounting the hard disk to copy the data to an external USB drive (or to a CD-ROM burner) before proceeding to any installation (error always happen, especially when you do not take the time to do backups).

Hope that helps.

Revision history for this message
Randy Schilling (rchilling) said :

I'm writing this in response to the help I got with my question 111497.

Thanks for looking into my problem.

Yes, I checked for updates to 8.04 before trying the updgade to 10.04.

I booted to the # prompt using a recovery option from the boot loader.
The first thing I did was to backup my home directory to a dvd.

 I entered the command "dpkg --configure -a" (after learning that dpkg has is no "reconfigure" option).
The response to this command was an immediate return to another # prompt. I entered "reboot".
The first screen following the boot loader had the word Ubuntu and under it, five streaming dots.
This meant progross because before the dots did not stream.
Also in this window was a message "your drives are being checked..." and after a few minutes
the system came up in what appeared to be a new gui, a little different from my 8.04 gui.

Well, the first thing I did was to reboot again. I guess I wanted to be sure I wasn't dreaming.
This time the dots under the word Ubuntu in the first screen following the boot loader were dead,
telling me that the system was locked up.

I trie to reboot one more time with the same result.

I think something positive happened but I'm still stuck.
Is there still something to try with my system in its current state
or should I just go ahead and install 10.04 from scratch?

Thanks again for your help, but please, take minute to provide me with a little more help.

Regards - Randy

Revision history for this message
Randy Schilling (rchilling) said :


I am the author of the original question 111497 writing this to update all of you on has happened.
As describes in my original submission, I tried to upgrade directly from 8.04 to 10.04.

That failing I followed the suggestion of Mr. Vu Do and created a live 10.04 cd.
I booted from that cd and chose the "try ubuntu without changing my pc" option.
The first up boot locked up but on I got up into ubuntu 10.04 on my second boot from the live cd.
10.04 seemed to me to be working just fine from the live cd so, continuing with Mr. Vu Do's suggestion,
I booted again from the live cd and this time chose the "Install" option. The installation continued for a brief
period of time but halted with the following message: "Failed to create File System. The ext4 file system in
partition #1 of serial ATA RAID nvidia hhdceaed (mirror) failed."

I reinstalled 8.04 from its live cd, got online, and am leaving you with this update. It appears that I (rather my system) will not be able to grow with Ubuntu. I don't see that I have any other choice but to look into using another Linux distribution.


Revision history for this message
Randy Schilling (rchilling) said :

Thanks Vu Do Quynh, that solved my question.