Problem to stop the pc

Asked by Jhkh Udfi on 2010-05-06

When I try to stop the computer, the hard disk is stopped, but the machine stays on!
I have to disconnect the power cable...
Is there a way to fix that?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Jhkh Udfi
Solved:
2010-05-11
Last query:
2010-05-11
Last reply:
2010-05-07

This question was reopened

Please describe your problem in more detail so we will be able to help you. :)

What version of Ubuntu are you using? (If it is Lucid / 10.04, you should know that it is not advised to upgrade to it for about 2-3 months until it is reasonably stable.)

Since when is this happening? Does it happen all the time or only sometimes?

Is a window prompted? Does it just freeze?

Jhkh Udfi (hippo-potam) said : #2

I'm using lucid 10.04; it's the first time I try Ubuntu installed on the hard disk. The problem always existed after the installation. (The live cd makes the same result)

The shutdown line does appear when I stop, the hard disk goes off (I can hear it because I'm using an old machine, what is acpi compatible, I think, I tried windows7 without problem) but after that the screen freezes on the Ubuntu logo.

(thanks for answering my question!)

Jhkh Udfi (hippo-potam) said : #3

Maybe I just should try Karmic...And see if the problem still exists

Yes, I was going to propose that next. As I already said, it would be better anyway for you to use Karmic because it is more stable.

Ask again if the problem persists. :)

Jhkh Udfi (hippo-potam) said : #5

Well,

I tried karmic, but the problem seems to be my computer...
It's exactly the same result.

I'm a windows user, and working with ubuntu on my machine pleased me; I don't want to cause damages to the system if I keeps using it with the "hard" stopping method.

So it did not happen with any Windows version? And you installed Ubuntu completely new both times, wiping the partition / hard disk clear?

Jhkh Udfi (hippo-potam) said : #7

I used Windows 98, 2000, 7 and a little linux, Slitaz on this machine...without problem.
For Ubuntu, I formatted the hard disk with ext3 system (automatically while installing).I Installed the updates, but nothing changed.

The bios is an Award.

Jhkh Udfi (hippo-potam) said : #8

I found in the bios alimentation setup: soft-off by PWR-BTTN. I selected instant-off, and now I can stop with the button when the ubuntu logo appear.

I preferred the automatic off, but it's better than unplugging the computer!

If we can't do anything more, that's not a real prob now, I just have to wait a few seconds. :-)

Thanks a lot for your help

I don’t think that that will be fixing your problem, but try formatting the disk with ext4 instead of ext3. Or may I ask why you opted for ext3 in the first place?

Anyway, glad you found a solution that works for you. You can leave the question open if you want a better one though. :)

Jhkh Udfi (hippo-potam) said : #10

I'm gonna try with ext4, I don't know wery well what are the characteristics of the linux files system

Jhkh Udfi (hippo-potam) said : #11

Doesn't work with ext4...!!
It will do for me.

Oh, I’m sorry. Let me know if you find a real solution. :)

Jhkh Udfi (hippo-potam) said : #13

Ok :)