No Grub Menu appears in Lucid Lynx

Asked by Cariboo1938 on 2010-05-05

Hello Launchpad,
I have a FRESH install of Lucid Lynx amd64 on SATA drive sda on my PC with Windows7 pre-installed on SATA drive sdb.
During boot sequence I don't get the grub menu at all.
The system boots directly into the drive as selected in the BIOS boot sequence.
From earlier Hardy Heron installation I got the Grub Menu and there I could select the OS I wanted to run.
I checked /boot/grub directory and looked for the menu.lst as I was used to do in the previous Ubuntu, but couldn't find it.
Also I checked Bug Report HERE:

https://bugs.launchpad.net/ubuntu/+bugs?field.searchtext=no+grub+menu+Lucid+Lynx&orderby=status&search=Search&field.status%3Alist=NEW&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.assignee=&field.bug_reporter=&field.omit_dupes=on&field.has_patch=&field.has_no_package=

These reports are all different because in my case there is no Grub Menu at all.
What Info is need to locate the problem?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2010-05-06
Last query:
2010-05-06
Last reply:
2010-05-05
Dawning (dawning) said : #1

Indeed I had a similar problem back when beta testing with Windows 7. The solution I utlimately decided to run with, though not entirely my preference, has been to manage grub in Windows via Wingrub (http://sourceforge.net/projects/grub4dos/)

Please let me know if that resolves your issue to your satisfaction.

Thomas Krüger (thkrueger) said : #2

The grub menu has been hidden if there is only Ubuntu on the system since Ubuntu 9.10. You can activate it by holding down shift after the BIOS screen.

Cariboo1938 (jgrauca) said : #4

Thanks for all replies...Holding down the Shift key worked once. Because the time seeing the menu was to short for me I changed in /etc/default/grub one line
=======================================
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=3
GRUB_HIDDEN_TIMEOUT_QUIET=true

GRUB_TIMEOUT=15 <-----I changed this number from 10 to 15

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true
# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"
# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
====================================================
and ran update-grub. After that the Grub Menu does NOT appear anymore!?!?What went wrong?/

Sam_ (and-sam) said : #5

Try this:
GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=3
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_HIDDEN_MENU_QUIET=false
GRUB_TIMEOUT="15"

Cariboo1938 (jgrauca) said : #6

Thanks Sam, that solved my question.

Cariboo1938 (jgrauca) said : #7

@ Thomas Krüger:
I found this here https://wiki.ubuntu.com/Grub2#grub%20%28/etc/default/grub%29
Quote
The user may force displaying the menu as the computer boots by holding down the SHIFT key.
During boot, the system will check the SHIFT key status. If it cannot determine the key status, a short delay will enable the user to display the menu by pressing the ESC key.
EndQuote
The ESC key has to be pressed too...........Anyway, thanks for the help

@Sam:
The quotation marks are not needed...it was the ESC key, which I didn't press........
Thanks, your links are very helpful....

Sam_ (and-sam) said : #8

JGrau,
glad you've found your individual solution.

> The quotation marks are not needed
yep, but they have been in my original grub file, so I left it and just changed the number in between.

Enjoy Ubuntu.