Wireless says it's connected, but i'm not able to access any internet.

Asked by Alex

The bars on the top bar say that I am connected with 87% to 89%, with should mean that I have a strong connection. Well, it doesn't even let me load websites on firefox, or read my email. I'm running Ubuntu Fiesty.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Wieslaw Nosal (wieslawnosal) said :

Does your wireless require proxy?

Revision history for this message
Aanjhan Ranganathan (aanjhan) said :

Hi Alex,

Are you able to ping the websites? Let us know whether your DNS is setup properly. Also as wieslaw requested, does your network require a proxy setting? if you are having a DHCP system, are you getting assigned a IP?


Revision history for this message
Alex (a-j-conrey) said :

My computer has an ip that I had setup myself. And No I am not required to have a proxy setup, but I guess it wouldn't hurt to try. How do I set up my proxy then? I have no clue if I have a DHCP or not. I just have a bulky 2wire wireless system on my main computer.

Revision history for this message
Luis Jorge (luisjorge) said :


The information Aanjhan asked you for could be useful. Still, maybe if you try to use the automatic DHCP configuration, you'll be able to surf the web. This will automatically assign an ip to your computer.
You can try this by clicking your network icon on the panel (the one showing the wifi signal) and select "manual configuration" at the bottom of the list. Then double-click the "wireless connection" and do one of two things:
1. Check the box that says "Enable roaming mode". Then just select your connection from the list of detected networks when you click the wifi icon, and enter your password and type of password. Be sure to check if the authentication of your 2wire modem is open or shared (it usually and by default is "open", unless you changed it yourself).
Or 2., if the roaming mode box is checked, then deselect it and enter the name of your network, your password type and password and select "automatic configuration (DHCP)" under the connection settings area. Be sure to check if you

Hope this helps! Good luck!

Revision history for this message
Alex (a-j-conrey) said :

It was already checked off and the 2wire is open. I tryed all the methods listed, Check It type in the password open or shared. Nothing is Working!!!!! Gah! I have a Linksys Wireless adapted for my desktop. I have a 2wire HomePortal. PLEASE HELP, ON LAST DESPIRATION, MIGHT LEAVE UBUNTU BECAUSE I NEED INTERNET!!!!!!!

Revision history for this message
Luis Jorge (luisjorge) said :

Hello again!

What does firefox say when you try to open a web page? Does it tell you that the server cannot be found or something similar? When it says that you are connected, right click the wifi icon and select "connection information". Are you getting an ip address and all the other values that appear there? Does it state a connection speed?
Sorry about all the questions, but the more information you can provide about what happens, the better. It would seem like it might be a problem with the drivers for the Linksys adapter... have you tried clicking on System---Administration---"Restricted drivers manager"?
Also do this: Open a terminal and enter:

ping localhost

Hit enter, and see if there's any activity. What happens?

Revision history for this message
professore (bob-moore-bemoore) said :

Hi, I have the same (or similar) problem. I am correctly assigned an IP address (mostly but cannot ping even the router. The same wireless connection works perfectly on Windows.

I can ping myself but that's it. All looks normal. If I connect wired it works as well.

Revision history for this message
akhi (aakash-cena) said :

HI all I am suffering from same problem as these two are. I think we should leave ubuntu and try somthing else.

Revision history for this message
Alex (a-j-conrey) said :

akhi, thanks but that wont solve the issue. I got it working over 6 months ago BTW, just was a kernel issue, and Arch Linux does the same thing.

Revision history for this message
Michael (mlp247) said :

I recently change to 9.04 the internet was working and my updates loaded just fine. Then oneday I got a error
message when I was trying to reboot. The computer would only load to 70% then it said I had some sort of
failure with my shell?? Any way I fixed that problem hit ctrl D and now it loads up fine . When I click on firefox
its acts as if it loads then the icon disappears from the task bar below. Then the updates comes up and it wont
update. I have tried a couple things like renaming Mozilla ...I tried scanning but i get an error. I run the system on a mini 9. Please Help.