Ubuntu 6.06 - Wireless stopped working.

Asked by Jan Jansen

I posted this question in the Ubuntu Forums:

"I tried the live cd and found to my delight that my wireless worked. After a while I decided to drop MS and installed Ubuntu 6.06. I did a couple of reboots and the wireless still worked. I did a shutdown, started the laptop again and the wireless no longer works. The bright wireless light is off and switching the wireless switch on/off does nothing. Here is an excerpt from dmesg:

[17179591.736000] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.1.1
[17179591.736000] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[17179591.736000] Warning: PCI driver ipw2200 has a struct device_driver shutdown method, please update!

[17179592.180000] ipw2200: Radio Frequency Kill Switch is On:
[17179592.180000] Kill switch must be turned off for wireless networking to work.

Any clues?"

I'm kinda lost, because I'm new to Linux, and the answers were too technical for me.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Junvarcha (jun314) said :

este es una buena obcion

Revision history for this message
Scott Dier (sdier) said :

Can you try this command in a terminal shell and send the output both when the wireless switch is on and off?

cat /sys/bus/pci/drivers/ipw2200/*/rf_kill

The numbers reported mean:

  0 = RF kill not enabled (radio on)
  1 = SW based RF kill active (radio off)
  2 = HW based RF kill active (radio off)
  3 = Both HW and SW RF kill active (radio off)

If 1 or 3 is listed can you tell me the model of your laptop? Can you give me the output of 'uname -a' and possibly try to boot an older kernel to see if the problem persists? (ie: 2.6.15-23 instead of 2.6.15-25)

Otherwise, if only 2 is listed then it may be a hardware problem and you may need to contact your hardware vendor.

Revision history for this message
Jan Jansen (pingvinklubbene) said :

Switch on:
$ cat /sys/bus/pci/drivers/ipw2200/*/rf_kill

Switch off:
$ cat /sys/bus/pci/drivers/ipw2200/*/rf_kill

$ uname -a
Linux xxxxx 2.6.15-25-686 #1 SMP PREEMPT Wed Jun 14 11:34:19 UTC 2006 i686 GNU/Linux

I've tried booting the older kernel, and I've tried booting the live CD. I downloaded the 686-kernel. No wireless.

Revision history for this message
Scott Dier (sdier) said :

If possible you may want to contact your hardware vendor and talk to them about the issue. A '2' in both positions and that it worked before sounds like it may be a broken switch.

Hopefully they can help you without having to have Windows involved, but they may not be willing to help debug their hardware without it, sadly.

Good Luck!

Revision history for this message
Jan Jansen (pingvinklubbene) said :

This page gave me the solution: http://folk.uio.no/krisvh/linux/cl56.html

I needed to install the Acer Hotkey driver.

Revision history for this message
carolyn (shordie222) said :

I have downloaded uuntu on my computer and I cannot get the wireless to work it works on windows, not sure if there is something I can do please let me know, thanks