changed resolution but now cannot see anything past the grub menu

Asked by Pieter16 on 2010-04-27

I have changed the resolution of ubuntu to a something that obviously is not suited for my screen. This is because after I have changed the resolution in ubuntu and restarted, a blank screen appears. I guess I am looking for a way to use the terminal via the grub menu or something to change to it back to a format that will work with my computer. I am a new user to linux so any advice with instructions would be greatly appreciated. Thank you very much in advance.

Pieter

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2010-06-11
Last reply:
2010-06-12

Is it the bootup screen or your desktop?

Pieter16 (babby18-sk8) said : #2

Basically as soon as I choose which OS I want to use from the grub menu, the screen proceeds to seem as if it loads but the screen is actually blank.

delance (olivier-delance) said : #3

In the grub menu, you should have bellow default boot, something like "safe boot" (don't remember the name).
Try it, and if it works configure screen.

Pieter16 (babby18-sk8) said : #4

I have tried the safe boot option before and just tried it now, but unfortunately that did not do anything.

Pieter16 (babby18-sk8) said : #5

Actually sorry I just tried to start the 'safe mode' but I noticed that there is only the recovery mode, which I assume is what you meant by safe mode. After loading it brings me to the menu with the 'repair pckgs' etc if that is what you needed to know. I have even signed in to ubuntu using this method but it is merely a non graphical log in and use of the OS.

delance (olivier-delance) said : #6

Sorry, but I'm upgrading to 10.4 today. I will have a look this week-end on problem.

Ubuntu has an X recovery system. X is what manages the display. To use it:
  Restart the computer
  Right at bootup there is a moment where you can either press Esc or Shift to bring up the boot menu.
     First try just holding Shift while the system boots
     If that doesn't work, watch for a point where it says to press Esc in the top left of the screen and push it then
  This will bring up a list of your boot options
  From this list, choose the second option in the list. It will say something like (Recovery Mode) at the end.
  Select that by pressing down and then press Enter.
  You will have a screen that pops up and allows you to recover X11 Window System. I can't remember the exact wording.
  Select that and press Enter.
  You should now be able to reboot and with luck things will work.

Pieter16 (babby18-sk8) said : #8

So, I have attempted all instruction possible last evening but unfortunately the boot menu only asks which drive to load first or to load from. Furthermore, attempting to hold the shift or esc key while loading does nothing. I have tried all of the buttons which are listed at initial start up and none have given me an option for any sort of recovery mode. The instructions were very clear through thank you.

The only recover mode option available so far is the one which I choose at the grub menu and it displays a few options of which one of them is something like 'dos' with the availabilitiy of networking.

Any further ideas of how to change back my resolution using either the windows portion of my hard drive which loads perfectly fine or even something that can be done utilizing the 'dos'/terminal of the linux portion? I am not sure if it is available through accessing the dos sort of screen that comes up with the recovery mode choice from the grub menu.

delance (olivier-delance) said : #9

Can you post /etc/X11/xorg.conf ?

Pieter16 (babby18-sk8) said : #10

I would love to if I was able to do that. I would think that I would have to find my way to the dos like screen and call some sort of code to bring it up. Then perhaps write it down on a piece of paper and then copy it to a message on here for you. The problem with me is that I do not know the line of code to use for such a thing. Is it something along the lines of "sudo gksudo gedit /etc/X11/xorg.conf" which I saw somewhere online?

delance (olivier-delance) said : #11

I have something like this. Does it match your file.
If you log as in a terminal, you can type
      more /etc/X11/xorg.conf

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
 DefaultDepth 24
EndSection

Section "Module"
 Load "glx"
EndSection

Section "Device"
 Identifier "Configured Video Device"
 Driver "nvidia"
 Option "NoLogo" "True"
EndSection

Launchpad Janitor (janitor) said : #12

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.

Pieter16 (babby18-sk8) said : #13

Ok, I am so sorry about leaving this thing for so long but I do not have the internet or even running water or showers where I work in the far reaches of the forests of BC. I finally made it into town after a few weeks on a contract. I tried to use the root shell prompt with and without networking to try these commands:

sudo gksudo gedit
sudo gedit
/etc/X11/Xorg.conf (received a statement "Gtk-WARNING ** : cannot open display"

I also noticed that when I try to start the most recent recovery mode option from the grub2 menu, that there is a line of text directly before the screen with options for root shell prompt and such. On the top left hand corner of the screen there is some code containing a resolution which is what I believe to be the problem. It states 1280X1024 or whatever. When I did some quick research on my model of laptop I find that the screen resolution should merely be 1280X800 for a widescreen monitor. I think this is the main problem.

I guess what my question really is, is how to access terminal from root shell prompt or even change the resolution using the root shell prompt??

Again I am sorry for my delayed reaction to your answers but was unable to open terminal or even execute the /etc/X11/Xorg.conf code to give you an answer and I only have access to electricity with the internet every few weeks, since I am a bush worker.

Thanks for all the help!

gksudo is used instead of sudo for gui apps:

e.g.

sudo apt-get install gedit

is a COMMAND LINE app.

gksudo nautilus

is a GUI app

therefore:

sudo gksudo gedit

makes no sense at all.

Can you help with this problem?

Provide an answer of your own, or ask Pieter16 for more information if necessary.

To post a message you must log in.