[gutsy kubuntu] Eclipse is crashing

Asked by Edmundo

I had already submitted this same problem, but it was marked invalid because I was not using eclipse from ubuntu packages.

I am now and the problem is still there. Here's the output from eclipse:

#
# An unexpected error has been detected by Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0xb4aa138c, pid=13354, tid=3084888976
#
# Java VM: Java HotSpot(TM) Client VM (1.6.0_02-b05 mixed mode, sharing)
# Problematic frame:
# C [libgtk-x11-2.0.so.0+0x25938c] gtk_tooltips_set_tip+0x1dc
#
# An error report file with more information is saved as hs_err_pid13354.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#

I'm using JDK 1.6u2 from sun (had to download it, didn't know what package to install to get from repositories... at least didn't find sun-java6-bin or jdk... perhaps you could point me to the package to use).

If you want the output from the hs_err file, just tell me.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Ryan Kavanagh (ryanakca) said :
#1

You probably want to remove JDK, and install both sun-java6-bin and sun-java6-jdk ... Maybe sun-java6-jre as well. If you still experience issues with the Ubuntu packages, I would file a bug report. https://bugs.launchpad.net/ubuntu/+filebug .

Hope this helps,
Ryan

Revision history for this message
Risto Välimäki (risto-valimaki) said :
#2

I can confirm this.

I have sun-java6-bin/sdk/jre + eclipse and both from gutsy repositories.

# An unexpected error has been detected by Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0xb4f3e44c, pid=8546, tid=3084360592
#
# Java VM: Java HotSpot(TM) Client VM (1.6.0_02-b05 mixed mode, sharing)
# Problematic frame:
# C [libgtk-x11-2.0.so.0+0x25944c] gtk_tooltips_set_tip+0x1dc
#
# An error report file with more information is saved as hs_err_pid8546.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp

more info:
JVM terminated. Exit code=1
/usr/lib/jvm/java-6-sun/bin/java
-Djava.library.path=/usr/lib/jni
-Dgnu.gcj.precompiled.db.path=/var/lib/gcj-4.1/classmap.db
-Dgnu.gcj.runtime.VMClassLoader.library_control=never
-Dosgi.locking=none
-jar /usr/lib/eclipse/startup.jar
-os linux
-ws gtk
-arch x86
-launcher /usr/lib/eclipse/eclipse
-name Eclipse
-showsplash 600
-exitdata 7c0012
-install /usr/lib/eclipse
-vm /usr/lib/jvm/java-6-sun/bin/java
-vmargs
-Djava.library.path=/usr/lib/jni
-Dgnu.gcj.precompiled.db.path=/var/lib/gcj-4.1/classmap.db
-Dgnu.gcj.runtime.VMClassLoader.library_control=never
-Dosgi.locking=none
-jar /usr/lib/eclipse/startup.jar

I had to run eclipse with following command: "eclipse -vm /usr/lib/jvm/java-6-sun/bin/java", because otherwise eclipse can't find java.

I'm going to test with sun-java5-jdk, but this can't be a 'final solution' because java 5.0 is soo slow compared to 6.0

Revision history for this message
ARam1024 (ariker) said :
#3

I was having almost exactly the same problem. I think the error message was almost identical. I uninstalled the alternative forms of java on my computer, installed sun-java6-jdk and sun-java6-plugin. I had already installed sun-java6-jre. Then I unistalled and reinstalled eclipse. It was then able to find java, and it appears to be working normally.

Can you help with this problem?

Provide an answer of your own, or ask Edmundo for more information if necessary.

To post a message you must log in.