TNT2-M64 Resolution Ability

Asked by eisudiem on 2010-04-21

I am once again back to the question boards.

I have successfully seduced another person with the promise of Ubuntu. However, as I am installing the OS on their HP 750c Desktop, I'm coming against the obstacle of their TNT2-M64 nvidia Video card. Yeah, that's an 11-year old card.

Situation Breakdown:

I've installed Ubuntu 9.10, i386 (32-bit) on his computer. He's got a P4 (1.8 GHz), 512 DDR RAM, 160Gb HDD.
I'm borrowing my own personal monitor for his computer. It's a Gateway FHD2400, with a native resolution of 1920x1200.
I'm stuck with an 800x600 resolution.
I'm on good authority that the card will support up to a 2046x1536 resolution.
There appears to be no xorg.conf file in the computer.
I've typed in "sudo dpkg-reconfigure -phigh xserver-xorg," and have gotten absolutely nothing.
The glx packages won't support the card, and I've gone researching https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia.
Here's the lspci | grep -i nvidia: 01:00.0 VGA Compatible controller: nvidia Corporation NV5m64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)
Here's what sudo gedit /etc/X11/xorg.conf says:

And that is why I must humbly throw myself at your mercy at solving this issue.
Thank you all for reading!

Eisudiem

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2010-04-22
Last reply:
2010-04-22

run:

gksudo gedit /etc/X11/xorg.conf

paste this text:

Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0"
EndSection

Section "Files"
EndSection

Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 28.0 - 33.0
    VertRefresh 43.0 - 72.0
    Option "DPMS"
EndSection

Section "Device"
    Identifier "Device0"
    Driver "nv"
    VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
        Modes "1024x768"
    EndSubSection
EndSection

Save the new file, close gedit and reboot, should be fine, The driver doesn't give you 3D accelleration but you will get a decent resolution, You can change the resolution to whatever you usually use in the same file and reboot.

eisudiem (eisudiem) said : #2

Wow! Fast response! Heavy emphasis on "ACTIONparsnip."

Thank you for your prompt response, but after I copy-pasted what you wrote - without any alteration - I got bumped down to 640x480 resolution!

Fortunately, I don't have to worry about 3D acceleration, the guy doesn't need fancy. But he was planning on buying a TV/Monitor with 1920x1080 resolution.

That was a great help, but I still need more, please!

Eisudiem

Ok try changing:

        Modes "1024x768"

To:
        Modes "1024x768@60"

And reboot, failing that try:

        Modes "1024x768_60"

See if they work.

eisudiem (eisudiem) said : #4

Alrighty, I'm back. And, I'm sorry actionparsnip, neither alteration worked. I also tried copying and pasting some of the lines from my previous encounter with my own xorg.conf issue - specifically, the lines of resolution - and that didn't work either.

Please and thank you for your continuing help!

Eisudiem

Jim Bauwens (jimbauwens) said : #5

Hi, maybe the nouveau drivers work, you could try downloading the 10.04 beta, because it include the nouveau drivers.
This is just to try if it would work.

--Jim

Jim Bauwens (jimbauwens) said : #6

 Note:I don't mean to install it, just to test the live cd.

eisudiem (eisudiem) said : #7

Hi there Jim!

Considering that time is not of the essence, I could just wait for 10.04 to come out, officially. It's all of a week, and if the guy's willing to wait so he doesn't have to spend more money on a computer, that's what will happen.

And, why yes, I do see that the NV05 family appears to be supported on the Nouveau driver page. Here's hopin'.

And hey, if the new drivers work better for 3D acceleration, maybe Left 4 Dead will be smoother on my Ubuntu partition. Awesome!

Evan

Hopefully the nouveau driver will give you 3D accelleration as I doubt the proprietary driver will run your chip

eisudiem (eisudiem) said : #9

Well, I've installed 10.04, and it definitely rocks. However, there was only a minor improvement in the screen quality. It finally jumped up to 1024x768. It is still way off the mark, even with the Nouveau firmware and drivers installed. And of course the xorg.conf file is gone.

It just may be that the guy is due for a new computer. I'll bring it up to him, and see if he's willing to spring for it.

Jim Bauwens (jimbauwens) said : #10

Wait! 'xorg -configure' generates xorg.conf file in the local dir.
So you could try configuring it for that resolution and copying it to /etc/X11

good luck!

Can you help with this problem?

Provide an answer of your own, or ask eisudiem for more information if necessary.

To post a message you must log in.