Cannot use CD-RW/DVD-RW Drive

Asked by bgh10788 on 2007-07-31

I am having a problem using the CD-RW/DVD-RW drive in my computer. I go to computer and click on the drive (with a CD or DVD in it) but it says...

Unable to mount the selected volume.
Show more details...
mount: special device /dev/hda does not exist

I have tried various CD's and DVD's with the same result. I installed from a LiveCD and use it all the time in Vista (dual boot). It is a laptop drive made by Matshita. I don't know the exact model number at this time.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
cubells
Solved:
2007-08-16
Last query:
2007-08-16
Last reply:
2007-08-16
Rodrigo Donado (frezeeer) said : #1

Hi:

Could you please paste your /etc/fstab file.

I think mount is pointing to the wrong place

bgh10788 (pianoman10788) said : #2

file:///etc/fstab

Some other information I found out...
-Running Feisty 7.04
-Drive Details: Matshita DVD-RAM UJ-850S ATA Device (from Vista device manager)

bgh10788 (pianoman10788) said : #3

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda2
UUID=fee0a54b-e2b4-4a03-883a-8380805bd012 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda5
UUID=26a1658b-41dd-40cf-b6ea-9cf6e262b5db none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0

Omid Alemi (omid) said : #4

put output of /dev/scd* here please

Saša Bodiroža (jazzva) said : #5

Replacing "/dev/hda" with "/dev/cdrom" in /etc/fstab should fix your problem. You need to have root privileges to do this. To do that issue "sudo text_editor /etc/fstab" in terminal. Replace "text_editor" with the command of the text editor you use. That would be "gedit" for GNOME's text editor, "kate" for KDE's, "nano" or "vi" for text editors with no GUI.

bgh10788 (pianoman10788) said : #6

Omid, I'm new to Linux. How do you want me to get the output?

Sasa, it still is giving me the unable to mount error.

Omid Alemi (omid) said : #7

welcome !
 open a terminal : Applications -> Accessories ->Terminal
 then type: ls /dev/scd*
 and copy and paste output of this command here

bgh10788 (pianoman10788) said : #8

It says...

bash: /dev/scd*: No such file or directory

I thought it should have done something more complicated than that lol...

Omid Alemi (omid) said : #9

Ok,
try these command in terminal too:
sudo mount /dev/cdrw /media/cdrom0
sudo mount /dev/cdrom /media/cdrom0

bgh10788 (pianoman10788) said : #10

I got these results...

mount: special device /dev/cdrw does not exist

mount: special device /dev/cdrom does not exist

Omid Alemi (omid) said : #11

I forgot !
try this too:
sudo mount /dev/dvd /media/cdrom0

bgh10788 (pianoman10788) said : #12

Same result...

mount: special device /dev/dvd does not exist

Saša Bodiroža (jazzva) said : #13

Hmm, considering that there is no /dev/scd*, /dev/cdrom, /dev/cdrw, /dev/dvd it sounds like Linux is not recognizing your DVD drive. Do a "sudo lshw" and look if there is a "cdrom" section.

bgh10788 (pianoman10788) said : #14

I don't see any cdrom or dvd section in "sudo lshw." I can't see everything all the way at the very top though. Here is the result of "sudo lshw -short"

H/W path Device Class Description
=========================================================
                                  system HP Pavilion dv2500 Notebook PC
/0 bus 30CE
/0/0 memory 102KB BIOS
/0/4 processor Intel(R) Core(TM)2 Duo CPU T73
/0/4/5 memory 64KB L1 cache
/0/4/6 memory 4MB L2 cache
/0/4/1.1 processor Logical CPU
/0/4/1.2 processor Logical CPU
/0/f memory 2GB System Memory
/0/f/0 memory 1GB SODIMM Synchronous 667 MHz (1.
/0/f/1 memory 1GB SODIMM Synchronous 667 MHz (1.
/0/100 bridge Mobile Memory Controller Hub
/0/100/1 bridge Mobile PCI Express Root Port
/0/100/1/0 display nVidia Corporation
/0/100/1a bus 82801H (ICH8 Family) USB UHCI #4
/0/100/1a/1 usb1 bus UHCI Host Controller
/0/100/1a.1 bus 82801H (ICH8 Family) USB UHCI #5
/0/100/1a.1/1 usb2 bus UHCI Host Controller
/0/100/1a.7 bus 82801H (ICH8 Family) USB2 EHCI #2
/0/100/1a.7/1 usb6 bus EHCI Host Controller
/0/100/1b multimedia 82801H (ICH8 Family) HD Audio Cont
/0/100/1c bridge 82801H (ICH8 Family) PCI Express P
/0/100/1c.1 bridge 82801H (ICH8 Family) PCI Express P
/0/100/1c.1/0 eth0 network Marvell Technology Group Ltd.
/0/100/1c.2 bridge 82801H (ICH8 Family) PCI Express P
/0/100/1c.3 bridge 82801H (ICH8 Family) PCI Express P
/0/100/1c.3/0 eth1 network PRO/Wireless 3945ABG Network Conne
/0/100/1d bus 82801H (ICH8 Family) USB UHCI #1
/0/100/1d/1 usb3 bus UHCI Host Controller
/0/100/1d.1 bus 82801H (ICH8 Family) USB UHCI #2
/0/100/1d.1/1 usb4 bus UHCI Host Controller
/0/100/1d.2 bus 82801H (ICH8 Family) USB UHCI #3
/0/100/1d.2/1 usb5 bus UHCI Host Controller
/0/100/1d.7 bus 82801H (ICH8 Family) USB2 EHCI #1
/0/100/1d.7/1 usb7 bus EHCI Host Controller
/0/100/1e bridge 82801 Mobile PCI Bridge
/0/100/1e/9 bus Ricoh Co Ltd
/0/100/1e/9.1 system R5C822 SD/SDIO/MMC/MS/MSPro Host A
/0/100/1e/9.2 system Ricoh Co Ltd
/0/100/1e/9.3 system R5C592 Memory Stick Bus Host Adapt
/0/100/1e/9.4 system xD-Picture Card Controller
/0/100/1f bridge Mobile LPC Interface Controller
/0/100/1f.1 storage Mobile IDE Controller
/0/100/1f.2 scsi0 storage Mobile SATA AHCI Controller
/0/100/1f.2/0.0.0 /dev/sda disk 74GB FUJITSU MHW2080B
/0/100/1f.2/0.0.0/1 /dev/sda1 disk HPFS/NTFS partition
/0/100/1f.2/0.0.0/2 /dev/sda2 disk Linux filesystem partition
/0/100/1f.2/0.0.0/3 /dev/sda3 disk 227MB Extended partition
/0/100/1f.2/0.0.0/3/5 /dev/sda5 disk Linux swap / Solaris partition
/0/100/1f.3 bus 82801H (ICH8 Family) SMBus Control
/1 power Intel Corporation

Saša Bodiroža (jazzva) said : #15

It seems like Ubuntu is not recognizing your DVD device, or that your DVD device is not working. I tried searching ubuntuforums.org to see if anyone else had a similar problem, but I found nothing. If the DVD device was recognized you would have something like this:

/0/e8000000/1f.1/1 /dev/cdrom disk DVD RW AD-7170A

Are you sure your device is not broken? (i.e. it works in some other OS)

bgh10788 (pianoman10788) said : #16

I'm positive it works in Vista. I just tested it to make sure (with dual boot).

bgh10788 (pianoman10788) said : #17

Should I report this as a bug or not? I see no reason why it shouldn't be supported.

Omid Alemi (omid) said : #18

Yes, I think it's better to report it.

Best cubells (cubells) said : #19

Try adding

libata
ata_piix
piix

to the bottom of the file /etc/modules and reboot.

It works for me!

bgh10788 (pianoman10788) said : #20

Thanks Worked perfectly!

Dougal Ballantyne (dougalb) said : #21

Hi,

I am having the sames issues on a HP Compaq 6710b notebook. DVD drive is available during install from Alternate CD and usable in windows.

Have updated the /etc/modules file and rebooted, no change. The DVD is not being seen.

I am running Ubuntu Gusty 32bit Tribe 4.

Can happily post any files or test if required.

cubells (cubells) said : #22

lsmod?

Dougal Ballantyne (dougalb) said : #23

I did some further research and if I add ide-generic module then the CDROM appears. Also I found that there is an open bug in the kernel for this. I will wait a few days and take a git version of the generic kernel and retest.

tudor (tudor-gmx) said : #24

same problem here with gutsy. adding ide-generic helped too. thanks a lot!

Ross (mondomunchies) said : #25

Can anyone explain what this does? How to do it more clearly? And how it helps?
-------------------
Try adding

libata
ata_piix
piix

to the bottom of the file /etc/modules and reboot.

It works for me!
---------------------

And how do you add ide-generic?

Ross (mondomunchies) said : #26

Adding libata, ata_piix, and piix to /etc/modules and rebooting did not work for me. I'm not even sure that I have those things.

john (jaytee1937) said : #27

Dell Inspiron 6400 with Ubuntu 8.04.

I am unable to eject a cd from the drive. The cd was burnt using Vista. When put it the cd was opened from icon on desktop, and the content viewed. When I went to eject the cd nothing happened. Pushing the eject button on the drive only produces a whirring sound, and the cd does not eject. On subsequent start ups the icon appears but disappears as soon as the eject command is made. A physical opening of the drive also does not work. How can this be solved.

cubells (cubells) said : #28

Can you try this?

$ sudo eject /dev/scd0

Uwe Koch (uwe-koch) said : #29

Hi, I get the following when running sudo lshw:

 *-cdrom
                description: DVD-RAM writer
                product: DVDRAM GSA-H62N
                vendor: HL-DT-ST
                physical id: 1
                bus info: scsi@3:0.0.0
                logical name: /dev/cdrom
                logical name: /dev/dvd
                logical name: /dev/scd0
                logical name: /dev/sr0
                version: CL00
                capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
                configuration: ansiversion=5 status=open

I'm running ubuntu 8.04 on a AMD64 X2 processor uname -r: 2.6.24-19-rt

I can run and copy DVD's, but can not mount CD's: I get a "can not mount the place, no support in the device" message.

I also added libata, ata_piix, piix as suggested and rebooted the system. When I run sudo eject /dev/scd0 it works. lsmod tells me "cdrom 41384 1 sr_mod" for cdrom.

I also have an ide-generic.ko file installed.

Any idea what else to do?

ozzz (pawel-kuznik) said : #30

cubells solution works great on hp dv7 1080ew with blue-ray drive on ubuntu 9.4

IgnorantGuru (ignorantguru) said : #31

I can't believe it, but cubells solution restored my ability to play dvds in VLC. Until then, I had no dvd:// or cdda:// device after installing Kubuntu Karmic alpha 4. After install, I had to manually add an entry for the drive to fstab, which gave me /dev/dvd but not dvd://. The /etc/modules entries restored dvd:// and cdda:// which made VLC happy, although it's still somewhat flakey. This was an Asus DVD-RW drive.

This computer only supported SATA 1.5G/s. I also installed Karmic on another computer that had that same identical drive, but supported SATA 3G/s, and that install had dvd:// working without modification.

Anyway, thanks for the fix! It was a hard find. Sad to see that a two-year old solution stills solves a problem.

Shaun (codemonkey1) said : #32

I cannot seem to get my CD/DVD ROM to work on my Toshiba Laptop. I am using Ubuntu 9.0 on a Toshiba Laptop. I followed one of the commands posted above:
ls /dev/scd*

this is what I got:
/dev/scd0

As I am very new to this OS, I have no idea what I am doing, but I am more than willing to learn. I would appreciate any help I can get.

Amazingly the following worked for me too (now running 9.10):

Try adding

libata
ata_piix
piix

to the bottom of the file /etc/modules and reboot.

Thanks!!

new2ubun2 (gubassas) said : #34

Help plz same bloody thing
tried all of the sugestions and nothing works
alex@gubasas:~$ ls /dev/scd*
/dev/scd0 /dev/scd1
alex@gubasas:~$ mount /dev/scd0
mount: can't find /dev/scd0 in /etc/fstab or /etc/mtab
alex@gubasas:~$

Joshua Mattox (asianaddict28) said : #35

Try adding

libata
ata_piix
piix

to the bottom of the file /etc/modules and reboot.

   Sorry, but WTF does this mean? why cant anyone explain Linux in dumbass so us dumbasses can understand. Im new to this so just saying add this add that without being specific on how to add these things are pointless, unless the point is to make yourself seem a bit more intelligent than the rest of us. not hating, just confused as hell. thank s for any help.

LINUX IS THE BEST!!!!!!!!

cubells (cubells) said : #36

$ sudo gedit /etc/modules

add these lines at the bottom of the file:

libata
ata_piix
piix

Save the changes.

And that's all.

But the question is more than five years old.

Are you sure your ubuntu doesn't detect your CD-RW/DVD-RW Drive?
Or simply the CD-RW/DVD-RW Drive is not properly connected?

Cheers.