at start up it says <windows root>\system32\hll.dll. restore

Asked by Stefan Neagu on 2007-07-31

Out of the box support for these hardware components:
- Atheros AR5007EG wireless lan card, integrated on new laptop models, notably the Acer Aspire 5100 series starting mid -2007
Currently Madwifi reports HAL status 13 for Hardware revision not supported. Ndiwswrapper installs the appropriate inf file from the windows driver but doesn't work. See: http://www.atheros.cz/ for inf files.
Also, can't disable the Madwifi driver from Restricted Driver Manager UI.
-ENE multimedia card readers SD, MMC, xD, Memory Stick Pro/Duo, integrated. Suggested backport here: http://urltea.com/196r
-Bison, Suyin, Logitech integrated webcams. Brand name used: Acer Orbicam series.
-Acer ACPI support for enabling, disabling devices, accurate battery status, display brightness control and extra customizable keys
-ATI X200M Integrated Graphics Processor with the restricted driver won't display accelerated graphics nor desktop effects for Beryl or Compiz because of no composition.
-ATI Southbridge features not supported. ALSA does not detect the actual hardware and instead uses ALCXXX disabling stereo analog/digital output and integrated Microphone. Recompiling solves the output problem.
System used: Acer Aspire 5100AWLMi, technical details here: http://urltea.com/196u
These problems make the experience so bad that I'm forced to use Microsoft Windows Vista to regain functionality. it would be nice if someone fixed some of these for Gutsy. Thank you.
P.S.: I'm not exactly sure this is where I should post this(I'm sorry).

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-07-25
Last reply:
2009-02-05
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

It seems no one gives a shit about this. Hello, people, I'm stuck with Vista!!!!

Mikko Virkkilä (virkkila) said : #3

I've linked this question to the relevant bug regarding the ENE memory card reader. Hopefully they'll add support for it before gutsy is released.

Your webcam is likely to be supported by the UVC driver (which is already included in the current gutsy developement version, not sure about Feisty). Note that the driver only supports video4linux version 2, which few programs support (yet). At least Ekiga supports v4l2, and my webcam (Acer Crystal Eye) worked out of the box with it (in gutsy with the UVC driver).

Thanks Mikko! Looking forward to the final release of Gutsy in October, hope it will solve these pesky driver problems that ruin Ubuntu. Also, after installing the 64 bit version of Feisty my Wlan card won't work. It's an Atheros AR5007EG 802.11b/g card. Used ndiswrapper as usually because madwifi doesn't support it (HAL status 13 hardware revision not supported). Drivers from here: http://www.atheros.cz/

Launchpad Janitor (janitor) said : #5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Well it's been a month now, does anyone now if someone is working on fixing these issues?

Greg Toombs (greg-toombs) said : #7

Have you tried a newer kernel, like from one of the gutsy tribes?

Yes, but it still doesn't see my atheros nor my webcam. The card reader sometimes works though.

Thanks Mikko Virkkilä, that solved my question.

Would like to reopen this, maybe someone will fix the atheros 5007eg wifi b/g PCI card and th webcam drivers in 8.10.

Dan Trevino (dantrevino) said : #11

Here is the compatibility list: http://madwifi-project.org/wiki/Compatibility/Atheros I believe this is fixed in linux-backports-modules

Can you help with this problem?

Provide an answer of your own, or ask Stefan Neagu for more information if necessary.

To post a message you must log in.