grub boot error - no WUBILDR

Asked by Desmond Stewart on 2010-04-03

I loaded an ASUS X5DC series laptop with Ubuntu version 9.1 within Windows 7 and everything worked fine until Ubuntu crashed.
I Ctrl-F1'd and logged in as root, then 'ps -A' to find the process number, killed the hanged process, exited the console, 'Alt-7' to the GUI, saw the desktop working then rebooted the machine.
Upon selecting Ubuntu from the OS menu, I saw two lines outputted very briefly, then just as quickly the following:

/* start of screen display (not displayed, just a comment!!)

GNU GRUB version 1.97~beta4

[ Minimal BASH-like line editing is supported. For the first word, TAB
  lists possible command completions, Anywhere else TAB lists possible
  device/file completions, ]

sh:grub> _ */ underscore represents cursor /*

*/ end of screen display

Rebooted the system a number of times, not understanding the possible commands lists or their usage at this stage and really hoping it would reset itself - no joy.

Started reading wubildr.cfg file in Windows Ubuntu install directory then begn reading the Grub manual, which did not help at all as it completely ignored this situation, but began utilising some of the commands therein to try and find out what was happening i.e:

sh:grub> boot (hd0,0)
error: no loaded kernel
sh:grub> root (hd0,0)
error: no such partition
sh:grub> root (hd0,1)
(hd0,1): Filesystem is fat.
sh:grub>root (hd0,2)
(hd0,2): Filesystem is ntfs.
sh:grub>root (hd0,5)
(hd0,5): Filesystem is ntfs.
sh:grub> ls -l
Device hd0: Partition table
              Partition hd0,5: Filesystem type ntfs, Label DATA, UUID ecca01ca6f6d7b56 */ Extended partition /*
              Partition hd0,2: Filesystem type ntfs, Label OS, UUID 66ea48c7ea489569 */ Windows (boot) partition /*
              Partition hd0,1: Filesystem type fat, Label RECOVERY, UUID 3c98-ac5d */ Invisible in Windows - hidden? /*

I even tried the command:

sh:grub> set root=(loop0) */ the result of conditional statement in wubildr.cfg file /*

which only silently brought me back to the grub prompt with no clue as to whether it had been effective or not

In near desperation due to not knowing what was the error message outputted before the grub prompt, I rebooted the machine, selected the Ubuntu option and pressed the pause button and was rewarded with:

Try (hd0,0): FAT32: No WUBILDR
Try (hd0,1): NTFS5: _

Can anyone make any sense from this as it appears that grub is trying to boot from an (apparently) non-existent partition - unless it created it itself in which case it has 'lost' the method of how to achieve this!!! I myself am confused as the wubildr.cfg file gives no indication whatsoever as to the install partition, yet this same file exists on hd0,1, which can be detected, but not read!!

Additionally, the main reason I am submitting this bug report is because I have had a very similar experience with an installation of Ubuntu on a Compaq Presario CQ70 upon which I also installed Ubuntu a week before, wherein that machine also experienced a frozen desktop and, upon logging into the console (tty1) as root to kill the process, I eventually rebooted the machine. Upon restarting the computer and auto-selecting the 2.6.31-20 kernel, the computer failed to boot and I had to turn off the computer and turn it back on as it locked up completely. However, what I did was to select the 2.6.31-14 kernel (after a few tries), which booted normally and then I found that I could then boot the 2.6.31-20 kernel as usual with no problems - until I again used the console - this time to do some work as root. This time, when the computer filed to start with the 2.6.31-20 kernel, I repeated rebooting with the 2.6.31-14 kernel as before and have since had no problem - having refrained from using the console since.

Please advise soonest 1) how to get the ASUS installation up and running as I am loathe to un-install it and 2) is there a problem accessing and using Crtl-Alt-F1 in Ubuntu? as root?

PS: I apologise for the length of this report, but I am trying to be as complete as possible for your considerations.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2010-04-04
Last reply:
2010-04-07
Desmond Stewart (sleepyd) said : #1

My apologies, I never mentioned that my name is SleepyD and if you desire any further info, please sumit your request here. I will explain as much as I am able.

Thank you.

SD

Vitaliy Kulikov (slonua) said : #2

wubi is designed to try ubuntu and the easiest way to install ubuntu to explore it. i purpose use live-cd (the same installation cd/dv) for exploration.
in case u wanna have permanent installation of ubuntu, u could install it on one of new created partition before by windows stuff or during ubuntu installation.

if u still prefer to use wubi, it will be better post a bug =)

Desmond Stewart (sleepyd) said : #3

Thanks for your reply Vitaliy. If I understand you correctly, wubi is for evaluation. OK. I would still like to know - if I permanently installed Ubuntu as suggested, would I still have the same problem when rebooting after using Ctrl-Alt-F1 to enter the main console as root? Remember, both my laptops failed to boot after trying this. To me this indicates a bug somewhere. However, I desired to know if anyone has had this same behaviour first?

SD

Vitaliy Kulikov (slonua) said : #4

so, normal flow for 'root' usage it's 'sudo'. at any time u can use Ctrl-Alt-(F1-F6), login with ur private account and type

$ sudo <any-comand>

OR read this (https://help.ubuntu.com/community/RootSudo#Special notes on sudo and shells), also whole wiki will be fine to have more information about 'sudo'

Can you help with this problem?

Provide an answer of your own, or ask Desmond Stewart for more information if necessary.

To post a message you must log in.