Can't enable wireless card

Asked by Michael on 2010-03-07

I have just installed Ubuntu on my laptop (compaq presario v2000) and I can't get my wireless card to turn on. I am still working my way around this system and have very little experience with linux. I ran a command line in terminal that said the card was disabled. I have seen some posts where people were able to go into windows and enable their wireless card, but I installed Ubuntu over windows. I turned the wireless card off the last time I was working in windows.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:

This question was reopened

Can you please give the output of:

sudo lshw -C network


Michael (istillhaveabeard) said : #2

I am going to start typing the output, but is there anything in particular you are looking for? I can't cut and paste it.

We need the product line.

Michael (istillhaveabeard) said : #4

product: bcm4318 [Airforce One 54g] 802.11g wireless LAN controller
vendor: Broadcom Corporation

Get a wired connection and it will install itself.

Michael (istillhaveabeard) said : #6


Hopefully, I won't get in trouble for tapping into the wired connection I ended up using.

Michael (istillhaveabeard) said : #7

Unfortunately this didn't do it, still can't activate the wireless card.

Michael (istillhaveabeard) said : #8

Something else I just noticed, the enable wireless button in the NetworkManager right click menu is no longer there.

Ian Ace (iaculallad) said : #9

How about using Broadcom's proprietary driver. See if you could find the "Hardware Drivers" in the Administration menu and enable any driver which coincides with bcm4318.

*I'm using a Lenovo laptop with Broadcom Corporation BCM4312 802.11b/g (rev 01) as my wireless card, enabling the proprietary driver (Broadcom STA wireless driver) works like a charm*


Michael (istillhaveabeard) said : #10

Thanks, the only driver listed is the one I just downloaded, where can I download the Broadcom STA wireless driver?

Punnsa (anubhavgupta1990) said : #11

i am also facing the same prblm ,but i have a Dell vostro 1510,
i typed the cmnd sudo lshw | more , but was unable to locate my wireless driver
. pls tell me a step wise soln for this as i am a beginner , so have a less idea about ubuntu;

thenubsauce (tantanchen) said : #12

jay@MyComputer:~$ sudo lshw -C network
[sudo] password for jay:
  *-network DISABLED
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 1c:4b:d6:6a:e4:f0
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k latency=0 multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:f8000000-f800ffff
       description: Ethernet interface
       product: Atheros AR8132 / L1c Gigabit Ethernet Adapter
       vendor: Attansic Technology Corp.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: c0
       serial: e0:cb:4e:a9:62:08
       size: 100MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion= duplex=full firmware=N/A ip= latency=0 link=yes multicast=yes port=twisted pair speed=100MB/s
       resources: irq:30 memory:f7fc0000-f7ffffff ioport:ec00(size=128)

My card says disabled, what's the command to enable it?

thenubsauce please give the output of:

sudo iwlist scan

The device seems to have a driver (ath9k) and is giving you the device wlan0. Lets see if it scans to find access points (APs)

If it does't then use this guide but replace Jaunty to your release name if you do not se Jaunty:


looks like you need the b roadcom firmware cutter, if you hook up the wired connection to the internet you will simply be offered the driver and it will automatically be installed for you (easier)

Can you help with this problem?

Provide an answer of your own, or ask Michael for more information if necessary.

To post a message you must log in.