Grub 9.10 latest update (20) freezing up

Asked by Catsys on 2010-03-07

Grub 9.10 Beta 19 was working great except a glitch in a command line (No floppy found) I was trying to fix.....So, Decided to run Update Manager that had update 20 expecting to have the solution for it, rebooted the computer and still no fix....I continued the same way by editing the command list and manually removing the usual line but, this time it did not reach to the login screen; it just froze while displaying the Ubuntu Logo............I hardboot the computer and tried different choices from the command line but now all of them freeze at the same point, never reaches to the login window where I enter the user name and password. I have not been able to find any solutions, except to reinstall ubuntu from CD..............Any light on this problem is greatly appreciated. I am new to Linux/Ubuntu leaping from Windows platform. (Detailed instructions if possible.pleeeeeeas)
Best Regards

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2010-03-08
Last query:
2010-03-08
Last reply:
2010-03-07

I suggest you reinstall grub using the liveCD

Catsys (catsys1) said : #2

I knew that much!!, Does anybody knows what could have happened and if it will happen again after reinstalling the OS and updating it?, how can I remain in Linux 2.6.31-19 genetic?
Thank you for your reply and assistance.
Cheers

You don't need to reinstall the OS, just the boot loader. Not sure why it borked though.

Catsys (catsys1) said : #4

Thank you I'll try that, it does sound less complicated than I thought. I suppose that installation option will be available via a menu choice?.

I give it a try....

Cheers

> To: <email address hidden>
> From: <email address hidden>
> Subject: Re: [Question #103518]: Grub 9.10 latest update (20) freezing up
> Date: Sun, 7 Mar 2010 20:23:15 +0000
>
> Your question #103518 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/103518
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> You don't need to reinstall the OS, just the boot loader. Not sure why
> it borked though.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/103518/+confirm?answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/103518
>
> You received this question notification because you are a direct
> subscriber of the question.

_________________________________________________________________
Hotmail: Powerful Free email with security by Microsoft.
http://clk.atdmt.com/GBL/go/201469230/direct/01/

Best Sam_ (and-sam) said : #5

Sounds like another UUID issue.
Good luck.
https://help.ubuntu.com/community/Grub2#Reinstalling%20GRUB%202

Maybe you edit the wrong file, grub.cfg will be overwritten on updates.
https://wiki.ubuntu.com/Grub2

Catsys (catsys1) said : #6

Thank you so much Sam, That did it. The link you sent was precise. I also would like to acknowledge everybody else for leading me in the right direction, I learned a few things today about Linux.
I would like to request a solution for the No device found (Floppy disk error on command list), I don't understand how to remove and save that line from the startup file.

Kudos gents.......

> To: <email address hidden>
> From: <email address hidden>
> Subject: RE: [Question #103518]: Grub 9.10 latest update (20) freezing up
> Date: Sun, 7 Mar 2010 22:45:06 +0000
>
> Your question #103518 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/103518
>
> Status: Open => Answered
>
> Sam proposed the following answer:
> Sounds like another UUID issue.
> Good luck.
> https://help.ubuntu.com/community/Grub2#Reinstalling%20GRUB%202
>
> Maybe you edit the wrong file, grub.cfg will be overwritten on updates.
> https://wiki.ubuntu.com/Grub2
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/103518/+confirm?answer_id=4
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/103518
>
> You received this question notification because you are a direct
> subscriber of the question.

_________________________________________________________________
Your E-mail and More On-the-Go. Get Windows Live Hotmail Free.
http://clk.atdmt.com/GBL/go/201469229/direct/01/

Catsys (catsys1) said : #7

Thanks Sam, that solved my question.

gksudo gedit /usr/lib/grub/grub-mkconfig_lib

remove the single instance of --no-floppy from the file save the new file, close gedit then run:

sudo update-grub

ONLY remove the --no-floppy bit, not the whole line. This is in reference to bug:
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/391044

HTH

Catsys (catsys1) said : #9

Thank you actionparsnip,

I have tried exactly that but, when I reboot it freezes up just like it did before (When I ran update manager). This time I was able to choose a different menu item (Linux 2.6.31-14), the XXXX-20, XXXX-17 and XXXX-19 got corrupted after the change and reboot.
I also tried removing the whole line and I get an error: unexpected "fi" in line item 187 , which is the next line's command. I am operational doing the same routine as before (manual removal of the whole line during boot) except the -- no-floppy comment that was taken out during my last attempt, I am reluctant to make any other changes that will eat all my boot command choices. I may try again restoring the bootloader to get back XXXX-17, XXXX-19 and XXXX-20 and have the latest updates.
Are these updates critical?? or can I live without them.

Thank you again actionparsnip, you do have the right idea. I don't know why my system is been stubborn (DELL Inspiron 6000)

Cheers

> To: <email address hidden>
> From: <email address hidden>
> Subject: RE: [Question #103518]: Grub 9.10 latest update (20) freezing up
> Date: Mon, 8 Mar 2010 09:59:15 +0000
>
> Your question #103518 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/103518
>
> actionparsnip posted a new comment:
> gksudo gedit /usr/lib/grub/grub-mkconfig_lib
>
> remove the single instance of --no-floppy from the file save the new
> file, close gedit then run:
>
> sudo update-grub
>
> ONLY remove the --no-floppy bit, not the whole line. This is in reference to bug:
> https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/391044
>
> HTH
>
> --
> You received this question notification because you are a direct
> subscriber of the question.

_________________________________________________________________
Hotmail: Powerful Free email with security by Microsoft.
http://clk.atdmt.com/GBL/go/201469230/direct/01/

Sam_ (and-sam) said : #10

Thanks Andrew.
Interesting bug, which I've never experienced though, maybe because I made a new installation of Karmic beta in the past. According to Colin #31 I didn't have an old_Grub_image_somewhere.

> error: unexpected "fi" in line item 187

Catsys,
the concerning line to edit is 147, could it be you edit the wrong line?
e.g.
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/391044/comments/14
as the example shows edit the first line that it looks like the second.
(of course ignore the minus and plus which is just commenting which one has negative and which has positive results)
Actually the procedure as described is supposed to help. Although it isn't considered as fix.

Make sure Grub is installed the way you expected it.
The result is in /boot/grub/device.map

According to Colins answer #31 I'd try to get rid of older image files (means it needs finally to be upgraded from Grub legacy as mentioned in the Wiki >>GRUB 2 should be fully installed, with GRUB legacy removed<<)
However you may read through the entire Bug report in order to figure out your final fix.

Catsys (catsys1) said : #11

Thank you for the observation. I left out the first error was line 147, then after trying once again it came back with line 187. Then I replaced the file with the backup I made before changes and I was able to continue. Still have the problem though, and working with the XXXX-14. I will continue to work on this later. (I'm quite an expert restoring the bootloader)
Cheers

> To: <email address hidden>
> From: <email address hidden>
> Subject: RE: [Question #103518]: Grub 9.10 latest update (20) freezing up
> Date: Mon, 8 Mar 2010 15:08:40 +0000
>
> Your question #103518 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/103518
>
> Sam posted a new comment:
> Thanks Andrew.
> Interesting bug, which I've never experienced though, maybe because I made a new installation of Karmic beta in the past. According to Colin #31 I didn't have an old_Grub_image_somewhere.
>
> > error: unexpected "fi" in line item 187
>
> Catsys,
> the concerning line to edit is 147, could it be you edit the wrong line?
> e.g.
> https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/391044/comments/14
> as the example shows edit the first line that it looks like the second.
> (of course ignore the minus and plus which is just commenting which one has negative and which has positive results)
> Actually the procedure as described is supposed to help. Although it isn't considered as fix.
>
> Make sure Grub is installed the way you expected it.
> The result is in /boot/grub/device.map
>
> According to Colins answer #31 I'd try to get rid of older image files (means it needs finally to be upgraded from Grub legacy as mentioned in the Wiki >>GRUB 2 should be fully installed, with GRUB legacy removed<<)
> However you may read through the entire Bug report in order to figure out your final fix.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.

_________________________________________________________________
Hotmail: Powerful Free email with security by Microsoft.
http://clk.atdmt.com/GBL/go/201469230/direct/01/

Sam_ (and-sam) said : #12

Ok,
maybe try also the
dpkg-reconfigure grub-pc

> I'm quite an expert restoring the bootloader
No wonder, it's proofed we learn through trial+error. Sure you'll get it fixed.

Catsys (catsys1) said : #13

Well gents,
I left this portal for a while, trying to figure out the estrange behaviour I thought I had solved.

I was able to accomplished the "~~no floppy ~ problem. I regret to criticise some of the posted recommendations by giving my solution.
"You must remove the whole line from the grub.cfg file, there are 9 instances. I first highlighted all of them by using the find command (great feature to be able to do that) then deleted one by one. Saved the file, rebooted and updated the file (update-grub.cfg). I was happy to see the system booting right pass the usual "search ~~no floppy device error" but, it will stop on the Ubuntu word logo and scanning worm on the bottom. I tried all the boot options "XXXX-20, XXXX-19, XXXX-17 and XXXX-14" .
I decided to restore the bootloader several times with the same results. At this point I was frustrated and left this nagging problem for a couple of days. Today I came armed with my boot discs and ready to start all over. I thought I try it once more before inserting the CD; I chose the XXXX-14 (Gut feeling) to my surprise IT BOOTED RIGHT THROUGH!!!, I was stoned by this miracle and restarted and decided to try XXXX-17, YES, IT WORKED, now XXXX-19, YES IT WORKS!!.
Needless to say the computer needed a couple of days to recuperate from all the surgeries. I guess...........I haven't try XXXX-20, (Gut feeling) "this is the one after the last update manager run" where everything went hair-wire.
Does anybody have an idea of this mysterious fix.
Cheers

Catsys (catsys1) said : #14

Here we go again!!
Everything was working as described on the previous post but, yesterday decided to try boot option XXXX-20. Bad decision.
It froze during boot up, same place, tried other boot choices and no luck.............I tried repairing the bootloader by selecting the recovery mode option , did not work except that it brought back the ~~no-floppy problem again. I will try the old routine and see what happens.

Cheers