Javascript-error-Mozilla.png Video player

Asked by Gunnar Tryggvason on 2010-03-04

I did install chrome browser, but have uninstalled it again. I do get following error when I try to play flash-movies in Firefox-browser.:

Exeption..."component returned failure code: 0x80520006
(NS_error_file_target_does_not_exist) [nsILocalFile.isFile]" nresult:0x80520006
(NS_error_file_target_does_not_exist)" location: JS frame::
chrome://mediaplayerconnectivity/content/mpc-overlay.js :: mpc_executeApp :: line 874 data:no]

Howe do I get Firefox to seek for another player.file:///home/gunnar/Desktop/Javascript-error-Mozilla.png

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Gunnar Tryggvason
Solved:
2010-03-10
Last query:
2010-03-10
Last reply:
2010-03-06

Can you give the output of:

dpkg -l | grep flash; dpkg -l | grep gnash; dpkg -l | grep swf; dpkg -l | grep firefox; uname -a

Thanks

gunnar@gt-kjallari:~$ dpkg -l | grep flash; dpkg -l | grep gnash; dpkg -l | grep swf; dpkg -l | grep firefox; uname -a
ii libswfdec-0.8-0 0.8.4-1 SWF (Macromedia Flash) decoder library
ii firefox-3.5 3.5.8+build1+nobinonly-0ubuntu0.9.10.1 safe and easy web browser from Mozilla
ii firefox-3.5-branding 3.5.8+build1+nobinonly-0ubuntu0.9.10.1 Package that ships the firefox branding
Linux gt-kjallari 2.6.31-20-generic #57-Ubuntu SMP Mon Feb 8 09:02:26 UTC 2010 x86_64 GNU/Linux

ok this will get you righted:

sudo apt-get --purge remove libswfdec-0.8-0; sudo apt-get --purge autoremove; mkdir ~/.mozilla/plugns; cd ~/.mozilla/plugns; wget http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.45.2.linux-x86_64.so.tar.gz; tar zxvf ./libflashplayer-10.0.45.2.linux-x86_64.so.tar.gz; rm ./libflashplayer-10.0.45.2.linux-x86_64.so.tar.gz

Your system is 64bit so you can use the 64bit flash plugin. Its alpha but works well.

See how you go.

If you want to use it in chromium run:

sudo cp ~/.mozilla/plugins/libflashplayer.so /usr/lib/chromium-browser/plugins

Tanks.
I tried that but I get the same error.

Can you run:

dpkg -l | grep flash; dpkg -l | grep gnash; dpkg -l | grep swf; file ~/.mozilla/plugins/*

Thanks

Thanks.
I did install some add-blocker, don't remember the name, but when I am logged in as any other user, the add-blocker isn't working and every thing is ok. I only get this error when I try to run the adds and I also have problem playing some videos on youtube, which I don't have if I am logged in as some one else. The add blocker treats the videos as add's and I cant play them.

gunnar@gt-kjallari:/$ dpkg -l | grep flash; dpkg -l | grep gnash; dpkg -l | grep swf; file ~/.mozilla/plugins/*
/home/gunnar/.mozilla/plugins/*: ERROR: cannot open `/home/gunnar/.mozilla/plugins/*' (No such file or directory)

Did you not run the LONG command above. It will give you native 64bit flash and remove the current flash you have installed (32bit flash + 64bit nspluginwrapper)?

Sounds like one of your addons is causing the issue. I suggest you disable them all and enable them noe at a time to see what is causing the issue.

Tanks. I removed all installations and reinstalled. All works now.