How do I turn off the notification area identifier for keyboard layout?

Asked by Rocko on 2010-03-01

I have two keyboard layouts defined, and in the notification area applet there is an identifier for the current keyboard layout (saying, eg 'USA'). I don't want it; it takes up room and in any case it's unreadable because it's black on black (changing foregroundColor in gconf-editor doesn't help). So how do I disable this identifier?

I can't find any setting in gnome-keyboard-properties for this, and although gconf-editor has a setting for /desktop/gnome/peripherals/keyboard/indicator, there doesn't seem to be a flag to turn it off.

I'm using Lucid alpha 3 (gnome-media 2.29.91-0ubuntu1).

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Rocko
Solved:
2010-05-03
Last query:
2010-05-03
Last reply:
2010-03-01
Delan Azabani (azabani) said : #1

Right click on the indicator and see if there's an option to "Remove from Panel" or something along the lines of that.

Delan Azabani (azabani) said : #2

Right click on the indicator and see if there's an option to "Remove from Panel" or something along the lines of that.

Rocko (rockorequin) said : #3

The right click options are:

* Groups -> (Shows the two installed layouts)
* Keyboard preferences (launches gnome-keyboard-properties, which has no setting to disable the indicator)
* Show current layout

So, no luck there.

Rocko (rockorequin) said : #4

As per the bug, the answer is to run this from gnome-terminal (or set the key using gconf-editor):

gconftool-2 -s /desktop/gnome/peripherals/keyboard/general/disable_indicator -t bool true

and then log out and back in.

You may need to enable the proposed repo and update to get it to work (see https://wiki.ubuntu.com/Testing/EnableProposed).