Karmic boot freeze after crash -filesystem won't mount

Asked by Malinger_now on 2010-02-27

Full sys crash/lockup after crashing Ristretto with Karmic. Unable to get through boot process afterwards. On boot, "init:mountall main process (549) terminated with STATUS 1 general error mounting filenames."

Details: using latest (date 2.28.10) Ristretto on Karmic with XFCE4 and some gnome components. Ristretto used in caching mode, default 64mb. Box is 5 y.o. AMD32 on Albatron K18-II mb. Install of Karmic Server went smoothly last week, using full encrypt-partitions options. Event: running Ristretto while (maybe)Firefox was still running, ristretto was loading files on starting, with several big 1.5mb images. I may have clicked the "next-pic" arrow before the app had fully loaded the folder. On clivking, Ristretto went bugf**k, flashing black frames in stacatto rapid-fore, finally locking up the sys. Contl-Alt-Delete did nothing. No usual attempts to shutdown or logoff worked as k'board and mouse were unresponsive. Power-off of box, then restart was okay on through opening of system crypt-disk. Boot begins for around 25 seconds then halts with the message shown above. I am then able to go to cmd-line. Tried sudo apt, etc but can't get the thing to install anything or access the system in order to try repairs. Note that as a beginner with Linux and command-line, i don't know how to use Commands to get through any boot process successfully. Am a long-time MacOS9 user with moderate exposure to the Gates pus-bucket that came with the Latitude laptop. Maybe like to use one of my several Ubuntu installer CD's to effect repairs but the "repair" function of all CD's seems only to want to replace the system. I'd just like to reinstall xfce4 or full Gnome to see if this clears up the mindf**k. I htransferred all my stuff from broken Dell shi*box laptop (what a horrorshow piece of junk) to My new Karmic box so would appreciate any advice. Note that prior to this the Karmic install had taken safe-upgrades beautifully and was running great. Only other thing worth mentioning is that a few days ago, I uninstalled SElinux from Karmic and replaced it with "harden-environment" and its recommended pkgs. Thank you and esp thanks to Ubuntu for some great distro options!
 my e-mail is <rory_stubble [at] yahoo.com>

Why did you install server if you were going to use desktop apps like firefox?

I suggest you boot to live CD and fsck -a the partitions. You can see their names using:

sudo parted -l

This will hopefully resolve your issue. I cannot see any other issue amongst the immense text above. If you can clarify it without obscenities or trolling it would be appreciated.

Thanks

Malinger_now (rory-stubble) said : #2

actionparsnip, thank you for your reply. I have tried live-cd but since it is an encrypted hd access is not avail from the CD. I am able to get past my crypt pass during a hd boot and from cmd-line I tried fsck -a and about 100 other maybe-useful commands. fsck says no problems. The problems above remained. I did a server-install to avoid having extraneous stuff (games and such) installed. Also, I understand the crypt-partition server-install offers the most robust default security. Thanks again.

If you installed the server install then simply installed ubuntu-desktop you DID get all the games. I have no experience of encrypted disks and think they cause a hell of a lot more issues than the cure.

Maybe someone else can contribute.

Can you help with this problem?

Provide an answer of your own, or ask Malinger_now for more information if necessary.

To post a message you must log in.