which part of openoffice may still be running if every part of it is shut down?

Asked by Horst Seeger

the recent updates (24 February 2010) were not possible because always it seemed that a part of OpenOffice is still running. I even have shut down the PC several times. Even then I got the error message, that update is not possiblöe as OpenOffice is still running.
Which part of it could it be or is it a bug of OpenOffice?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Ryan Kavanagh
Last query:
Last reply:
Revision history for this message
Best Ryan Kavanagh (ryanakca) said :

From a terminal, you can run:
" ps aux | grep soffice.bin " to see if there are any components of open office running... If you see a line that has /usr/lib/openoffice/program/soffice.bin in it, it's one of them.

The " ps aux " part gets a list of processes while " grep soffice.bin " prints only the lines with "soffice.bin" in them.

Failing that, you could try going 'ps aux' to get a list all running processes and manually search for something. (You can us 'ps xU $USER' if you're the only human user, it'll only show processes that you're running, instead of all system processes..)

Last but not least, you can run 'killall -9 soffice.bin' to forcibly (!!) close/kill any running OpenOffice components. I must warn you that you will LOOSE all unsaved data in ALL open OpenOffice programs.

Revision history for this message
Horst Seeger (horstseeger) said :

the problem seems to be solved. After several times running "Killall -9 soffice.bin" still I got errormessages. But finally the Update Manager told me: "your system is up to date" and the alarm-icon disappeared from the panel.