Blue hue or solid green screen in video playback (regardless of player)

Asked by Mike Millman on 2010-02-24

Ok, I am experiencing a similar problem to the one in Question #7373, however, none of the solutions in that thread work for me.

When trying to playback DVDs, I experience 2 different problems depending on which player I use... This is what happens:

In totem (regardless of whether I use totem-gstreamer or totem-xine) I get no video playback... Audio plays fine, but the video is a SOLID green screen...

This is the case regardless of what I set video output to in "gstreamer-properties"... I have tried all available settings in there (and restarted after every change), and regardless of what I do in there, I get a solid green screen in totem.

OK, now in VLC:
If I leave the video output set to "default", I get this same solid green screen.

If I set the video output to "Xvideo Extension Video Output", I get the same solid green screen.

If I set the video output to "OpenGL Video Output", I get perfect and smooth DVD playback (and perfect colors), but the picture is somewhat pixelated and blocky and that is a bit undesirable.

If I set the video output to "X11 Video Output", I get perfect quality DVD playback... no pixelation at all and pretty much perfect quality. HOWEVER, the colors are severely messed up (almost as if the colors in the RGB field are switched around) with everything having a blue tint to it. Another problem is that when using this setting the playback tears and is somewhat choppy, especially in full screen (which I expect is because "X11 Video Output" is not accelerated as opposed to the "Xvideo Extension Video Output" which is accelerated I think).

I am running an IBM ThinkPad R32 with the ATI Mobility Radeon 7000 (or M6, or M6 LY, depending on the documentation) w/ 16mb of video ram.

I am using the open source radeon driver (with ati wrapper) and I'm running Ubuntu 9.04 Jaunty Jackelope.

It's also worth noting that I have tried a few other video players with the same results (including xine-ui).

It seems to me that it is most likely a problem with drivers or possibly codecs rather than with the video player(s) themselves since it seems to be the same case across the board.

I am not at my computer right now so any other information you might need, feel free to ask, and I will update tonight when I get to my computer.

Thank you ahead of time.

Also, my xorg.conf is as follows:
Section "Device"
 Identifier "radeon"
        Driver "ati"
        BusID "PCI:1:0:0"
 Option "AccelMethod" "XAA"
 Option "EnablePageFlip" "true"
 Option "TripleBuffer" "true"
        Option "AGPMode" "4"
 Option "DRI" "true"
 Option "AGPFastWrite" "yes"
 Option "RenderAccel" "true"
 Option "DynamicClocks" "true"
 Option "BIOSHotkeys" "true"
EndSection

Section "Monitor"
        Identifier "Generic Monitor"
 Option "DPMS"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Device "radeon"
        Monitor "Generic Monitor"
        DefaultDepth 16
        SubSection "Display"
                Depth 16
                Modes "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Mike Millman
Solved:
2010-02-25
Last query:
2010-02-25
Last reply:
2010-02-24
Tom (tom6) said : #1

Hi :)

The first thing to sort out at any install of Ubuntu is to work through the Medibuntu worksheet
https://help.ubuntu.com/community/Medibuntu
This should sort out all the codecs and everything and deal with the copyright issues for your country. I tend to keep all the non-free components but hope to free myself one day and go completely OpenSource. It might be different in the USA, if you are there you might need to take more care.

Since you have an Ati card you might then be able to sort the problem (if it hasn't already been fixed by Medibuntu) by typing this into the command-line

gstreamer-properties

click on the "Video" tab and change "Output" from "Auto" to "..(no Xv) .." Sorry i can't remember the exact phrase in there. This will make the Cpu do the work rather than the Gpu but it seems to work better that way for many Ati cards (such as mine). If you are using a laptop then it might mean you could re-arrange the bios so that none of your Ram is shelved off to the monitor but it might not work that way, i haven't played around with that yet.

It does sound more likely a codec or something issue so hopefully Medibuntu should fix it.

Good luck and regards from
Tom :)

Mike Millman (millman12345) said : #2

Tom, thank you for your quick response, however I have already tried the fix you suggested (as noted in my original post), and it did not work.

I have tried ALL of the suggestions located in question #7373, and none of them worked.

Also, I already followed the medibuntu worksheet to add support for encrypted dvds (and it seemed to work just fine since the DVDs are playing back just fine aside from the color issue).

Any other suggestions?

Tom (tom6) said : #3

Hi :)

From the Release Notes for Ubuntu 9.10
http://www.ubuntu.com/getubuntu/releasenotes/910#Window%20corruption%20with%20older%20ATI%20graphics%20cards
This was not easy to find but should be and i apologise for that although i have no control over that at all. "It was 'clearly on display' in the bottom of a locked filing cabinet in a disused lavatory with a sign on the door saying "Beware of the leopard""

I found that both the ati proprietary drivers and the OpenSource ati drivers all broke my system and i had to reinstall Ubuntu as i didn't know how to get it back to the default driver. Here is this guid about the OpenSource driver tho
https://help.ubuntu.com/community/RadeonDriver

I dont think this guide deals with the issue but it might be worth a quick glance
https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver

Sorry i can't seem to find anything useful here. It's annoying me because i am sure i read somewhere about exactly this issue and thought i would find it in community or official documentation under a title like "troubleshooting after install". Incidenatlly the Medibuntu page does address quite a few issues, not just dealing with encrypted dvds but i'm sure that you found the codecs section at the bottom of the page amongst other things.

Hopefully someone gets a nudge in the right direction from something in this post!
Good luck and regards from
Tom :)

Mike Millman (millman12345) said : #4

Tom,

In my xorg.conf, you'll notice that I actually have my "renderaccel" set to "true", and it doesn't seem to be causing any problems for me... Direct rendering seems to work fine, and I have all desktop effects turned off since it's just eye candy anyway and my computer is very old and not very powerful at all...

Anyway, I SORT OF fixed the problem...

I say sort of,because I still can't get my "X Window System (No Xv)" to work correctly without having blue tint.... but I DID get the XVideo output to work correctly with good performance and perfect colors!!!!

I'm not at my computer right now, so I can't give the exact procedure until I get home tonight, but the problem was that for some reason, when I set the output to "Xvideo", it detects two different devices (can't remember the names of them right now), and the first device (the device it uses by default) simply does not output any video whatsoever.... by forcing it to use the second device ("device=1" I believe) I get perfect quality and perfect color output!!!!

Unfortunately, it brings up a second problem:

No matter what I do in "gstreamer-properties", the settings don't stick when I open totem-gstreamer....

So what I'm doing now is using VLC to play the movies, and in the advanced settings in VLC, I can force it to use the xvideo output, and force it to use "device 1" as opposed to "device 0".

VOILA! I'm going to leave this problem open until I can get home tonight and post the exact solution!

Tom (tom6) said : #5

Hi :)

Superb, nicely done !!! Congrats. A work-around is better than nothing but i hope you get a good answer later. I seem to be using VLC a lot these days too. For me it solves a darkness issue since my monitor is quite old and slowly dying but also movies all seem to like showing people in dark clothing at night = perhaps that's just me getting old tho.

Thanks, good luck and regards from
Tom :)

Mike Millman (millman12345) said : #6

Ok, so I'm home now, and I am going to post what I've discovered...

I hope this helps someone... it may not help anyone, but this is the case for an IBM ThinkPad R32 with the ATI Mobility Radeon 7000 (or M6, or M6 LY)...

1. open a terminal
2. sudo gstreamer-properties
3. click video tab
4. set plugin to "X Window System (X11/XShm/Xv)"
5. set device to "Radeon Textured Video"... there are two different choices here, for me at least, the first one is "ATI Radeon Video Overlay", and the second is "Radeon Textured Video"... for me, the first choice absolutely does not work... just get a solid green (or sometimes solid blue) screen... I HAD to pick "Radeon Textured Video".
6. Click test to ensure that it works...
7. if it worked, click close
8. Restart your computer (or at least restart x with ctrl+alt+backspace [or if you are in 9.04, right-alt+print screen+k])
9. Test a video in totem-gstreamer

Theoretically, this should work (however, as I said before, for me the settings I make in gstreamer-properties don't seem to stick...)

If (like me), your changes didn't stick and you still get a solid green or blue screen in totem, use the work around that I did...

Install VLC if it isn't installed already (sudo apt-get install vlc)

Now, we are going to force VLC to use the settings that we forced gstreamer to use in the instructions above...

1. start vlc
2. click tools->preferences
3. this will bring up the SIMPLE preferences menu.. what we need is in the advanced preferences menu
4. at the bottom left corner of the preferences menu... click the little radio button under show settings that says "All"
5. the appearance of the preferences menu will now change completely to show advanced options
6. on the left side of the window, expand the "video" heading by clicking the little arrow to the left of it.
7. expand the heading that says "output modules" also by clicking the little arrow to the left of it
8. click the actual "output modules" heading... not the arrow, but the actual word itself
9. now set the "video output module" to "XVideo extension video output"
10. once that is set, look at the pane on the left again where you expanded "output modules" in step 7, click the last one in the list that just says "Xvideo"
11. now, where it says "XVideo adaptor number", change that from -1 (which is auto select), to 1 (which is the "Radeon Textured Video" device that we discussed earlier in the other set of instructions... setting this to -1 would be "autodetect", 0 would be "ATI Radeon Video Overlay", and 1 would be "Radeon Textured Video"... that is the [only] one that works for me.)
12. click "Save" at the bottom right hand of the preferences window
13. You're done!

Now VLC should be able to properly use the "Xv" method even if totem-gstreamer won't.

I hope this helps someone else who has the same problem I had.

It'd be really nice if I could figure out why the settings I set in gstreamer-properties don't seem to stick for when I open totem-gstreamer, but in the meantime, at least I can force VLC to use the properties that I want as an alternative method...

Mike Millman (millman12345) said : #7

Ok... so I'm going to update this one more time with the ACTUAL cause of the headaches:

The real problem is that I had my depth set to 16bpp as opposed to 24bpp... The reason is that on this card (the M6/7000/any other RV100 based chip), 16bpp gives MUCH better performance than 24bpp... therefore I made a custom xorg.conf using 16bpp...

That's all great and good... however the open source ati driver (at least the one in Jaunty) doesn't play well with Xv in 16bpp...

If I set my depth to 24bpp, I get perfect playback from both devices that I mentioned earlier (both "ATI video overlay" and "Radeon textured video")... as a matter of fact... with 24bpp depth on, the "ATI Video Overlay" (device="0") actually renders video much better than the Radeon Textured video (device="1") because it uses bicubic filtering and reduces screen tearing A LOT!!!!

It's really a catch-22... I can use 16bpp and get very good 3d performance with decent quality video playback (but with lots of tearing).
Or I can use 24bpp and get reduced 3d performance but with much better quality video playback (virtually no tearing)...

Quite a decision to make... I think I'll stick with the 24bpp and better video quality... i do much more video watching than I do 3d gaming anyway... besides... with 24bpp I can actually use desktop effects! (on 16bpp, desktop effects make my windows all fudged up).

Que sera sera I suppose...

I hope this thread can help other people with this same card!

Tom (tom6) said : #8

Wow!! i really hope you are able to go through the Answers section and perhaps help people with graphics issues. There is seldom anyone hear that has such advanced knowledge of graphics. We have great people on sound and other issues but xorg eludes most of us and graphics is a total mystery almost all of the time.

I noticed you helped in some other qquestions and that is very much appreciated too.

Good luck and regards from
Tom :)

Tom (tom6) said : #9

Hi :)

Have you been able to test the new Ubuntu 10.04 before it gets officially released?
http://www.ubuntulinux.org/testing/lucid/beta1
Trying it as a LiveCd or as an extra dual/multi-boot would be ideal. Developers and everyone are keen to try to iron out any problems before 10.04 gets officially released so you might find faster & more effective answers to your bug reports which would make 10.04 work better on your system for you

Thanks and regards from
Tom :)