Parpadeo de pantalla en ubuntu 9.10 con ATI 2400 HD

Asked by galileony on 2010-02-16

Tenia Ubuntu 9.04 y al actualizarlo a la 9.10 empezaron mis problemas, la calidad de la imagen excepcional pero parpadeaba cada vez que me desplazaba verticalmente, instale ati-driver-installer-10-1-x86.x86_64.run descargada de la pagina de ATI y sigue igual, la informacion del lspci es el siguiente:

00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:19.0 Ethernet controller: Intel Corporation 82562V-2 10/100 Network Connection (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc RV610 [Radeon HD 2400 XT]

Despues en el menu de inicio para seleccionar SO tengo lo siguiente:

Ubuntu 9.10, kernel 2.6.31-19-generic-pae (no se que es PAE)
Ubuntu 9.10, kernel 2.6.31-19-generic-pae Recovery mode
Ubuntu 9.10, kernel 2.6.31-19-generic
Ubuntu 9.10, kernel 2.6.31-19-generic Recovery mode
Ubuntu 9.10, kernel 2.6.28-14-generic
Ubuntu 9.10, kernel 2.6.28-14-generic Recovery mode
Windows XP

¿porque tengo tantas lineas? ¿como saber cual conviene y cuales no?

con glxinfo obtengo el siguiente resultado:

name of display: :0.0
X Error of failed request: BadRequest (invalid request code or no such operation)
  Major opcode of failed request: 156 (GLX)
  Minor opcode of failed request: 19 (X_GLXQueryServerString)
  Serial number of failed request: 15
  Current serial number in output stream: 15

El contenido de xorg.conf:

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
 DefaultDepth 24
EndSection

Section "Module"
 Load "glx"
EndSection

Section "Device"
 Identifier "Configured Video Device"
 Driver "fglrx"
EndSection

Question information

Language:
Spanish Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Jorge Suárez de Lis
Solved:
2010-02-16
Last query:
2010-02-16
Last reply:
2010-02-16
Jorge Suárez de Lis (ys) said : #1

Vamos por partes.

Primero, lo del PAE. Es una opción del núcleo para que los sistemas de 32 bits puedan usarse con más de 4GB de memoria RAM. Has debido instalar una Ubuntu de 32 bits en un sistema de 64 bits con bastante RAM (4GB o más), lo ha detectado y te ha instalado un núcleo con PAE.

Sin el PAE, usando un sistema de 32 bits, solo tendrás acceso a 3GB de memoria si no voy errado, aunque el núcleo se reserva el otro GB de forma que tampoco se desaprovecha del todo. Siempre es mejor que optes por instalar un sistema de 64 bits, obtendrás mucho mejor rendimiento que con el de 32 bits (ten en cuenta que con el PAE activado, aunque puedas usar los 4GB o más sin problema, tendrás todavía menos rendimiento).

Dicho esto, tienes varias versiones de núcleo instaladas, la 2.6.31-19 que es la última de Karmic y la 2.6.28-14 que es la de Jaunty, la versión anterior. Puedes desinstalar las que no quieras, aunque siempre es recomendable dejar al menos la versión actual y una vieja, por si las moscas. Cuando quieras eliminar uno, vete a Sistema > Administración > Gestor de paquetes Synaptic. Allí busca linux-image-2.6.28-14-generic (o la versión que sea), márcalo para desinstalar y aplica los cambios, así de simple.

Ahora, tema ATI. El driver más actual ya no soporta tu modelo de gráfica, el último que lo hace es de diciembre de 2009. Te recomiendo que desinstales el driver privativo de ATI (puedes hacerlo a través de Sistema > Administración >Controladores de hardware) y dejes el driver libre, que rendirá mucho mejor y te dará menos problemas (o al menos debería).

La próxima vez que compres una gráfica ten esto en cuenta... no puedo decir más.

Fabián Rodríguez (magicfab) said : #2

Por favor para asuntos distintos abran preguntas separadas.

PAE no se instala automáticamente. Si tiene más de 3GB conserve ese núcleo, de lo contrario no es necesario.

galileony (galileony) said : #3

Gracias por tu respuesta, me has aclarado varios puntos. En lo que a ATI se refiere, bueno en Controladores de hardware me pone lo siguiente: No se estan utilizando controladores privativos en este sistema, Controlador Grafico FGLRX para ATI/AMD y abajo del todo me pone que este controlador no esta activado, ¿entonces?

Best Jorge Suárez de Lis (ys) said : #4

Seguramente no hayas instalado los drivers creando los paquetes deb, y no reconoce que los has instalado tú manualmente. Mira en la documentación de donde te los has bajado cómo puedes desinstalarlos.

Por lo pronto, borrando el /etc/X11/xorg.conf deberían desactivarse.

Jorge Suárez de Lis (ys) said : #5

Por cierto, Fabián, no estoy seguro, pero creo que comenzando en Karmic detecta automáticamente si tienes 4GB de ram o más y te instala el núcleo con PAE si es así. No lo he comprobado, pero creo recordar que es así.

galileony (galileony) said : #6

En un foro me dijeron que resinstalara no se que (no me acuerdo), apartir de ahi no pude entrar al entorno grafico, entonces en el foro de ubuntu me aconsejaron que hicese lo siguiente para restablecerlo:

sudo apt-get update
sudo apt-get install libqtgui4
sudo sh ./ati-driver-installer-10-1-x86.x86_64.run --buildpkg Ubuntu/karmic (descargado de la pagina oficial de ATI)
sudo dpkg -i *

De esa manera pude acceder al sistema grafico, dejandolo tal y como estaba antes de desinstalar el sistema grafico
Despues de ahi todo igual, tal y como me lo dejo la actualizacion a la version 9.10 de Ubuntu, con parpadeo etc..
Acabo de darme cuenta que el teclado numerico del teclado no va, no se si es una circustancia relativa a los movimientos que he realizado o no, en fin.

Si borro el xorg.conf no tendre una hecatombe verdad? :-)

galileony (galileony) said : #7

Thanks Jorge Suárez de Lis, that solved my question.

Jorge Suárez de Lis (ys) said : #8

¿Estará el bloqueo numérico apagado? Vete a sistema » preferencias » teclado y en la pestaña "distribuciones" intenta seleccionar el modelo de teclado más adecuado.

Para lo de la ATI, yo te diría que probases a mover el /etc/X11/xorg.conf a otro sitio para que utilice los drivers libres. Si no arranca, siempre puedes volver a restaurar el archivo. Por ejemplo:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.viejo

Y reinicia. ¿Que no sale el entorno gráfico? (cosa rara) Pues lo vuelves a mover:

sudo mv /etc/X11/xorg.conf.viejo /etc/X11/xorg.conf