Cannot mount volume, external hard drive

Asked by jamesyazzie@comcast.net on 2010-02-16

Having trouble mounting an external hard drive. When I connect it to the computer a message pops up "Unable to mount the volume 'My passport' details says "$MFTMirr does not match $MFT (record0). Failed to mount 'dev/sdc1' ; Input/output error NTFS is either inconsistent, or there is a hardware fault," and it goes on... I'm unsure on how to proceed without further exasperation of the problem, should I use gedit or terminal on the /etc/fstab file to fix the problem?. Any suggestions?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Lustfield
Solved:
2010-02-21
Last query:
2010-02-21
Last reply:
2010-02-16

It sounds like your hard drive is dead or dying.

What I would suggest is this:
plug in the drive
dd if=/dev/sdc1 of=/home/USER/sdc1.dd

Then follow by mounting with this:
mkdir /mnt/drive
mount -o loop /home/USER/sdc1.dd /mnt/drive

Then you should hopefully be able to grab any information you need.

If I'm wrong and the drive is not dying, then we will need the full error.

Thanks Michael Lustfield, that solved my question.