Partition problem in Windows XP

Asked by Mikerjf

I tried to install Ubuntu 9.0.1 from the live cd to a computer running Windows XP Pro with an 80G hard drive. I got to step 4 (partitioning the hard drive) and selected the option to split the drive into equal parts. I hit the forward button and a window popped up with a partitioning message (couldn't read it) that lasted about 2 seconds (looked like it went to 100% and then the installer stalled on step 5 (the Forward button remained greyed out). The computer gave no indication it was doing anything so after about an hour I hit the quit button. When I restarted the computer it went through chkdisk and then booted into XP but my hard drive has been reduced to 40G and I can't see another partition. How do I get Ubuntu to complete the installation or get my hard drive capacity back?



Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Ishan A B Ambanwela (ishanaba) said :

Its better to read community document on partitioning and follow instructions.You ll understand how to do your own

Revision history for this message
thtsarjun (thtsarjun) said :

I think the problem might have occurred because of the filesystem you have specified say ex4, during installation. The above mentioned link works when you have ubuntu installed already and you can modify the partition using Gparted. Anyway, your problem seems to be something which has been encountered during installation.

I assume you had selected manual partitioning.
Here is how you you can achieve the partitioning without any trouble.

Choose manual partitioning, dont let it use the whole disk in case you want window to function normally.
There will be a colored bar where you can see 40 GB in Blue color used for Windows n other around 40 GB unused or other installation as ur installation last time caused the filesystem to be other than NTFS or FAT unreadable by windows and little amount of swap memory.

Select the 40 GB say sda1/2 , select the option format partition, and mount point root, filesystem ex3. proceed to next.
confirm formatting. (dont delete swap partition)
and your partition is created.
Next is import account from windows, click on the check box. It will import ur themes from windows accounts.
Thats it proceed to next.

In case you get stuck mail me the snapshot of ur selections.


Revision history for this message
Mikerjf (mikerjf) said :

I'm running Ubuntu from the live cd. I do in fact have an 80G hard drive. There is one "Filesystem" that contains the Ubuntu files (14G). There is another "43GB Filesystem" that contains all the Windows XP programs. Apparently most of the loading was completed but the installer hung up at step 5. How do I get it to finish?

Thanks for the above replies.


Revision history for this message
thtsarjun (thtsarjun) said :

When you boot what all options do you get ? Are you getting Ubuntu loader options ? If not repeat the installation again and DELETE the partition on which ubuntu is installed and then create another one by giving the size (80GB - window space+swp).
Format the new partition and create the mount point.

One suggestion is that if you are installing Ubuntu or any flavour of Linux, Please Experiment !! :)


Revision history for this message
Mikerjf (mikerjf) said :

     Ubuntu wasn't installed but the hard drive was divided in half. One half was windows, the other half was "unallocated". I downloaded a fresh ISO and created another CD (mine checked OK but it locked up the pc in the CD drive but worked fine in the DVD drive so I figured I'd try a fresh one).

     The new CD worked OK and I selected to install Ubuntu to the empty (unallocated) space. Everything worked OK. Then I tried to edit the Grub bootloader. I don't have a terminal in the accessories so I can't get to a command line. Then I tried to use the computer janitor and it asked me for a password. I hadn't entered one during setup as I was using automatic login. I left it blank and it told me the password was incorrect.

     I went to the recovery screen and changed my password to an actual password and rebooted. I still have no terminal and now I can log in to the janitor but I get an error message that says "Essential package dash is missing. There may be problems with apt sources.list or Packages files may be missing."

     How can I load the missing files?



Revision history for this message
Mikerjf (mikerjf) said :

The 1st problems solved. I'll post this as a new one.