Openoffice JRE broken on upgrade to 8.04

Created by marcobra (Marco Braida) on on 2008-05-05
Keywords:
openoffice java error broken 8.04 hardy

QUESTION:

Having upgraded to 8.04 I now start my file and get a java error thus when trying to view my db with a form, (well do actually anything):

"...The selected JRE is defective. Please select another version or install a new JRE and select it... Please install the openoffice.org-java-common package for this functionality."

So I've re-installed it as well as openoffice-base and still no joy. I uninstalled the Sun java 5 I had so now only Sun 1.6.0_06 and FSF 1.5.0 according to openoffice options > java

ANSWER:

Some users have reported that after an upgrade to hardy, the oopenoffice java configuration file becomes obsolete and doesn't get renewed ($HOME/.openoffice.org2/user/config/javasettings_Linux_x86.xml). That leaves java non-working by default in the openoffice shipped with hardy. The proposed workaround is to delete the file, since openoffice recreates it upon restart.

That solved the problem for another user of openoffice base, as can be seen in

https://answers.launchpad.net/ubuntu/+question/30914