HTTP error when trying to download

Asked by Zack on 2009-06-12

I'm trying to get a few things working with Ubuntu. I'm using Ubuntu 9.04 Jaunty and have successfully made it able to authenticate with Microsoft's Active Directory. Now, the problem I'm running into is that the kids that will be using these laptops have never had a login name or password at the school before, thus are inexperienced as how we function. We give them their own drives (H:\username##$). To get to their drives on Ubuntu, as of right now, they have to actually navigate the network and the server to get to their folder, which I don't really like considering they can see the pool of users. They can't actually get into the folders, but that's not the point. What I'd like to do is have it where when the student logs in with their credentials their drive is mounted automatically upon their login. Everything I've found to do that has been for single user machines only, and I don't really want Johnny mounting Billy's drive when he logs in.

Now, to the problem that concerns you. I was told that Ubuntu Tweak may be able to solve that issue for me, however I am unable to download and install it. I'm getting an error every time I try. The error I get is this:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com FE85409EEAB40ECCB65740816AF0E1940624A220
gpg: requesting key 0624A220 from hkp server keyserver.ubuntu.com
gpgkeys: HTTP fetch error 7: couldn't connect to hose
gpg: no valid OpenPGP data found
gpg: Total number processed 0

Now, I realize this may be out of your hands, considering it's from the ubuntu site it'self. However, I was thinking maybe someone had the same problem and could steer me in the right direction.

Thanks for your time

Zack

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Tweak Edit question
Assignee:
No assignee Edit question
Solved by:
Zack
Solved:
2009-06-24
Last query:
2009-06-24
Last reply:
2009-06-23

Unfortunately, I can't help you with the keyserver error, but you can download the most recent version of Ubuntu Tweak from GetDeb (http://www.getdeb.net). Then if you have it up and running, you can add UbuntuTweak's own PPA to your sources list, from the Third Party Repositories section.

Zack (mctiguez) said : #2

Okay cool. I'll give that a shot. Thanks!

junreyes (nujseyer) said : #3

Hello. I would just like to follow-up re this issue. Has anybody resolved this? I'm having the same error, and I can't through it. Any help would be appreciated. Thanks!

Aikiko (meriadoc-brandebouc) said : #4

I got nearly the same problem :

tom@tom-desktop:~$ sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com FE85409EEAB40ECCB65740816AF0E1940624A220
[sudo] password for tom:
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --recv-keys --keyserver keyserver.ubuntu.com FE85409EEAB40ECCB65740816AF0E1940624A220
gpg: requesting key 0624A220 from hkp server keyserver.ubuntu.com
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error
tom@tom-desktop:~$ ping keyserver.ubuntu.com
PING keyserver.ubuntu.com (91.189.94.173) 56(84) bytes of data.
64 bytes from esperanza.canonical.com (91.189.94.173): icmp_seq=1 ttl=128 time=30.5 ms
64 bytes from esperanza.canonical.com (91.189.94.173): icmp_seq=2 ttl=128 time=22.7 ms
64 bytes from esperanza.canonical.com (91.189.94.173): icmp_seq=3 ttl=128 time=22.9 ms
64 bytes from esperanza.canonical.com (91.189.94.173): icmp_seq=4 ttl=128 time=22.2 ms
^C
--- keyserver.ubuntu.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3003ms
rtt min/avg/max/mdev = 22.240/24.638/30.541/3.422 ms

Is the problem from Ubuntu keyserver, maybe better to contact them directly instead ?

Ding Zhou (tualatrix) said : #5

It may be Ubuntu keyserver's problem.Is it still like this?