suggestion: ability to change default DVD player e.g. from Totem to VLC.

Asked by manny on 2008-05-01

ability to change default DVD player e.g. from Totem to VLC.

Gnome 2.22 does not include it anymore (or got broken) and Ubuntu Tweak is an easier to use tool anyway, so it's a nice option.

Ubuntu-tweak as an all in one tool is perfect.

Even if gnome devs break more stuff in the future we can count on ubuntu-tweak

there 're a few guides in UF to fix the problem but not very easy to follow.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Tweak Edit question
Assignee:
No assignee Edit question
Last query:
2008-05-01
Last reply:
2008-11-20
Ding Zhou (tualatrix) said : #1

Thanks of your idea.
I consider to add this function in the future release.

Bruce Hobson (bruce-hobson) said : #2

 How to make VLC open when you insert a DVD

Some users may run into problems using Totem to play DVDs. Totem is the default program for DVD-playback in Hardy, and there is no obvious way to change it. A lot of tips that worked in previous versions no longer work. The main problem is that VLC does not register itself as a DVD-capable application. These steps will set VLC media player as your default DVD player.

Create a new directory, if it doesn't already exist, for our custom settings. At the console, type:

   mkdir ~/.local/share/applications

Copy the standard VLC settings file. Type:

   cp /usr/share/applications/vlc.desktop ~/.local/share/applications/vlc-dvd.desktop

Edit vlc-dvd.desktop. Type:

   gedit ~/.local/share/applications/vlc-dvd.desktop

Scroll down, and find the line that reads:

   Exec=vlc %U

Replace the above line with one of the following:

    1. (all you really need)

   Exec=vlc %f

    2. (recommended settings from ubuntuforums for better dvd playback)

   Exec=vlc --vout-filter deinterlace --deinterlace-mode blend --volume 512 %f

    3. (recommended settings from ubuntuforums for better dvd playback and automatic full screen playback)

   Exec=vlc --vout-filter deinterlace --deinterlace-mode blend --volume 512 --fullscreen %f

Save the file and close gedit, then open mimeapps.list. At the console, type:

   gedit ~/.local/share/applications/mimeapps.list

In most cases this will be a new (blank) file, and all you will need to do is paste in the following text. If mimeapps.list already exists, scroll down until you find the line that begins with «x-content/video-dvd» under the [Added Associations] heading, and change it to match the following text (or paste in the entire line if you couldn't find it).

   [Added Associations]
   x-content/video-dvd=vlc-dvd.desktop;totem.desktop;

Save the file and close gedit. To check that the settings have properly applied, from the Gnome menus go to Places → Home Folder, then from the file manager menus go to Edit → Preferences → Media, and «DVD Video» should be set to «Open VLC media player» (you should be able to choose between Totem/Move Player and VLC)

Can you help with this problem?

Provide an answer of your own, or ask manny for more information if necessary.

To post a message you must log in.