Ubuntu tweak doesn't launch on 12.10

Asked by Gerard Rocher Ros on 2013-02-01

After installing Ubuntu tweak in 12.10, on a Dell Vostro 1500, it doesn't start.
If I start it from the console I get the folowing message:

compizconfig - Info: Backend : ini
compizconfig - Info: Integration : true
compizconfig - Info: Profile : default

(ubuntu-tweak:3123): Gtk-ERROR **: GtkBox child GtkTreeView minimum width: -1 < 0 for height 356

I couldn't find any information about this error, so I ask it here.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Tweak Edit question
Assignee:
No assignee Edit question
Solved by:
Ding Zhou
Solved:
2013-02-03
Last query:
2013-02-03
Last reply:
2013-02-03
Ding Zhou (tualatrix) said : #1

Did you install the GNOME 3.6 or other third party sources?

Yes, I have gnome 3.6. i've uninstalled it and other related packages, including gnome-tweak-tools. But it doesn't solve the problem.

Ubuntu tweak starts in the first screen, saying "loading" but it doesn't go further. It disappears after.

Best Ding Zhou (tualatrix) said : #3

How do you uninstall GNOME 3.6? I think you should use ppa-purge to revert the original gnome packages.

Thanks Ding Zhou, that solved my question.

peter smout (psmouty) said : #5

Hi,
I know this is solved (and probally a bit naughty) but I am having the same issue WITHOUT gnome ppa, the error i get is:

(ubuntu-tweak:21744): Gdk-CRITICAL **: gdk_error_trap_pop_internal: assertion `trap != NULL' failed
[gtk][DEBUG] <function post_ui at 0x8cfeb1c>: (debug.py:182)
[gtk][DEBUG] args-1: <function func_wrapper at 0x9009d4c> (debug.py:184)
[gtk][DEBUG] <function post_ui at 0x8cfeb1c>: (debug.py:182)
[gtk][DEBUG] args-1: <function _confirm_deps at 0x9009d84> (debug.py:184)
[gtk][DEBUG] <function post_ui at 0x8cfeb1c>: (debug.py:182)
[gtk][DEBUG] args-1: <function on_find_object at 0x90234c4> (debug.py:184)
[gtk][DEBUG] <function post_ui at 0x8cfeb1c>: (debug.py:182)
[gtk][DEBUG] args-1: <function on_scan_finished at 0x9023534> (debug.py:184)
[gtk][DEBUG] <function post_ui at 0x8cfeb1c>: (debug.py:182)
[gtk][DEBUG] args-1: <function on_scan_error at 0x90235a4> (debug.py:184)
[gtk][DEBUG] <function post_ui at 0x8cfeb1c>: (debug.py:182)
[gtk][DEBUG] args-1: <function on_plugin_object_cleaned at 0x90236f4> (debug.py:184)
compizconfig - Info: Backend : gsettings
compizconfig - Info: Integration : true
compizconfig - Info: Profile : unity
Segmentation fault (core dumped)
 Any ideas?

Yosh (spmmoi) said : #6

I'm having same problem after going through the upgrade process from 12.04 LTS. Now I have 13.04, I upgraded to Gnome 3.8 also... and it won't launch either. I want to clean up the cache etc but now I can't any more. Hope there can be a fix soon.

peter smout (psmouty) said : #7

Hi,

I solved my problem (sorry should have come back and marked it here) by moving libkconfig.so (libkconfig4.so) at "/usr/lib/compizconfig/backends"
I moved into desktop so as if anything went wrong I could put it back!! (need to be root to move it!)

Hope this helps