Missing some tweak options

Asked by Kent Storbakken on 2010-10-14

I just installed Ubuntu-Tweak on Ubuntu 10.10 after upgrading from 10.04 and I wanted to change the window control buttons from the left to the right. But I'm missing Window Manager Settings and quite a few other menu options. Here's a screenshot: http://img52.imageshack.us/img52/2814/screenshot1mk.png
Why is this and how can I restore them?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Tweak Edit question
Assignee:
No assignee Edit question
Solved by:
Ding Zhou
Solved:
2010-10-18
Last query:
2010-10-18
Last reply:
2010-10-18
Ding Zhou (tualatrix) said : #1

I want to know the environment of your desktop, do you use GNOME?

Or run "env" under terminal, and give me the output:

Kent Storbakken (watupgroupie) said : #2

env output:

ORBIT_SOCKETDIR=/tmp/orbit-kent
SSH_AGENT_PID=1667
TERM=xterm
SHELL=/bin/bash
XDG_SESSION_COOKIE=9be3437260a871377da837e44bdc0546-1287095624.729761-1595357013
WINDOWID=81788933
HUSHLOGIN=FALSE
GNOME_KEYRING_CONTROL=/tmp/keyring-pMuKaf
GTK_MODULES=canberra-gtk-module
USER=kent
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:
SSH_AUTH_SOCK=/tmp/keyring-pMuKaf/ssh
SESSION_MANAGER=local/kent-laptop:@/tmp/.ICE-unix/1676,unix/kent-laptop:/tmp/.ICE-unix/1676
MAIL=/var/mail/kent
PATH=/home/kent/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/ps3dev/bin:/usr/local/ps3dev/ppu/bin:/usr/local/ps3dev/spu/bin:/usr/local/ps3dev/bin:/usr/local/ps3dev/ppu/bin:/usr/local/ps3dev/spu/bin
PWD=/home/kent
LANG=en_CA.UTF-8
PS3DEV=/usr/local/ps3dev
SPEECHD_PORT=7560
HOME=/home/kent
SHLVL=2
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
LOGNAME=kent
XDG_DATA_DIRS=/usr/share/gnome:/usr/local/share/:/usr/share/
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-4CIUl8X4yO,guid=fc934027a4195c4f432a3eaf00000028
LESSOPEN=| /usr/bin/lesspipe %s
WINDOWPATH=7
DISPLAY=:0.0
LESSCLOSE=/usr/bin/lesspipe %s %s
XAUTHORITY=/home/kent/.Xauthority
COLORTERM=gnome-terminal
_=/usr/bin/env

Hope it helps.

Ding Zhou (tualatrix) said : #3

OK ,thanks.

Have you enabled the "Auto Login"?

Kent Storbakken (watupgroupie) said : #4

Yes I do have Auto Login enabled. I'm having problems with bootup right now also if that helps, I have to always boot through recovery because I get xorg issues.

Best Ding Zhou (tualatrix) said : #5

So try to disable the Auto Login, then open Ubuntu Tweak again. See if it works, thanks.

Kent Storbakken (watupgroupie) said : #6

Thanks Tualatrix Chou, that solved my question.

Myzeus (myzeus) said : #7

I would like to re-open this bug. I am also affected and I got Auto login disabled under Gnome.

paolo@paolo-laptop:~$ env
ORBIT_SOCKETDIR=/tmp/orbit-paolo
SSH_AGENT_PID=1577
TERM=xterm
SHELL=/bin/bash
XDG_SESSION_COOKIE=be30974c54c6f6af5280511a00000019-1287472877.28837-2114022097
WINDOWID=106954756
GNOME_KEYRING_CONTROL=/tmp/keyring-r6ntEg
GTK_MODULES=canberra-gtk-module
USER=paolo
SSH_AUTH_SOCK=/tmp/keyring-r6ntEg/ssh
DEFAULTS_PATH=/usr/share/gconf/xsession.default.path
SESSION_MANAGER=local/paolo-laptop:@/tmp/.ICE-unix/1546,unix/paolo-laptop:/tmp/.ICE-unix/1546
USERNAME=paolo
XDG_CONFIG_DIRS=/etc/xdg/xdg-xsession:/etc/xdg
DESKTOP_SESSION=xsession
PATH=/home/paolo/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
PWD=/home/paolo
GDM_KEYBOARD_LAYOUT=it
LANG=en_US.utf8
GNOME_KEYRING_PID=1527
MANDATORY_PATH=/usr/share/gconf/xsession.mandatory.path
GDM_LANG=en_US.utf8
UBUNTU_MENUPROXY=libappmenu.so
GDMSESSION=xsession
SHLVL=1
HOME=/home/paolo
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
LOGNAME=paolo
XDG_DATA_DIRS=/usr/share/xsession:/usr/share/gnome:/usr/local/share/:/usr/share/
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-SZkwZ8Dp40,guid=e07bed533fe90810a66bedbb00000050
WINDOWPATH=7
DISPLAY=:0.0
XAUTHORITY=/var/run/gdm/auth-for-paolo-rAweXy/database
COLORTERM=gnome-terminal
_=/usr/bin/env

Ding Zhou (tualatrix) said : #8

Do you use the self-defined X Session?

Myzeus (myzeus) said : #9

I've added unity to my Ubuntu Desktop Edition to try the new interface. Tried once then i removed the unity related packages and set the Ubuntu Default X session

Ding Zhou (tualatrix) said : #10

Try to select the "Ubuntu Desktop" session or "GNOME" if it is available.

Myzeus (myzeus) said : #11

I did indeed and it works. Thanks.

I would like to re-open this bug. I am also affected and I got Auto login disabled .i don't understand your 2nd answer, i am totally new in linux. what is self-defined X Session, Ubuntu Desktop, GNOME & how to change this

ORBIT_SOCKETDIR=/tmp/orbit-babua
SSH_AGENT_PID=1638
TERM=xterm
SHELL=/bin/bash
XDG_SESSION_COOKIE=79388b19603da1c471e26c8600000009-1292477720.58336-104902895
WINDOWID=81788932
GNOME_KEYRING_CONTROL=/tmp/keyring-hiVfka
GTK_MODULES=canberra-gtk-module
USER=babua
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:
SSH_AUTH_SOCK=/tmp/keyring-hiVfka/ssh
DEFAULTS_PATH=/usr/share/gconf/xsession.default.path
SESSION_MANAGER=local/babua-desktop:@/tmp/.ICE-unix/1608,unix/babua-desktop:/tmp/.ICE-unix/1608
USERNAME=babua
XDG_CONFIG_DIRS=/etc/xdg/xdg-xsession:/etc/xdg
DESKTOP_SESSION=xsession
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
PWD=/home/babua
GDM_KEYBOARD_LAYOUT=us
LANG=en_IN.utf8
GNOME_KEYRING_PID=1589
MANDATORY_PATH=/usr/share/gconf/xsession.mandatory.path
GDM_LANG=en_IN.utf8
GDMSESSION=xsession
SHLVL=1
HOME=/home/babua
LANGUAGE=en_IN.utf8
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
LOGNAME=babua
XDG_DATA_DIRS=/usr/share/xsession:/usr/share/gnome:/usr/local/share/:/usr/share/
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-a7lRt3gzj5,guid=a8c07ce16276885e79822ad900000019
LESSOPEN=| /usr/bin/lesspipe %s
WINDOWPATH=7
DISPLAY=:0.0
LESSCLOSE=/usr/bin/lesspipe %s %s
XAUTHORITY=/var/run/gdm/auth-for-babua-2DQkaq/database
COLORTERM=gnome-terminal
_=/usr/bin/env

Ding Zhou (tualatrix) said : #13

@Tanmoy Kumar Thakur

When you select your username in login window, there will be three options below, the third one is Session Choose Option, Please choose "Ubuntu Desktop".

Rafay Rao (elegant-rao) said : #14

Ding Zhou (tualatrix) : thank you very much changing the interface option did it for me. keep rocking. \o/