How to get a working otheros.bld kernel 2.6.35 on PS3

Asked by Tim


For years, I'm using ubuntu on the ps3. Not because it is snappy, but because the ubuntu repository is so vast, it is a pleasure to test and try cutting edge OSS. This way I'm also able to use very light software for most of the tings. Even tuning upstart so that the total boottime is more like 15s.

However, the kernel on 10.04.1 is actually a bit buggy on the network side when a download starts in e.g. firefox. I found out by some luck that the 2.6.35 version from the linux kernel git repository is working like it should. It is also faster even - probable because me using different options here and there.

To further cut back the boottime, and also for fun :), I want the double kernel boot to be a single kernel boot with my own simple initramfs/initrd. Thus, the otheros.bld kernel would immediatly be the OS kernel followed by a mount on /dev/ps3da1 and a pivot_root/exec to the upstart init.

Happens to be that I'm out of luck here. The kernel boots fine from the ubuntu 10.4.1 otheros.bld, so I would assume that if I run the wrapper script, I would get a working otheros.bld. The ps3 however goes into a red-light flashing when booting with the created otheros.bld. Does someone know what needs to be done? Or how this can be debugged rather nicely? How is this done with the ubuntu 10.4.1 otheros.bld build? Is there a must-have in .config that I might have forgotten? Can I find that .config somewhere for the ubunti 10.4.1 otheros.bld?

Thx for helping,

Question information

English Edit question
Ubuntu PS3 Port Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Tim (aardbeiplantje) said :

Ah! I found out myself :-).

instead of doing:

  bash ./arch/powerpc/boot/wrapper -p ps3 vmlinux

and use the ./otheros.bld

I needed to be doing

  make zImage

and use the file ./arch/powerpc/boot/otheros.bld.

They differ in only a few 100 bytes, probably because the ./arch/powerpc/boot/zImage is a different one.

By total boottime is now 10s :-).