initial root password on ubuntu beta

Asked by Billy Lightfoot on 2009-01-27

I followed the Ubuntu ec2 starter guide and when trying to log into the instance it is asking me for the root password.. what is it or how do I find it???

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu on EC2 Edit question
Assignee:
No assignee Edit question
Last query:
2009-01-27
Last reply:
2009-02-11
Dulio Samayoa (dulios) said : #1

Greetings

https://help.ubuntu.com/community/EC2StartersGuide

You have to specify the key you generated in step 6 in "Installing the API tools". In this step if followed exactly you got a file named ec2-keypair.pem in the directory you were working.

ssh -i ec2-keypair.pem root@<external-host-name>

This way you will authenticate without a password.

If this doesn't help post he commands you typed and the message.

afrancis7 (ajfrancis35) said : #2

 I am having the same problem:

I am trying to login to an instance via keypair , it seems to connect - it returns the servers fingerprint- but it keeps asking for the root password.

Here's what I get

afrancis@ajf-ubuntu:~$ ec2-describe-instances

RESERVATION r-8069dae9 052325780344 default
INSTANCE i-09b43d60 ami-814aaee8 ec2-174-129-171-89.compute-1.amazonaws.com domU-12-31-38-00-45-04.compute-1.internal running 0 m1.small 2009-02-05T22:46:11+0000 us-east-1c aki-af14f0c6ari-ac14f0c5

******** I try to login: ********

afrancis@ajf-ubuntu:~$ ssh -i ec2-keypair.pem <email address hidden>

******* it seems to connect*******

The authenticity of host 'ec2-174-129-171-89.compute-1.amazonaws.com (174.129.171.89)' can't be established.
RSA key fingerprint is 0f:83:73:c4:9e:4b:c4:6e:fe:54:37:54:2b:39:a7:3a.
Are you sure you want to continue connecting (yes/no)? y
Please type 'yes' or 'no': yes
Warning: Permanently added 'ec2-174-129-171-89.compute-1.amazonaws.com,174.129.171.89' (RSA) to the list of known hosts.

******but it keeps asking for the root password.

<email address hidden>'s password:
Permission denied, please try again.
<email address hidden>'s password:

Why would ssh -i ask for a password ?

Any ideas?

Thanks

afrancis7

afrancis7 (ajfrancis35) said : #3

OK I got it working and and ssh -i logs in now .

The problem was i wasn't specifying the -k option when running ec2-run-instances.

for anyone else that it may help:

This works : ec2-run-instances ami-2e5fba -k ec2-keypair

This does not: ec2-run-instances ami-2e5fba
( it will start an instance , but with no keypair so you won't be able to login).

If you look at my post above , you will notice that in the output from "ec2-describe instances" , --right after the word 'running' there is no keypair specified -- so that's why it would n't let me log in.

afrancis7

Can you help with this problem?

Provide an answer of your own, or ask Billy Lightfoot for more information if necessary.

To post a message you must log in.