Support for t2 AWS instance types?

Asked by Patrick Mauro on 2014-10-16

It looks like all the available Marketplace and Public AMIs do not support t2 instance types.
Are there plans to include t2 in future builds?
If not, what is the reason they are not included?

Thanks,
-Patrick

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu on EC2 Edit question
Assignee:
No assignee Edit question
Last query:
2014-10-16
Last reply:
2014-10-17
Eric Hammond (esh) said : #1

The EC2 t2.micro instance type requires HVM AMIs. Reference this matrix:

  http://aws.amazon.com/amazon-linux-ami/instance-type-matrix/

Many AWS Marketplace products only build PV AMIs and not HVM, so you can only run them on instance types that support PV. Contact the vendor that publishes the AWS Marketplace AMI to request an HVM version.

Canonical does publish both PV and HVM AMIs for Ubuntu.

Try typing "hvm:ebs-ssd trusty" into the search form on this page:

  http://cloud-images.ubuntu.com/locator/ec2/

Can you help with this problem?

Provide an answer of your own, or ask Patrick Mauro for more information if necessary.

To post a message you must log in.