Cannot disable sriov mode once set to simple

Asked by Dan Krent on 2014-02-11

Hi,
I want to use SR-IOV for my Ubuntu 12.04 hvm instance. I see there is a bug #1274676 such that when enabled the networking cannot find an interface. We need this fixed as you know... but also when this is encountered there is no way to use the image in a VPC as I have not found no way to reset or change the sriov mode. An AMI can be made and launched outside of any VPC and that image will boot - but launching inside a VPC the image will attempt to use sriov and not be accessible as the network interface fails to start. The sriov "simple" attribute stays with the AMI and I have not found any way to remove it.

How do we disable the sriov mode or change it back to its original setting after setting it to "simple"?

I noticed the bug #1274676 a working example is shown using 10GE driver ixfbevf version 2.7.12-k but the standard image boots showing ixgbef version 2.2.0-k. I downloaded and installed the 2.11.3 version as described in Enabling Enhanced Networking yet it still shows version 2.2.0-k why is this?

Working example in bug: [ 0.979949] ixgbevf: Intel(R) 10 Gigabit PCI Express Virtual Function Network Driver - version 2.7.12-k
Failing version in 12.04 EC2 AMI: [ 2.369930] ixgbevf: Intel(R) 10 Gigabit PCI Express Virtual Function Network Driver - version 2.2.0-k

Why does the image use the olderversion of the ixgbevf driver and how do we get it to use the current version?

Thanks,
-Dan

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu on EC2 Edit question
Assignee:
No assignee Edit question
Last query:
2014-02-28
Last reply:
2014-02-26
Patrick (skyshard) said : #1

Doing `sudo update-initramfs -c -k all` after installing the driver worked for me.

See also: https://gist.github.com/CBarraford/8850424

'''
ubuntu@ip-10-0-0-10:~$ sudo ethtool -i eth0
driver: ixgbevf
version: 2.11.3
firmware-version: N/A
bus-info: 0000:00:03.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: no
supports-register-dump: yes
ubuntu@ip-10-0-0-10:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.3 LTS
Release: 12.04
Codename: precise
'''

Dan Krent (dan-krent) said : #2

Doing the `sudo update-initramfs -c -k all` after the modprobe is the key to making SR-IOV work for Ubuntu 12.04 HVM instance.
This is great! - and directly addresses bug #1274676

One question remains ... if one does want to turn SR-IOV off for an instance how is this done?

The question is about how to turn SR-IOV off... the main reason I needed to turn it off is because of the bug - resolved by the one line addition. Amazon needs to add this info to the instructions for "Enabling Enhanced Networking on Linux Instances in a VPC".

Does anyone know if there is a way to turn off or clear the sriov "simple" mode set via 'ec2-modify-instance-attribute <instance-id> --sriov simple' command?

Thanks!

Can you help with this problem?

Provide an answer of your own, or ask Dan Krent for more information if necessary.

To post a message you must log in.