problem building live cd with UCK

Asked by pico on 2007-11-27

Hi,
I want to use minibunto as starting point for a custom live CD.

After few step the building phase crash with this message (build.log)

Starting CD remastering on Tue Nov 27 10:30:38 CET 2007
Customization dir=/home/pico/tmp/customization-scripts
Mounting ISO image...
Unpacking ISO image...
Unmounting ISO image...
Mounting SquashFS image...
Unpacking SquashFS image...
Unmounting SquashFS image...
Copying customization scripts...
Copying resolv.conf...
Copying local apt cache, if available
Mounting X11 sockets directory to allow access from customization environment...
Creating user directory...
Copying X authorization file to chroot filesystem...
chroot: cannot run command `xauth': No such file or directory
Unmounting directory /home/pico/tmp/remaster-root/proc...
Unmounting directory /home/pico/tmp/remaster-root/sys...
Unmounting directory /home/pico/tmp/remaster-root/dev/pts...
Failed to merge X authorization file, error=127

Any idea??

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Mini Remix Edit question
Assignee:
No assignee Edit question
Last query:
2007-11-27
Last reply:
2007-12-24
belleke (davy-debel) said : #1

i have the same problem ...

are you using uck-gui, it should not work with minibuntu because minibuntu does not have all the X environment, try the uck-remaster-* scripts instead

Felix Haller (felixhaller) said : #3

When I start

sudo uck-remaster ubuntu-mini-remix-10.10-i386.iso

the following Error occurs:

...
...
...
Please choose customization action
1) Run package manager
2) Run console application
3) Continue building
Your choice (1..3)> 1
CHOICE='Run package manager'
Starting package application...

Failure
Unable to find any package manager application
Hit <RETURN> to continue...

Please choose customization action
1) Run package manager
2) Run console application
3) Continue building
Your choice (1..3)> 2
CHOICE='Run console application'
Starting console application...

Failure
Unable to find any console application
Hit <RETURN> to continue...

IWhat am I doing wrong?

Can you help with this problem?

Provide an answer of your own, or ask pico for more information if necessary.

To post a message you must log in.