Backport of Font version 0.70 to Maverick

Asked by adoa on 2011-01-28

Is there an easy possibility to use the font family version 0.70 or newer in Maverick Meerkat without upgrading to Natty Narwhal? (ppa, backports package ...)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Font Family Edit question
Assignee:
No assignee Edit question
Solved by:
adoa
Solved:
2011-02-03
Last query:
2011-02-03
Last reply:
2011-01-30
Paul Sladen (sladen) said : #1

Adoa: thank you for the suggestion! Lets do it! Bug #709980 should follow-on the tradition started in bug #650889. Perhaps we should aim to ensure the SRU proposal happens ~1 week after a new upload goes into the development release if there are no shop-stoppers.

adoa (adoa) said : #2

Yeah, let's do it! But I don't acually know how I can help you with that.

Paul Sladen (sladen) said : #3

adoa: I've (re-)done stable-release-update uploads to hardy, karmic, lucid, maverick (the first time I cheated and naughtily tried to re-use the previous bug report, which is why these ones end with a '2'). To do it properly it requires a new bug report each time.

In answer to your specific question, you can most certainly help:

  1. reminding that this should be done ~1 week after each update
  2. x4 (or as many as you have access to), testing that the uploaded versions waiting in *-proposed do work as advertised

Once those are done then they can it can be accepted into the respective *-updates repositories more speedily than this time around.

In the longer run, there's no reason why uploading should be restricted to myself or anyone else in particular. If you get bored and would like to learn how to get more involved and prepare the updates themselves (they are very simple, just lots of paperwork and a new header in the changelog, plus for each) then I'm quite happy to guide you through the process and to sponsor your uploads.

adoa (adoa) said : #4

So you already uploaded new packages to the *-proposed or to the
*-updates repositories? apt-get did not try to update the
ttf-ubuntu-font-family package. Not from “my” update server, nor on the
main update server (archive.ubuntu.com).

Will I have to get the proposed packages from a special server or just
wait until they hit “my” update server?

And I only have access to my own computer: Maverick+Gnome on a Laptop.
How am I supposed to test the package 4 times on only one computer?

Should we just do this counseling via e-mail or jabber? Launchpad does
not really seem appropriate for so many confusing questions.

adoa (adoa) said : #5

or irc?

adoa (adoa) said : #6

The maverick-proposed package works on my system. No problems have occurred for two days.