can't find any way to select or delete files

Asked by Bob Harvey on 2016-05-31

I am accumulating files in the Download directory, and thought it would be a good idea to clear it out. I can't find any way to do it.

I tried with the touch interface, and then with a mouse and keyboard. I expected to be able to select or highlight files in some way and then be able to delete them. I can't.

a single touch or click on a file attempts to open it, and does not leave it selected in any way. there are no buttons for selection and no file-operation menus at all.

how am I supposed to clear out the download directory? or, indeed, select files for copying or moving or renaming in any way?

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu File Manager App Edit question
Assignee:
No assignee Edit question
Last query:
2016-05-31
Last reply:
2016-05-31
Bob Harvey (bobharvey) said : #1

I have, of course, been able to clear out the directory from the command line. I just expected the file manager to have a way to manage files.

Do you want to simply empty the directory?

Bob Harvey (bobharvey) said : #3

In this instance, yes. But in general I might want to delete some but not all files, move files to another location, or rename files

(M10 tablet, OTA10.1m by the way)

Then drag the files you want out to somewhere else, then you can easily empty the folder with:

rm -r ~/Downloads/*

Or open the file manager and use the Select All option under the edit menu. Simple stuff, it's the same in Windows and Mac OS too......

Bob Harvey (bobharvey) said : #5

Edit menu? there is a 3-line (hamburger) menu, but it does not have any edit values.

Bob Harvey (bobharvey) said : #6

Hmm. Can't attach a screenshot to this question.

Bob Harvey (bobharvey) said : #7

On Tuesday, 31 May 2016 08:57:59 BST, actionparsnip
<email address hidden> wrote:

> Or open the file manager and use the Select All option under the edit
> menu. Simple stuff, it's the same in Windows and Mac OS too......

herewith the attachment by email. I see no edit menu style things

--
Sent using Dekko from my Ubuntu device

Upload the image to Imageshack or use Dropbox to make a URL of the image. Post the URL as an update on
https://answers.launchpad.net/ubuntu/+source/ubuntu-filemanager-app/+question/294637

Bob Harvey (bobharvey) said : #9

well, that would be http://i63.tinypic.com/1z65h51.png then

Bob Harvey (bobharvey) said : #10

and here it is after entering a password to unlock things http://i64.tinypic.com/28ta35.png

Bob Harvey (bobharvey) said : #11

and this is what is in the view menu http://i65.tinypic.com/14dljzp.png

Bob Harvey (bobharvey) said : #12

There is only one option under 'settings' and I already have it on http://i68.tinypic.com/2nqcsy8.png

Does CTRL + A not work?

Bob Harvey (bobharvey) said : #14

Nope. Tried that.

And anyway, suppose I only wanted to delete half of them?

sudo rm -r ~/Downloads/*

Bob Harvey (bobharvey) said : #16

>sudo rm -r ~/Downloads/*
See comment 2. Already did that, without having to invoke sudo.

I think this should turn into a bug. Thanks for all the time!

Yeah, does sound like a bug. Ubuntu phone is incredibly young so stuff like this may be missed.

Bob Harvey (bobharvey) said : #18

Well, that was painful.

Launchapd failed spectacularly when trying to turn this into a bug with 'create bug report'. So I had to report /that/ (https://bugs.launchpad.net/launchpad/+bug/1587487)

I was unable to enter any bugs at all for ubuntu-filemanager-app, so I had to report it elsewhere:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1587499

Lets see what happens.

Michal Predotka (mpredotka) said : #19

Press and hold on a file or a folder to see options. There should be 'Delete' there.

Bob Harvey (bobharvey) said : #20

Aye, that appeared on OTA11 (see the bug). Still only does one at a time, which is sub-optimal.

Can you help with this problem?

Provide an answer of your own, or ask Bob Harvey for more information if necessary.

To post a message you must log in.