Feedback on the Dell Vostro 5590

Asked by Florian on 2020-05-14

There are numerous issues with this laptop regarding Ubuntu 18.04…
I updated BIOS to the latest available.

At first, without any tweaks and basic updates for Ubuntu 18.04.03, there was no sound and sleeping mode didn't work. As a workaround, I installed kernel 5.3.18…

However, still no microphone, internal or through jack.

Since this model is certified, I guess it means it worked perfectly at some point :-).

If you've got any lead in on this subject

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
2020-05-14
Last reply:
2020-05-18
Rex Tsai (chihchun) said : #1

The platform is certified with a 5.0 osp1 kernel, please use the linux-oem-osp1 kernel to see if the problem still exists. Thanks

sudo apt install linux-oem-osp1

Lucas May Petry (lucasmp53) said : #3

I installed the linux-oem-osp1 package to get the Wi-fi working, but then sound stops working. At no point I was able to get the internal mic to work, although an external one works just fine.

Please check this out for a more detailed description of the problems I had:
https://askubuntu.com/questions/1198762/wireless-audio-not-working-on-dell-vostro-15-5590-with-ubuntu-18-04-3-lts

Can you help with this problem?

Provide an answer of your own, or ask Florian for more information if necessary.

To post a message you must log in.